ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dmitry Lysnichenko (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-18651) HDP-2.5 installation allows ZKFC to advertise version
Date Thu, 20 Oct 2016 16:22:58 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-18651?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Dmitry Lysnichenko updated AMBARI-18651:
----------------------------------------
    Fix Version/s: 2.5.0

> HDP-2.5 installation allows ZKFC to advertise version
> -----------------------------------------------------
>
>                 Key: AMBARI-18651
>                 URL: https://issues.apache.org/jira/browse/AMBARI-18651
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>            Reporter: Dmitry Lysnichenko
>            Assignee: Dmitry Lysnichenko
>             Fix For: 2.5.0
>
>         Attachments: AMBARI-18651.patch
>
>
> Previous to HDP-2.5.0.0, ZKFC was not included with hdp-select.  Therefore, the metainfo
for ZKFC used {{<versionAdvertised>false</versionAdvertised>}}.  It was recently
discovered that 2.5.0.0-1154+ has added this capability.
> * Change versionAdvertised
> * Add code to ZKFC python to hdp-select.  This code MUST check the stack_feature to ensure
that it is executed ONLY for HDP-2.5+



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message