ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-18630) For rolling upgrade of Kafka 0.10.0.1, set configs for backward compatibility
Date Wed, 19 Oct 2016 14:43:58 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-18630?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15588957#comment-15588957
] 

Hudson commented on AMBARI-18630:
---------------------------------

SUCCESS: Integrated in Jenkins build Ambari-branch-2.5 #170 (See [https://builds.apache.org/job/Ambari-branch-2.5/170/])
AMBARI-18630. For rolling upgrade of Kafka 0.10.0.1, set configs for (ncole: [http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=342a088d555ca9808167a3e4ed4dec98ff04e415])
* (edit) ambari-server/src/main/resources/stacks/HDP/2.4/upgrades/config-upgrade.xml
* (edit) ambari-server/src/main/resources/stacks/HDP/2.4/upgrades/upgrade-2.5.xml
* (edit) ambari-server/src/main/resources/stacks/HDP/2.3/upgrades/config-upgrade.xml
* (edit) ambari-server/src/main/resources/stacks/HDP/2.3/upgrades/upgrade-2.5.xml


> For rolling upgrade of Kafka 0.10.0.1, set configs for backward compatibility
> -----------------------------------------------------------------------------
>
>                 Key: AMBARI-18630
>                 URL: https://issues.apache.org/jira/browse/AMBARI-18630
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>            Reporter: Nate Cole
>            Assignee: Nate Cole
>            Priority: Critical
>             Fix For: trunk, 2.5.0, 2.4.2
>
>         Attachments: AMBARI-18630.patch
>
>
> In the 2.5 upgrade pack, the following properties need to be set
> {code}
> inter.broker.protocol.version=0.9.0.0
> log.message.format.version=0.9.0.0
> {code}
> after upgrade is done we should delete the inter.broker.protocol.version.
> Users should remove log.message.format.version once they update their clients.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message