ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-11639) Ambari Admin View URL does not get properly parsed for custom versions
Date Fri, 02 Sep 2016 21:12:21 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-11639?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15459601#comment-15459601
] 

Hudson commented on AMBARI-11639:
---------------------------------

FAILURE: Integrated in Jenkins build Ambari-trunk-Commit #5619 (See [https://builds.apache.org/job/Ambari-trunk-Commit/5619/])
AMBARI-11639: Ambari Admin View URL does not get properly parsed for (dili: [http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=24a50b7a26336c7d91a3623ce77d83e280f026a8])
* (edit) ambari-web/test/views/main/admin/stack_upgrade/version_view_test.js
* (edit) ambari-web/app/views/main/admin/stack_upgrade/versions_view.js
* (edit) ambari-web/test/router_test.js
* (edit) ambari-web/app/router.js


> Ambari Admin View URL does not get properly parsed for custom versions
> ----------------------------------------------------------------------
>
>                 Key: AMBARI-11639
>                 URL: https://issues.apache.org/jira/browse/AMBARI-11639
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-admin
>    Affects Versions: 2.1.0
>            Reporter: Jesus Alvarez
>            Assignee: Di Li
>             Fix For: trunk
>
>         Attachments: 0001-AMBARI-11639-Ambari-Admin-View-URL-does-not-get-prop.patch,
AMBARI-11639.patch
>
>   Original Estimate: 4h
>  Remaining Estimate: 4h
>
> When building a custom version of ADMIN VIEW jar with new version such as "2.1.0_custom",
the UI returns a 404 message upon redirect.
> Upon loading ambari-server (http://node1.bigdata:8080) for the first time, the URL is
redirected to:
> http://node1.bigdata:8080/views/ADMIN_VIEW/2.1.0_custom/INSTANCE/# , which returns a
404 missing page.
> If the URL is manually changed to http://node1.bigdata:8080/views/ADMIN_VIEW/2.1.0/INSTANCE/#
, the UI loads -- though links in ambari UI remain broken.
> This appears to be caused by 
> latestVersion = sortedMappedVersions[sortedMappedVersions.length-1];
> and ambari.service.load_server_version ; each parsing version string differently. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message