ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-18123) Ambari server start fails after upgrade with java.lang.NoSuchFieldError: IS_SECURITY_ENABLED
Date Thu, 11 Aug 2016 19:18:20 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-18123?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15417777#comment-15417777
] 

Hudson commented on AMBARI-18123:
---------------------------------

FAILURE: Integrated in Ambari-trunk-Commit #5509 (See [https://builds.apache.org/job/Ambari-trunk-Commit/5509/])
AMBARI-18123 Ambari server start fails after upgrade with (dsen: [http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=3cc479e300a95870980cbd5ade7896a2dabd9343])
* contrib/views/hive/pom.xml
* contrib/views/hive-next/pom.xml
* ambari-server/pom.xml


> Ambari server start fails after upgrade with java.lang.NoSuchFieldError: IS_SECURITY_ENABLED
> --------------------------------------------------------------------------------------------
>
>                 Key: AMBARI-18123
>                 URL: https://issues.apache.org/jira/browse/AMBARI-18123
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server, ambari-views
>    Affects Versions: 2.4.0
>            Reporter: Dmytro Sen
>            Assignee: Dmytro Sen
>            Priority: Blocker
>             Fix For: 2.4.0
>
>         Attachments: AMBARI-18123.patch
>
>
> ambari-server --hash
> dcb6d19d2e34b76caae73bcfbd830388155c16dc
> Observed this issue after upgrade of Ambari server from 2.2.2.0 to 2.4.0.0 where after
running "ambari-server start" command, the logs throw below errors:
> {code}
> 05 Aug 2016 18:00:03,007 ERROR [main] AmbariServer:927 - Failed to run the Ambari Server
> java.lang.NoSuchFieldError: IS_SECURITY_ENABLED
> 	at org.apache.jasper.compiler.JspRuntimeContext.<init>(JspRuntimeContext.java:197)
> 	at org.apache.jasper.servlet.JspServlet.init(JspServlet.java:150)
> 	at org.eclipse.jetty.servlet.ServletHolder.initServlet(ServletHolder.java:532)
> 	at org.eclipse.jetty.servlet.ServletHolder.doStart(ServletHolder.java:344)
> 	at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:64)
> 	at org.eclipse.jetty.servlet.ServletHandler.initialize(ServletHandler.java:793)
> 	at org.eclipse.jetty.servlet.ServletContextHandler.startContext(ServletContextHandler.java:265)
> 	at org.eclipse.jetty.webapp.WebAppContext.startContext(WebAppContext.java:1242)
> 	at org.eclipse.jetty.server.handler.ContextHandler.doStart(ContextHandler.java:717)
> 	at org.eclipse.jetty.webapp.WebAppContext.doStart(WebAppContext.java:494)
> 	at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:64)
> 	at org.eclipse.jetty.server.handler.HandlerCollection.doStart(HandlerCollection.java:229)
> 	at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:64)
> 	at org.eclipse.jetty.server.handler.HandlerWrapper.doStart(HandlerWrapper.java:95)
> 	at org.eclipse.jetty.server.Server.doStart(Server.java:282)
> 	at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:64)
> 	at org.apache.ambari.server.controller.AmbariServer.run(AmbariServer.java:616)
> 	at org.apache.ambari.server.controller.AmbariServer.main(AmbariServer.java:925)
> {code}
> Ambari classpath contains 2 jars with JspRuntimeContext.
> The failure is caused by in Hive view 
> [Loaded org.apache.jasper.compiler.JspRuntimeContext from file:/var/lib/ambari-server/resources/views/work/HIVE%7B1.5.0%7D/WEB-INF/lib/jasper-compiler-5.5.23.jar]
> JspRuntimeContext in this jar doesn't have field IS_SECURITY_ENABLED



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message