ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-18112) Fix spark.executor.extraLibraryPath to include native gpl library
Date Thu, 11 Aug 2016 22:02:21 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-18112?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15418014#comment-15418014
] 

Hadoop QA commented on AMBARI-18112:
------------------------------------

{color:red}-1 overall{color}.  Here are the results of testing the latest attachment 
  http://issues.apache.org/jira/secure/attachment/12823351/AMBARI-18112_v1.patch
  against trunk revision .

    {color:red}-1 patch{color}.  Top-level trunk compilation may be broken.

Console output: https://builds.apache.org/job/Ambari-trunk-test-patch/8389//console

This message is automatically generated.

> Fix spark.executor.extraLibraryPath to include native gpl library
> -----------------------------------------------------------------
>
>                 Key: AMBARI-18112
>                 URL: https://issues.apache.org/jira/browse/AMBARI-18112
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>    Affects Versions: trunk, 2.5.0
>            Reporter: Weiqing Yang
>            Assignee: Weiqing Yang
>         Attachments: AMBARI-18112_v0.patch, AMBARI-18112_v1.patch
>
>
> When spark applications run in yarn cluster mode, there is an error from executors:
> ---------------------------------------------------------------------------------
> java.lang.UnsatisfiedLinkError: no gplcompression in java.library.path
> at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1889)
> at java.lang.Runtime.loadLibrary0(Runtime.java:849)
> at java.lang.System.loadLibrary(System.java:1088)
> at com.hadoop.compression.lzo.GPLNativeCodeLoader.<clinit>(GPLNativeCodeLoader.java:32)
> at com.hadoop.compression.lzo.LzoCodec.<clinit>(LzoCodec.java:71)
> at java.lang.Class.forName0(Native Method)
> .......
> org.apache.spark.executor.Executor$TaskRunner.run(Executor.scala:274)
> at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
> at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
> at java.lang.Thread.run(Thread.java:745)
> 16/08/08 12:59:03 ERROR LzoCodec: Cannot load native-lzo without native-hadoop.
> In the patch, it will set “spark.executor.extraLibraryPath /usr/hdp/current/hadoop-client/lib/native:/usr/hdp/current/hadoop-client/lib/native/Linux-amd64-64”
in spark-defaults.conf.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message