ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jayush Luniya (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-18030) Ambari quicklinks for Atlas points to url "http://<host>:<port>/#!/search?user.name=admin" by default, which seems incorrect
Date Tue, 16 Aug 2016 06:39:21 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-18030?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jayush Luniya updated AMBARI-18030:
-----------------------------------
    Resolution: Fixed
        Status: Resolved  (was: Patch Available)

> Ambari quicklinks for Atlas points to url "http://<host>:<port>/#!/search?user.name=admin"
by default, which seems incorrect
> ----------------------------------------------------------------------------------------------------------------------------
>
>                 Key: AMBARI-18030
>                 URL: https://issues.apache.org/jira/browse/AMBARI-18030
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>    Affects Versions: 2.4.0
>            Reporter: Nahappan Somasundaram
>            Assignee: Nahappan Somasundaram
>            Priority: Blocker
>             Fix For: 2.4.0
>
>         Attachments: rb50817.patch
>
>
> Ambari quick links for Atlas points to url http://<host>:<port>/#!/search?user.name=admin
by default, which seems incorrect because user can login with any user name depending on customer
auth configuration. But the url is sticking to user name "admin"; instead the url can be something
like this "http://<host>:<port>/login.jsp".
> ambari-server/src/main/resources/common-services/ATLAS/0.7.0.2.5/quicklinks/quicklinks.json:
>         "url": "%@://%@:%@/#!/search?user.name=%@",



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message