ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Onischuk (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-18028) Failed to load stack versions
Date Thu, 04 Aug 2016 16:47:20 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-18028?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Andrew Onischuk updated AMBARI-18028:
-------------------------------------
    Status: Patch Available  (was: Open)

> Failed to load stack versions
> -----------------------------
>
>                 Key: AMBARI-18028
>                 URL: https://issues.apache.org/jira/browse/AMBARI-18028
>             Project: Ambari
>          Issue Type: Bug
>            Reporter: Andrew Onischuk
>            Assignee: Andrew Onischuk
>             Fix For: 2.4.0
>
>         Attachments: AMBARI-18028.patch
>
>
> GET _api/v1/stacks?fields=versions/*_  
> and  
> GET _api/v1/clusters/c/stack_versions?fields=*&ClusterStackVersions/repository
> _version=2_  
> sometimes (ex. 2 of 10 requests) return
>     
>     
>     {
>       "status" : 500,
>       "message" : "org.apache.ambari.server.controller.spi.SystemException: Could not
load xml for Repository 2"
>     }
>     
> As this request is also used in Add Service Wizard, sometimes it fails deploy
> of new service.
> This issue is reproduced after visiting Hive View, when hive was not
> installed.
> STR:  
> 1\. Install cluster without hive.  
> 2\. Create Hive view.  
> 3\. Open Hive view, open Query section.
> Then try those two requests several times. There are no records in ambari-
> server.log about these requests.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message