ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nate Cole (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-17883) Installing Components After Registering A New Repository Uses The Wrong Version
Date Mon, 25 Jul 2016 20:26:20 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-17883?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Nate Cole updated AMBARI-17883:
-------------------------------
    Attachment: AMBARI-17883.patch

> Installing Components After Registering A New Repository Uses The Wrong Version
> -------------------------------------------------------------------------------
>
>                 Key: AMBARI-17883
>                 URL: https://issues.apache.org/jira/browse/AMBARI-17883
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>            Reporter: Nate Cole
>            Assignee: Nate Cole
>            Priority: Critical
>             Fix For: 2.4.0
>
>         Attachments: AMBARI-17883.patch, AMBARI-17883.patch
>
>
> STR:
> - Install HDP 2.4 with ZooKeeper
> - Register HDP 2.5 and distribute the stack to the hosts
> - Attempt to install another service, such as HDFS
> The version installed is 2.5, not 2.4:
> {code}
> 2016-07-20 14:13:10,155 - Package['unzip'] {'retry_on_repo_unavailability': False, 'retry_count':
5}
> 2016-07-20 14:13:10,270 - Skipping installation of existing package unzip
> 2016-07-20 14:13:10,271 - Package['curl'] {'retry_on_repo_unavailability': False, 'retry_count':
5}
> 2016-07-20 14:13:10,322 - Skipping installation of existing package curl
> 2016-07-20 14:13:10,323 - Package['hdp-select'] {'retry_on_repo_unavailability': False,
'retry_count': 5}
> 2016-07-20 14:13:10,374 - Skipping installation of existing package hdp-select
> 2016-07-20 14:13:10,520 - Using hadoop conf dir: /usr/hdp/current/hadoop-client/conf
> 2016-07-20 14:13:10,523 - Stack Feature Version Info: stack_version=2.4, version=2.4.2.0-236,
current_cluster_version=2.4.2.0-236 -> 2.4.2.0-236
> 2016-07-20 14:13:10,525 - Using hadoop conf dir: /usr/hdp/current/hadoop-client/conf
> 2016-07-20 14:13:10,531 - checked_call['rpm -q --queryformat '%{version}-%{release}'
hdp-select | sed -e 's/\.el[0-9]//g''] {'stderr': -1}
> 2016-07-20 14:13:10,547 - checked_call returned (0, '2.5.0.0-965', '')
> 2016-07-20 14:13:10,554 - Package['hadoop_2_5_0_0_965'] {'retry_on_repo_unavailability':
False, 'retry_count': 5}
> {code}
> Taking a look at my hosts:
> {code}
> [root@c6401 ~]# ll /usr/hdp/
> total 12
> drwxr-xr-x  6 root root 4096 Jul 19 19:48 2.4.2.0-236
> drwxr-xr-x 13 root root 4096 Jul 20 14:13 2.5.0.0-965
> drwxr-xr-x  2 root root 4096 Jul 20 14:13 current
> {code}
> {code}
> [root@c6401 ~]# ll /usr/hdp/current/ | grep zookeeper
> lrwxrwxrwx 1 root root 30 Jul 20 14:15 zookeeper-client -> /usr/hdp/2.4.2.0-236/zookeeper
> lrwxrwxrwx 1 root root 30 Jul 20 14:15 zookeeper-server -> /usr/hdp/2.4.2.0-236/zookeeper
> {code}
> {code}
> [root@c6401 ~]# rpm -q --queryformat '%{version}-%{release}' hdp-select | sed -e 's/\.el[0-9]//g'
> 2.5.0.0-965
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message