ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nate Cole (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AMBARI-17773) NFS_GATEWAY version reports incorrect in DB after EU
Date Mon, 18 Jul 2016 18:25:20 GMT
Nate Cole created AMBARI-17773:
----------------------------------

             Summary: NFS_GATEWAY version reports incorrect in DB after EU
                 Key: AMBARI-17773
                 URL: https://issues.apache.org/jira/browse/AMBARI-17773
             Project: Ambari
          Issue Type: Bug
          Components: ambari-server
            Reporter: Nate Cole
            Assignee: Nate Cole
            Priority: Blocker
             Fix For: 2.4.0


*Steps*
# Deploy 2.4.2 cluster with Ambari 2.2.2.0
# Upgrade Ambari to 2.4.0.0-892
# Perform EU to 2.5.0.0-1000 and let it complete

Run below SQL to verify version of NFS Gateway
{code}
select cl.cluster_name,hs.host_name,h.component_name,h.version,h.current_state from hostcomponentstate
h inner join hosts hs on hs.host_id=h.host_id inner join clusters cl on cl.cluster_id=h.cluster_id
where cl.cluster_name='cl1' and h.component_name like 'NFS%'
{code}

*Result*
{code}
cl1	host1	NFS_GATEWAY	2.4.2.0-258	STARTED
cl1	host2	NFS_GATEWAY	2.4.2.0-258	STARTED
cl1	host3	NFS_GATEWAY	2.4.2.0-258	STARTED
{code}

NFS_GATEWAY version shows as 2.4.2.0 instead of 2.5.0.0





--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message