ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-17579) fix spark.driver.extraLibraryPath to include native gpl library
Date Mon, 11 Jul 2016 01:39:10 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-17579?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15370064#comment-15370064
] 

Hudson commented on AMBARI-17579:
---------------------------------

FAILURE: Integrated in Ambari-trunk-Commit #5265 (See [https://builds.apache.org/job/Ambari-trunk-Commit/5265/])
AMBARI-17579. fix spark.driver.extraLibraryPath to include native gpl (smohanty: [http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=49396c4ed14ea0d507c60b7389a86fc55d68f74f])
* ambari-server/src/main/resources/common-services/SPARK2/2.0.0/package/scripts/params.py
* ambari-server/src/main/resources/common-services/SPARK/1.2.1/package/scripts/params.py


> fix spark.driver.extraLibraryPath to include native gpl library
> ---------------------------------------------------------------
>
>                 Key: AMBARI-17579
>                 URL: https://issues.apache.org/jira/browse/AMBARI-17579
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>    Affects Versions: 2.4.0
>            Reporter: Yesha Vora
>            Assignee: Weiqing Yang
>             Fix For: trunk, 2.4.0
>
>         Attachments: AMBARI-17579_v0.patch
>
>
> spark-shell command prints "Could not load native gpl library" error.
> {code}
> 16/07/05 12:07:06 WARN DomainSocketFactory: The short-circuit local reads feature cannot
be used because libhadoop cannot be loaded.
> 16/07/05 12:07:06 ERROR GPLNativeCodeLoader: Could not load native gpl library
> java.lang.UnsatisfiedLinkError: no gplcompression in java.library.path
> 	at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1889)
> 	at java.lang.Runtime.loadLibrary0(Runtime.java:849)
> 	at java.lang.System.loadLibrary(System.java:1088)
> 	at com.hadoop.compression.lzo.GPLNativeCodeLoader.<clinit>(GPLNativeCodeLoader.java:32)
> 	at com.hadoop.compression.lzo.LzoCodec.<clinit>(LzoCodec.java:71)
> 	at java.lang.Class.forName0(Native Method)
> 	at java.lang.Class.forName(Class.java:278)
> 	at org.apache.hadoop.conf.Configuration.getClassByNameOrNull(Configuration.java:2147)
> 	at org.apache.hadoop.conf.Configuration.getClassByName(Configuration.java:2112){code}
> We might need to add directory of libgplcompression in spark.driver.extraLibraryPath.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message