ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jayush Luniya (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (AMBARI-17244) Ambari 2.2.0 breaks backward compatibility with HDP 2.3.2 and below due to spark configs with hdp.version being removed
Date Wed, 15 Jun 2016 01:43:44 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-17244?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jayush Luniya resolved AMBARI-17244.
------------------------------------
    Resolution: Duplicate

> Ambari 2.2.0 breaks backward compatibility with HDP 2.3.2 and below due to spark configs
with hdp.version being removed
> -----------------------------------------------------------------------------------------------------------------------
>
>                 Key: AMBARI-17244
>                 URL: https://issues.apache.org/jira/browse/AMBARI-17244
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server, stacks
>    Affects Versions: 2.2.0
>            Reporter: Jayush Luniya
>            Assignee: Jayush Luniya
>            Priority: Critical
>             Fix For: 2.4.0
>
>
> In Ambari 2.2.0 following Spark properties were removed. This is because HDP 2.3.4 (Spark
1.5) self-detect hdp version (AMBARI-13899)
> noformat}
> spark.driver.extraJavaOptions -Dhdp.version= 
> spark.yarn.am.extraJavaOptions -Dhdp.version= 
> {noformat}
> However, removing these properties causes Ambari 2.2.0 + HDP 2.3.2 (Spark 1.4) to break
as those properties were required. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message