ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrii Tkach (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AMBARI-17125) Wizards operation gets into inconsistent state when logged into from a different browser
Date Wed, 08 Jun 2016 16:20:21 GMT
Andrii Tkach created AMBARI-17125:
-------------------------------------

             Summary: Wizards operation gets into inconsistent state when logged into from
a different browser
                 Key: AMBARI-17125
                 URL: https://issues.apache.org/jira/browse/AMBARI-17125
             Project: Ambari
          Issue Type: Bug
          Components: ambari-web
    Affects Versions: 2.4.0
            Reporter: Andrii Tkach
            Assignee: Andrii Tkach
            Priority: Critical
             Fix For: 2.4.0


Create user with the following usernames and roles : 
admin2 : ambari administrator 
clusteradmin : cluster administrator 

Step 1 : 
Login using user "admin". 
Start an action which creates a widget. ( Eg : Enabling HA/Adding hosts) 
Stop at step2 

Step 2 : 
Using a different browser session, login using user "admin" 
*Issue :* The widget popup is not shown. It doesn't even show the bar that say adding hosts
is in progress 

Step 3: 
Using a different browser session, login using user "admin2" 
* Accessing cluster user using : 
http://&lt;hostURL&gt;/#/main/host/add/step1 
shows the widget and the steps can go on. 

* Accessing using the default http://&lt;host&gt;:8080 shows the "Add hosts is in
progress bar" but the bar is not clickable 

* Most importantly, admin2 which is an admin user is not allowed to do admin operations like
"Manage ambari" (The button is not available in the UI. It was available before the widget
was started.) 

Step 4: 
Using a different browser session, login using user "clusteradmin"
* Accessing cluster user using : 
http://&lt;hostURL&gt;/#/main/host/add/step1 
shows the widget and the steps can go on. 

* Accessing using the default http://&lt;host&gt;:8080 shows the "Add hosts is in
progress bar" but the bar is not clickable 

This effectively means we can't start a widget operation and continue in a different browser
session. 

This doesn't go away on ambari server restart as well. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message