ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dmytro Sen (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-17111) ATS needs a dynamic dependency on Tez and Spark
Date Wed, 08 Jun 2016 07:51:21 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-17111?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Dmytro Sen updated AMBARI-17111:
--------------------------------
    Attachment:     (was: AMBARI-17111.patch)

> ATS needs a dynamic dependency on Tez and Spark
> -----------------------------------------------
>
>                 Key: AMBARI-17111
>                 URL: https://issues.apache.org/jira/browse/AMBARI-17111
>             Project: Ambari
>          Issue Type: Bug
>          Components: stacks
>    Affects Versions: 2.2.0
>            Reporter: Dmytro Sen
>            Assignee: Dmytro Sen
>            Priority: Blocker
>             Fix For: 2.4.0
>
>         Attachments: AMBARI-17111.patch
>
>
> Today, ATS can be installed without Tez, which is fine.
> However, when you add Tez, the client also needs to be installed on the host that has
ATS.
> Without it, the Tez View will not work and be unable to display detailed information.
> A similar problem exists for Spark, in which YARN shouldn't require Spark, but installing
Spark should require reconfiguring YARN and installing Spark client on the ATS box.
> This has existed from the time that Spark was added in Ambari 2.2.
> STR:
> Install a 3 node cluster with HDP 2.3 or higher.
> Install ATS on host 1
> After installation, add Tez service, and only install the Tez client on host 3
> The ATS host should also install Tez client.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message