ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-16651) Ambari 2.2.0 breaks backward compatibility with HDP 2.3.2 and below due to spark configs with hdp.version being removed
Date Wed, 15 Jun 2016 22:08:09 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-16651?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15332698#comment-15332698
] 

Hudson commented on AMBARI-16651:
---------------------------------

FAILURE: Integrated in Ambari-trunk-Commit #5085 (See [https://builds.apache.org/job/Ambari-trunk-Commit/5085/])
AMBARI-16651: Ambari 2.2.0 breaks backward compatibility with HDP 2.3.2 (jluniya: [http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=515e1e99212b4c4473ba9ccca6ca34bad6d54e4c])
* ambari-server/src/main/resources/common-services/SPARK/1.2.1/package/scripts/params.py
* ambari-server/src/main/resources/common-services/SPARK/1.5.2/metainfo.xml
* ambari-server/src/main/java/org/apache/ambari/server/upgrade/UpgradeCatalog240.java
* ambari-server/src/main/resources/common-services/SPARK/1.2.1/package/scripts/setup_spark.py
* ambari-server/src/test/python/stacks/2.2/SPARK/test_job_history_server.py
* ambari-server/src/test/java/org/apache/ambari/server/upgrade/UpgradeCatalog240Test.java
* ambari-server/src/main/resources/common-services/SPARK/1.2.1/metainfo.xml
* ambari-server/src/test/python/stacks/2.3/SPARK/test_spark_thrift_server.py
* ambari-server/src/main/resources/common-services/SPARK/1.4.1/metainfo.xml
* ambari-server/src/main/resources/common-services/SPARK/1.6.0/metainfo.xml
* ambari-server/src/test/python/stacks/2.2/SPARK/test_spark_client.py
* ambari-server/src/main/resources/common-services/SPARK/1.3.1/metainfo.xml
* ambari-server/src/main/resources/common-services/SPARK/1.2.1/configuration/spark-defaults.xml
* ambari-server/src/main/resources/common-services/SPARK/1.2.1/configuration/spark-javaopts-properties.xml


> Ambari 2.2.0 breaks backward compatibility with HDP 2.3.2 and below due to spark configs
with hdp.version being removed
> -----------------------------------------------------------------------------------------------------------------------
>
>                 Key: AMBARI-16651
>                 URL: https://issues.apache.org/jira/browse/AMBARI-16651
>             Project: Ambari
>          Issue Type: Bug
>          Components: stacks
>    Affects Versions: 2.4.0
>            Reporter: Jayush Luniya
>            Assignee: Jayush Luniya
>            Priority: Critical
>             Fix For: 2.4.0
>
>         Attachments: AMBARI-16651.trunk.patch
>
>
> In Ambari 2.2.0 few Spark properties were removed. This is because HDP 2.3.4 (Spark 1.5+)
self-detects hdp version.
> spark.driver.extraJavaOptions -Dhdp.version= 
> spark.yarn.am.extraJavaOptions -Dhdp.version= 
> However, removing these properties causes Ambari 2.2.0 + HDP 2.3.2 (Spark 1.4) to break
as those properties were required.
> This JIRA is to address this backward compatibility issue with HDP 2.3.2 and below caused
after upgrading to Ambari 2.2.0



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message