ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-16854) Failed to install packages for HDP 2.4 and 2.5
Date Wed, 25 May 2016 19:19:12 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-16854?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15300683#comment-15300683
] 

Hudson commented on AMBARI-16854:
---------------------------------

ABORTED: Integrated in Ambari-trunk-Commit #4922 (See [https://builds.apache.org/job/Ambari-trunk-Commit/4922/])
AMBARI-16854. Failed to install packages for HDP 2.4 and 2.5 (ncole) (ncole: [http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=6d15dc6cf1271977c7076d6c8244603819e082c0])
* ambari-server/src/main/java/org/apache/ambari/server/controller/internal/ClusterStackVersionResourceProvider.java
* ambari-server/src/test/java/org/apache/ambari/server/controller/internal/ClusterStackVersionResourceProviderTest.java


> Failed to install packages for HDP 2.4 and 2.5
> ----------------------------------------------
>
>                 Key: AMBARI-16854
>                 URL: https://issues.apache.org/jira/browse/AMBARI-16854
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>            Reporter: Nate Cole
>            Assignee: Nate Cole
>            Priority: Critical
>             Fix For: 2.4.0
>
>         Attachments: AMBARI-16854.patch
>
>
>     If there is a repository that is already installed and the version
>     is GREATER than the one trying to install, we must fail (until we can support that
via Patch Upgrades)
>     For example:
>     1. Install 2.3.0.0
>     2. Register and Install 2.5.0.0 (with or without package-version; it gets computed
correctly)
>     3. Register 2.4 (without package-version)
>     Installation of 2.4 will fail because the way agents invoke installation is to
>     install by name.  if the package-version is not known, then the 'newest' is ALWAYS
installed.
>     In this case, that would be 2.5.0.0.  2.4 is never picked up as the correct repository.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message