ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gautam Borad (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-16811) Kafka broker and RM start fail after Ambari upgrade while running JsonDecoder
Date Mon, 23 May 2016 12:09:12 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-16811?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Gautam Borad updated AMBARI-16811:
----------------------------------
    Attachment: AMBARI-16811.patch

> Kafka broker and RM start fail after Ambari upgrade while running JsonDecoder
> -----------------------------------------------------------------------------
>
>                 Key: AMBARI-16811
>                 URL: https://issues.apache.org/jira/browse/AMBARI-16811
>             Project: Ambari
>          Issue Type: Bug
>            Reporter: Gautam Borad
>            Assignee: Gautam Borad
>             Fix For: 2.4.0
>
>         Attachments: AMBARI-16811.patch
>
>
> Observed errors for Kafka brokers and RM restart after upgrading ambari from 2.2 to 2.4
in secure environment. 
> {code}
> Traceback (most recent call last):
>   File "/var/lib/ambari-agent/cache/common-services/YARN/2.1.0.2.0/package/scripts/resourcemanager.py",
line 287, in <module>
>     Resourcemanager().execute()
>   File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py",
line 254, in execute
>     method(env)
>   File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py",
line 675, in restart
>     self.start(env, upgrade_type=upgrade_type)
>   File "/var/lib/ambari-agent/cache/common-services/YARN/2.1.0.2.0/package/scripts/resourcemanager.py",
line 119, in start
>     setup_ranger_yarn() #Ranger Yarn Plugin related calls
>   File "/var/lib/ambari-agent/cache/common-services/YARN/2.1.0.2.0/package/scripts/setup_ranger_yarn.py",
line 68, in setup_ranger_yarn
>     component_user_keytab=params.rm_keytab if params.security_enabled else None
>   File "/usr/lib/python2.6/site-packages/resource_management/libraries/functions/setup_ranger_plugin_xml.py",
line 77, in setup_ranger_plugin
>     policy_user,is_security_enabled,component_user,component_user_principal,component_user_keytab)
>   File "/usr/lib/python2.6/site-packages/resource_management/libraries/functions/ranger_functions_v2.py",
line 144, in create_ranger_repository
>     response = self.get_repository_by_name_curl(component_user,component_user_keytab,component_user_principal,repo_name,
component, 'true')
>   File "/usr/lib/python2.6/site-packages/resource_management/libraries/functions/decorator.py",
line 82, in wrapper
>     return function(*args, **kwargs)
>   File "/usr/lib/python2.6/site-packages/resource_management/libraries/functions/ranger_functions_v2.py",
line 348, in get_repository_by_name_curl
>     response_json = json.loads(response_stripped)
>   File "/usr/lib/python2.6/site-packages/ambari_simplejson/__init__.py", line 307, in
loads
>     return _default_decoder.decode(s)
>   File "/usr/lib/python2.6/site-packages/ambari_simplejson/decoder.py", line 338, in
decode
>     raise ValueError(errmsg("Extra data", s, end, len(s)))
> ValueError: Extra data: line 1 column 12 - line 1 column 50 (char 12 - 50)
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message