ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marco Silva (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AMBARI-16778) Kafka state checks conflict with kafka-python pip package
Date Thu, 19 May 2016 17:42:13 GMT
Marco Silva created AMBARI-16778:
------------------------------------

             Summary: Kafka state checks conflict with kafka-python pip package
                 Key: AMBARI-16778
                 URL: https://issues.apache.org/jira/browse/AMBARI-16778
             Project: Ambari
          Issue Type: Bug
          Components: ambari-agent, ambari-server
    Affects Versions: 2.2.2
         Environment: Linux/Ubuntu 14.04
            Reporter: Marco Silva


Kafka is running but Ambari shows it is in INSTALLED state

Brokers are installed and runnig, but Brokers turns into the red state. 
ambari-server.logs shows that the Kafka broker turned into INSTALLED state briefly after starting
the brokers.

I've tried various things to debug the issue, until I stumbled upon this Post on the Hortonworks
Community Forum : 

https://community.hortonworks.com/questions/28296/kafka-is-running-but-ambari-shows-it-is-in-install.html

Solution: pip uninstall kafka-python

This should NOT be a conflict. kafka-python is one of the most used packages to use kafka
in a Python Environment. 


To Replicate: 

Setup clean ambari env
Install Kafka
Check Kafka is green
install kafka-python : pip install kafka-python
wait some time -> Kafka goes Red
uninstall kafka-python -> Kafka goes Green.





--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message