ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-15992) Ambari2400:Deploy fails at Confirm Hosts page due to Two-way SSL authentication failure
Date Wed, 20 Apr 2016 17:34:25 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-15992?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15250338#comment-15250338
] 

Hadoop QA commented on AMBARI-15992:
------------------------------------

{color:red}-1 overall{color}.  Here are the results of testing the latest attachment 
  http://issues.apache.org/jira/secure/attachment/12799758/AMBARI-15992.patch
  against trunk revision .

    {color:green}+1 @author{color}.  The patch does not contain any @author tags.

    {color:red}-1 tests included{color}.  The patch doesn't appear to include any new or modified
tests.
                        Please justify why no new tests are needed for this patch.
                        Also please list what manual steps were performed to verify this patch.

    {color:green}+1 javac{color}.  The applied patch does not increase the total number of
javac compiler warnings.

    {color:green}+1 release audit{color}.  The applied patch does not increase the total number
of release audit warnings.

    {color:green}+1 core tests{color}.  The patch passed unit tests in .

Test results: https://builds.apache.org/job/Ambari-trunk-test-patch/6562//testReport/
Console output: https://builds.apache.org/job/Ambari-trunk-test-patch/6562//console

This message is automatically generated.

> Ambari2400:Deploy fails at Confirm Hosts page due to Two-way SSL authentication failure
> ---------------------------------------------------------------------------------------
>
>                 Key: AMBARI-15992
>                 URL: https://issues.apache.org/jira/browse/AMBARI-15992
>             Project: Ambari
>          Issue Type: Bug
>            Reporter: Andrew Onischuk
>            Assignee: Andrew Onischuk
>             Fix For: 2.4.0
>
>         Attachments: AMBARI-15992.patch
>
>
> With Ambari2400 on above environment setup, all tests have failed at Confirm
> Hosts page.  
> We see the below error in ambari-agent logs
>     
>     
>     
>     Two-way SSL authentication failed. Ensure that server and agent certificates were
signed by the same CA and restart the agent. 
>     In order to receive a new agent certificate, remove existing certificate file from
keys directory. As a workaround you can turn off two-way SSL authentication in server configuration(ambari.properties)

>     Exiting..
>     ERROR 2016-04-11 21:26:55,952 Controller.py:194 - Unable to connect to: https://os-r6-jfiyhu-24-frmwork-repro-5.novalocal:8441/agent/v1/register/os-r6-jfiyhu-24-frmwork-repro-4.novalocal
>     Traceback (most recent call last):
>       File "/usr/lib/python2.6/site-packages/ambari_agent/Controller.py", line 147, in
registerWithServer
>         ret = self.sendRequest(self.registerUrl, data)
>       File "/usr/lib/python2.6/site-packages/ambari_agent/Controller.py", line 426, in
sendRequest
>         raise IOError('Request to {0} failed due to {1}'.format(url, str(exception)))
>     IOError: Request to https://os-r6-jfiyhu-24-frmwork-repro-5.novalocal:8441/agent/v1/register/os-r6-jfiyhu-24-frmwork-repro-4.novalocal
failed due to [Errno 185090050] _ssl.c:330: error:0B084002:x509 certificate routines:X509_load_cert_crl_file:system
lib
>     ERROR 2016-04-11 21:26:55,952 Controller.py:195 - Error:Request to https://os-r6-jfiyhu-24-frmwork-repro-5.novalocal:8441/agent/v1/register/os-r6-jfiyhu-24-frmwork-repro-4.novalocal
failed due to [Errno 185090050] _ssl.c:330: error:0B084002:x509 certificate routines:X509_load_cert_crl_file:system
lib
>     WARNING 2016-04-11 21:26:55,952 Controller.py:196 -  Sleeping for 29 seconds and
then trying again 
>     
> Artfacts can be found [here](http://linux-
> jenkins.qe.hortonworks.com/home/jenkins/qe-artifacts/os-r6-jfiyhu-24-frmwork-
> repro/ambari-frmwork-1460410683/artifacts/screenshots/com.hw.ambari.ui.tests.i
> nstaller.InstallHadoop/install/_11_21_26_54_Element_has_not_been_found_within_
> 1440_seconds__/)
> Same setup works fine on Ambari222. Could you please help take a look to
> figure out the issue



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message