ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "skrho (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AMBARI-15966) ambari-web 2.2.1 build error
Date Tue, 19 Apr 2016 08:28:25 GMT
skrho created AMBARI-15966:
------------------------------

             Summary: ambari-web 2.2.1 build error
                 Key: AMBARI-15966
                 URL: https://issues.apache.org/jira/browse/AMBARI-15966
             Project: Ambari
          Issue Type: Bug
            Reporter: skrho


Hi Everyone~~ 

Now I am building the ambari-web 2.2.1 version
My Environment is 
npm : 3.8.7
node : 4.4.3
brunch : 2.5.3

I have a problem when building .. 
I just command
# $apache-ambari-2.2.1-src/ambari-web]#brunch build -d

There is error message

  brunch:config Trying to load brunch-config +0ms
  brunch:config Trying to load config +5ms
19 Apr 08:26:28 - warn: config.files.stylesheets.defaultPaths was removed
19 Apr 08:26:28 - warn: config.files.templates.defaultPaths was removed
19 Apr 08:26:28 - error: Initialization error - You probably need to execute `npm install`
to install brunch plugins. SyntaxError: Setter must have exactly one formal parameter.
  at /usr/lib/node_modules/brunch/lib/plugins.js:101:17
  at Array.map (native)
  at deps.filter.dependency.map (/usr/lib/node_modules/brunch/lib/plugins.js:88:8)
  at packages.filter.plugins.map.plugin.filter.deps.filter.allPlugins.filter (/usr/lib/node_modules/brunch/lib/plugins.js:108:19)
  at Object.packages.filter.plugins.map.plugin.filter.deps.filter.exports.init.plugins.filter.map.preCompilers.push.teardownBrunch
[as init] (/usr/lib/node_modules/brunch/lib/plugins.js:131:20)
  at /usr/lib/node_modules/brunch/lib/watch.js:101:19


Please Help me~
What can I do that?

In advanced Thank you everyone






--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message