ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Nettleton (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-15861) NullPointerException in cluster deployment due to LogSearch PropertyProvider error
Date Wed, 13 Apr 2016 14:23:25 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-15861?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Robert Nettleton updated AMBARI-15861:
--------------------------------------
    Attachment: AMBARI-15861.patch

Uploaded initial patch

> NullPointerException in cluster deployment due to LogSearch PropertyProvider error
> ----------------------------------------------------------------------------------
>
>                 Key: AMBARI-15861
>                 URL: https://issues.apache.org/jira/browse/AMBARI-15861
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>    Affects Versions: 2.4.0
>            Reporter: Robert Nettleton
>            Assignee: Robert Nettleton
>            Priority: Critical
>             Fix For: 2.4.0
>
>         Attachments: AMBARI-15861.patch
>
>
> The initial checkin of the LogSearch REST integration code for Ambari Server appears
to have caused the following NullPointerException:
> java.lang.NullPointerException
> 	at org.apache.ambari.server.controller.logging.LoggingSearchPropertyProvider.populateResources(LoggingSearchPropertyProvider.java:98)
> 	at org.apache.ambari.server.controller.internal.ClusterControllerImpl.populateResources(ClusterControllerImpl.java:155)
> 	at org.apache.ambari.server.api.query.QueryImpl.queryForSubResources(QueryImpl.java:483)
> 	at org.apache.ambari.server.api.query.QueryImpl.queryForResources(QueryImpl.java:437)
> 	at org.apache.ambari.server.api.query.QueryImpl.execute(QueryImpl.java:217)
> This issue is caused by the fact that the LoggingSearchPropertyProvider does not add
a check for null when attempting to populate a resource with logging data.  
> This problem will occur in every cluster deployment where LogSearch isn't installed,
which is the common case at this point. 
> I'm working on a fix for this, and will be submitting a patch soon. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message