ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-15721) Ambari Admin module fails to build due to npm issues
Date Wed, 06 Apr 2016 00:45:25 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-15721?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15227455#comment-15227455
] 

Hudson commented on AMBARI-15721:
---------------------------------

FAILURE: Integrated in Ambari-branch-2.2 #596 (See [https://builds.apache.org/job/Ambari-branch-2.2/596/])
AMBARI-15721. Ambari Admin module fails to build due to npm issues. (yusaku: [http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=bc711e716afed88e1b3e6d642af9780f4d41aa96])
* ambari-admin/pom.xml


> Ambari Admin module fails to build due to npm issues
> ----------------------------------------------------
>
>                 Key: AMBARI-15721
>                 URL: https://issues.apache.org/jira/browse/AMBARI-15721
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-admin
>    Affects Versions: 2.2.2
>            Reporter: Yusaku Sako
>            Assignee: Yusaku Sako
>            Priority: Blocker
>             Fix For: 2.2.2
>
>         Attachments: AMBARI-15721.patch
>
>
> Seems like the npm registry started gzipping the content on package downloads.  Older
versions of npm cannot handle gzipped content, so "npm install" command fails.
> Ambari Admin in particular uses node 0.10.26, which ships with npm 1.4.3 that cannot
handle gzip.
> There have been numerous reports on the internet regarding this breakage (see https://github.com/npm/npm/issues/12196,
for example), but the npm registry still has not been fixed. 
> We'll go ahead and update the npm version used to build Ambari Admin.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message