ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yusaku Sako (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AMBARI-15721) Ambari Admin module fails to build due to npm issues
Date Tue, 05 Apr 2016 21:32:25 GMT
Yusaku Sako created AMBARI-15721:
------------------------------------

             Summary: Ambari Admin module fails to build due to npm issues
                 Key: AMBARI-15721
                 URL: https://issues.apache.org/jira/browse/AMBARI-15721
             Project: Ambari
          Issue Type: Bug
          Components: ambari-admin
    Affects Versions: 2.2.2
            Reporter: Yusaku Sako
            Assignee: Yusaku Sako
             Fix For: 2.2.2


Seems like the npm registry started gzipping the content on package downloads.  Older versions
of npm cannot handle gzipped content, so "npm install" command fails.
Ambari Admin in particular uses node 0.10.26, which ships with npm 1.4.3 that cannot handle
gzip.

There have been numerous reports on the internet regarding this breakage (see https://github.com/npm/npm/issues/12196,
for example), but the npm registry still has not been fixed. 
We'll go ahead and update the npm version used to build Ambari Admin.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message