ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dmitry Lysnichenko (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-15617) Express Upgrade (after Ambari upgrade) fails due to package import errors for cint
Date Tue, 29 Mar 2016 16:12:25 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-15617?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Dmitry Lysnichenko updated AMBARI-15617:
----------------------------------------
    Resolution: Fixed
        Status: Resolved  (was: Patch Available)

Committed
   34a076b..c990877  branch-2.2 -> branch-2.2
   6d668d2..d606234  trunk -> trunk


> Express Upgrade (after Ambari upgrade) fails due to package import errors for cint
> ----------------------------------------------------------------------------------
>
>                 Key: AMBARI-15617
>                 URL: https://issues.apache.org/jira/browse/AMBARI-15617
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>    Affects Versions: 2.2.2
>            Reporter: Dmitry Lysnichenko
>            Assignee: Dmitry Lysnichenko
>             Fix For: 2.2.2
>
>         Attachments: AMBARI-15617.patch
>
>
> ambari-server --hash
> 68d42abe1e91711c2a1d1b517887b56a452eeb19
> Build # ambari-server-2.2.2.0-343.x86_64
> *Steps*
> 1. Install HDP 2.3.4.0 with Ambari 2.2.0.0 (unsecure, non-HA cluster)
> 2. Upgrade Ambari to 2.2.2.0
> 3. Register Derg-M10 version and install the bits (2.4.2.0-69)
> 4. Start Express Upgrade
> Following upgrade tasks reported below cint package import error:
> a. Snapshot HBase
> b. Prepare HDFS
> c. Wait to leave Safemode
> d. Preparing Oozie Server on vs-dalm20todergm10-cint-3.novalocal
> *Error:*
> {code}
> 2016-03-28 06:11:07,263 - Task. Type: EXECUTE, Script: scripts/hbase_upgrade.py - Function:
take_snapshot
> Traceback (most recent call last):
> File "/var/lib/ambari-agent/cache/common-services/HBASE/0.96.0.2.0/package/scripts/hbase_upgrade.py",
line 41, in <module>
> HbaseMasterUpgrade().execute()
> File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py",
line 219, in execute
> method(env)
> File "/var/lib/ambari-agent/cache/common-services/HBASE/0.96.0.2.0/package/scripts/hbase_upgrade.py",
line 28, in take_snapshot
> import params
> File "/var/lib/ambari-agent/cache/common-services/HBASE/0.96.0.2.0/package/scripts/params.py",
line 26, in <module>
> from params_linux import *
> File "/var/lib/ambari-agent/cache/common-services/HBASE/0.96.0.2.0/package/scripts/params_linux.py",
line 27, in <module>
> from ambari_commons.str_utils import cbool, cint
> ImportError: cannot import name cint
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message