ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "DIPAYAN BHOWMICK (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-15530) Hive View: Execution of queries throws "No query to process."
Date Wed, 23 Mar 2016 09:16:25 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-15530?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15208116#comment-15208116
] 

DIPAYAN BHOWMICK commented on AMBARI-15530:
-------------------------------------------

I was able to reproduce it in local Development Environment(VMs)
Steps to reproduce:
1. Create a view instance with the following parameters(instance_name: hive_view_test, display
name: Hive View Test, description: Hive View Test)
2. Execute some queries in that view instance.
3. Delete 'hive_view_test' view instance
4. Create a view instance with the same properties as give in Step 1 (instance_name: hive_view_test,
display name: Hive View Test, description: Hive View Test) 
5. Execute a query
6. 1st execution passes and fetches result.
7. Change the query and execute it once more. This time the query does not fetch result and
the query in the editor changes to what is executed in step 5.
8. Change the query again and execute. This time we are greeted with the dreaded "No query
to execute" error 
Now it seems that we are not clearing the environment properly when the instance is deleted.

> Hive View: Execution of queries throws "No query to process."
> -------------------------------------------------------------
>
>                 Key: AMBARI-15530
>                 URL: https://issues.apache.org/jira/browse/AMBARI-15530
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-views
>    Affects Versions: 2.1.0
>            Reporter: DIPAYAN BHOWMICK
>            Assignee: DIPAYAN BHOWMICK
>             Fix For: 2.2.2
>
>
> It is seen this a few times but no consistent way to reproduce. The Hive view can get
into a state where when you hit Execute it says "No query to process." This happens when using
queries that you can execute other times.
> Nothing shows up in the HS2 log when you hit this so this might be purely happening on
the client side.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message