ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vitaly Brodetskyi (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-15514) 'ambari-server check database' failed
Date Tue, 22 Mar 2016 17:12:25 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-15514?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Vitaly Brodetskyi updated AMBARI-15514:
---------------------------------------
    Resolution: Fixed
        Status: Resolved  (was: Patch Available)

Committed to trunk and branch-2.2

> 'ambari-server check database' failed
> -------------------------------------
>
>                 Key: AMBARI-15514
>                 URL: https://issues.apache.org/jira/browse/AMBARI-15514
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>    Affects Versions: 2.2.2
>            Reporter: Vitaly Brodetskyi
>            Assignee: Vitaly Brodetskyi
>            Priority: Critical
>             Fix For: 2.2.2
>
>         Attachments: AMBARI-15514.patch
>
>
> *STR:*
> 1) Install and setup Ambari with ORACLE_JDK_8
> 2) Stop ambari-server
> 3) reset ambari-server
> 4) remove ambari-server from host
> 5) install ambari-server
> 6) setup ambari with ORACLE_JDK_7
> 7) start ambari-server
> 8) Stop ambari-server
> 9) reset ambari-server
> 10) remove ambari-server from host
> 11) install ambari-server
> 12) setup ambari with custom jdk (set wrong JDK location)
> 13) execute ambari-server check-database
> Result: 
> {code}
> Using python  /usr/bin/python
> Checking database
> Looking for available JDKs at /usr/jdk64
> Found: ['/usr/jdk64/jdk1.8.0_60', '/usr/jdk64/jdk1.7.0_67']
> Trying to use JDK /usr/jdk64/jdk1.8.0_60
> Selected JDK /usr/jdk64/jdk1.8.0_60
> ERROR: Unexpected ValueError: '' is not in list
> For more info run ambari-server with -v or --verbose option
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message