ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-15439) Add Upgrade Check for Kafka Kerb on HDP 2.2 -> 2.3+
Date Wed, 16 Mar 2016 16:26:33 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-15439?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15197608#comment-15197608
] 

Hudson commented on AMBARI-15439:
---------------------------------

SUCCESS: Integrated in Ambari-branch-2.2 #517 (See [https://builds.apache.org/job/Ambari-branch-2.2/517/])
AMBARI-15439 Add Upgrade Check for Kafka Kerb on HDP 2.2 -> 2.3+ (dsen) (dsen: [http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=345a52a27bfde11992f6f761d061d501e71b44d1])
* ambari-server/src/main/resources/stacks/HDP/2.2/upgrades/upgrade-2.4.xml
* ambari-server/src/main/java/org/apache/ambari/server/checks/CheckDescription.java
* ambari-server/src/main/resources/stacks/HDP/2.2/upgrades/upgrade-2.3.xml
* ambari-server/src/test/java/org/apache/ambari/server/checks/KafkaKerberosCheckTest.java
* ambari-server/src/main/resources/stacks/HDP/2.2/upgrades/nonrolling-upgrade-2.3.xml
* ambari-server/src/main/java/org/apache/ambari/server/checks/UpgradeCheckGroup.java
* ambari-server/src/main/resources/stacks/HDP/2.2/upgrades/nonrolling-upgrade-2.4.xml
* ambari-server/src/main/java/org/apache/ambari/server/checks/KafkaKerberosCheck.java


> Add Upgrade Check for Kafka Kerb on HDP 2.2 -> 2.3+
> ---------------------------------------------------
>
>                 Key: AMBARI-15439
>                 URL: https://issues.apache.org/jira/browse/AMBARI-15439
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>    Affects Versions: trunk, 2.2.2
>            Reporter: Dmytro Grinenko
>            Assignee: Dmytro Sen
>            Priority: Critical
>             Fix For: trunk, 2.2.2
>
>         Attachments: AMBARI-15439.patch, AMBARI-15439.patch.1
>
>
> Users that are running HDP 2.2 with Kafka and Kerberos is enabled, Kafka does is not
kerberized (because Kafka in HDP 2.2 did not support Kerb).
> In HDP 2.3, Kafka supports Kerb. 
> Therefore, when that HDP 2.2 user upgrades to HDP 2.3, their Kafka will get Kerberized
unintentionally.
> We need to an a pre-upgrade check to warn the user this will happen.
> - If cluster is HDP 2.2
> - If kerberos is enabled
> - If cluster is kerb'd
> - If target upgrade is to HDP 2.3 (or later)
> - Warning for both EU and RU upgrades
> It's a warning check, not a required check. Should inform the user that since their cluster
has Kerberos enabled, after upgrade, Kafka will be Kerberized.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message