ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sandy <sandy.wad...@gmail.com>
Subject Re: Requesting help regaring remote Debugging ambari-server
Date Wed, 01 Feb 2017 16:04:55 GMT
I'm using 5005 itself.  Refer attached screenshot in original mail.  Still
facing the issue.

On 01-Feb-2017 9:27 PM, "Jonathan Hurley" <jhurley@hortonworks.com> wrote:

> Which port are you trying to connect to? When starting Ambari Server with
> debug on, a different port is used for JDWP. You need to connect on port
> 5005. Here's an excerpt from the startup command:
>
> -Xdebug -Xrunjdwp:transport=dt_socket,address=5005
>
> On Feb 1, 2017, at 10:05 AM, Sandy <sandy.wadhwa@gmail.com<mailto:
> sandy.wadhwa@gmail.com>> wrote:
>
> I am trying to setup remote debugging for ambari server and have started
> the server using
>
> ambari-server start --debug
>
> But when I try to connect to server using eclipse, I am getting following
> exception:
>
> java.net.ConnectException: Connection refused (Connection refused)
> at java.net.PlainSocketImpl.socketConnect(Native Method)
> at java.net.AbstractPlainSocketImpl.doConnect(
> AbstractPlainSocketImpl.java:350)
> at java.net.AbstractPlainSocketImpl.connectToAddress(
> AbstractPlainSocketImpl.java:206)
> at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:
> 188)
> at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
> at java.net.Socket.connect(Socket.java:589)
> at java.net.Socket.connect(Socket.java:538)
> at java.net.Socket.<init>(Socket.java:434)
> at java.net.Socket.<init>(Socket.java:211)
> at org.eclipse.jdi.internal.connect.SocketTransportService$2.run(
> SocketTransportService.java:148)
> at java.lang.Thread.run(Thread.java:745)
>
> Attached screenshots of Eclipse Settings and Error Message.
>
> Can someone help me with what i might be missing.
>
> --
>
> Sandeep Kumar,
>  Mobile +91-9866507368
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message