ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Xavier Leong <xavier.le...@gmail.com>
Subject Upgrade path for extension stack eg 2.3.GlusterFS
Date Tue, 19 Apr 2016 02:17:23 GMT
Hi, I'm trying to extend a stack services similar to GlusterFS with sub
version of 2.4.YYY.

I don't seem to find a upgrade.xml file within GlusterFS stack version (eg
2.3.GlusterFS). How would the user upgrade the version let's say from
2.1.GlusterFS to 2.3.GlusterFS?

I can install the stack subverion 2.4.YYYY, but when I try to register new
version on top of it for upgrade, I get the following error:

An internal system exception occurred: There were no suitable upgrade packs
for stack HDP-2.4.YYY

Is subversion string type like GlusterFS supporting upgrade? If so, how
would one do an upgrade from 2.1.GlusterFS to 2.3.GlusterFS?

Thanks.

PS: Sorry for an earlier email that was send before complete.


Best regards,
-Xavier.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message