ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dmitro Lisnichenko <dlysniche...@hortonworks.com>
Subject Review Request 44264: Upgrade Warning on Non-Versioned Components
Date Wed, 02 Mar 2016 11:55:59 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/44264/
-----------------------------------------------------------

Review request for Ambari, Jonathan Hurley and Nate Cole.


Bugs: AMBARI-15260
    https://issues.apache.org/jira/browse/AMBARI-15260


Repository: ambari


Description
-------

When preparing to upgrade stack versions, the following warning is seen:

{code}
Reason: c6401.ambari.apache.org/ZKFC desired version: UNKNOWN, actual version: UNKNOWN
c6402.ambari.apache.org/ZKFC desired version: UNKNOWN, actual version: UNKNOWN
Failed on: c6401.ambari.apache.org,c6402.ambari.apache.org
{code}

We should be excluding non-versioned components from this check. Not sure which branches this
might exist in; I encountered this in trunk.


Diffs
-----

  ambari-server/src/main/java/org/apache/ambari/server/events/listeners/upgrade/StackVersionListener.java
9d989f1 
  ambari-server/src/test/java/org/apache/ambari/server/events/listeners/upgrade/StackVersionListenerTest.java
aa405ae 

Diff: https://reviews.apache.org/r/44264/diff/


Testing
-------

mvn clean test


Thanks,

Dmitro Lisnichenko


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message