ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bil Bingham (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-14903) Ambari Metrics
Date Wed, 03 Feb 2016 16:57:40 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-14903?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Bil Bingham updated AMBARI-14903:
---------------------------------
    Affects Version/s:     (was: 0.1.0)
                       2.2.0
          Component/s:     (was: ambari-metrics)
                       ambari-agent

> Ambari Metrics
> --------------
>
>                 Key: AMBARI-14903
>                 URL: https://issues.apache.org/jira/browse/AMBARI-14903
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-agent
>    Affects Versions: 2.2.0
>         Environment: Hadoop with kafka brokers
>            Reporter: Bil Bingham
>            Priority: Minor
>
> Ambari Metrics Monitor status check for the kafka broker fails with : 
> DEBUG 2016-02-02 19:39:02,665 PythonReflectiveExecutor.py:47 - Running command reflectively
['/usr/bin/python2',
>  '/var/lib/ambari-agent/cache/common-services/KAFKA/0.8.1.2.2/package/scripts/kafka_broker.py',
>  'STATUS',
>  '/var/lib/ambari-agent/data/status_command.json',
>  '/var/lib/ambari-agent/cache/common-services/KAFKA/0.8.1.2.2/package',
>  '/var/lib/ambari-agent/data/structured-out-status.json',
>  'DEBUG',
>  '/var/lib/ambari-agent/tmp']
> DEBUG 2016-02-02 19:39:02,692 PythonReflectiveExecutor.py:61 - Reflective command failed
with exception:
> Traceback (most recent call last):
>   File "/usr/lib/python2.6/site-packages/ambari_agent/PythonReflectiveExecutor.py", line
55, in run_file
>     imp.load_source('__main__', script)
>   File "/var/lib/ambari-agent/cache/common-services/KAFKA/0.8.1.2.2/package/scripts/kafka_broker.py",
line 28, in <module>
>     from kafka import ensure_base_directories
> ImportError: cannot import name ensure_base_directories
> When kafka-python is installed as a python package. 
> the ams '/var/lib/ambari-agent/cache/common-services/KAFKA/0.8.1.2.2/package/scripts/kafka.py'
and '/usr/lib/python2.6/site-packages/kafka/consumer/kafka.py' conflict



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message