ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Amruta Borkar (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-13923) Ambari Blueprint deployment fails during HBase Client install: "TypeError: expected string or buffer"
Date Sun, 07 Feb 2016 18:51:39 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-13923?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Amruta Borkar updated AMBARI-13923:
-----------------------------------
    Attachment: AMBARI-13923-2.png
                AMBARI-13923-1.png

When trying to reproduce the error on 2.1.0 I am getting the output shown in the screenshot
AMBARI-13923-1.png , which shows that HBase Client is started, and does not log any errors.

I also tried to reproduce it on 2.2.0, with following two cases:
1. When used blueprint with empty configuration, I did not get any error and output was similar
to AMBARI-13923-1.png
2. When used blueprint with invalid entry for property "hbase_regionserver_heapsize" , I get
error as shows in attachment AMBARI-13923-2.png, which looks like a valid system error for
invalid input.
With both 2.1.0 and 2.2.0 I could not reproduce the error logged here. 
Are you still facing the same error? If yes, could you provide more information about reproducing
the same?

> Ambari Blueprint deployment fails during HBase Client install: "TypeError: expected string
or buffer"
> -----------------------------------------------------------------------------------------------------
>
>                 Key: AMBARI-13923
>                 URL: https://issues.apache.org/jira/browse/AMBARI-13923
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server, blueprints, stacks
>    Affects Versions: 2.1.0
>         Environment: HDP 2.3
>            Reporter: Hari Sekhon
>            Assignee: Amruta Borkar
>            Priority: Critical
>         Attachments: AMBARI-13923-1.png, AMBARI-13923-2.png
>
>
> When deploying a cluster using blueprints the install fails with the following exception:
> {code}
> Traceback (most recent call last):
>   File "/var/lib/ambari-agent/cache/common-services/HBASE/0.96.0.2.0/package/scripts/hbase_client.py",
line 80, in <module>
>     HbaseClient().execute()
>   File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py",
line 216, in execute
>     method(env)
>   File "/var/lib/ambari-agent/cache/common-services/HBASE/0.96.0.2.0/package/scripts/hbase_client.py",
line 32, in install
>     import params
>   File "/var/lib/ambari-agent/cache/common-services/HBASE/0.96.0.2.0/package/scripts/params.py",
line 26, in <module>
>     from params_linux import *
>   File "/var/lib/ambari-agent/cache/common-services/HBASE/0.96.0.2.0/package/scripts/params_linux.py",
line 106, in <module>
>     regionserver_xmn_size = calc_xmn_from_xms(regionserver_heapsize, regionserver_xmn_percent,
regionserver_xmn_max)
>   File "/var/lib/ambari-agent/cache/common-services/HBASE/0.96.0.2.0/package/scripts/functions.py",
line 34, in calc_xmn_from_xms
>     heapsize = int(re.search('\d+',heapsize_str).group(0))
>   File "/usr/lib64/python2.7/re.py", line 142, in search
>     return _compile(pattern, flags).search(string)
> TypeError: expected string or buffer
> {code}
> There is a similar bug AMBARI-5066 but that one was resolved in Ambari 1.5 and this is
Ambari 2.1
> Looking at the code it looks like it should be testing the heapsize_str variable is actually
a string before passing it to re.search in /var/lib/ambari-agent/cache/common-services/HBASE/0.96.0.2.0/package/scripts/functions.py,
or probably catch in an earlier calling method and raise the source issue to the user, ie
"you forgot to enter a value for parameter X", or just set a default value if none is passed.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message