ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lav Jain <lj...@pivotal.io>
Subject Ambari TRUNK build failing with Python 2.6
Date Wed, 17 Feb 2016 19:12:40 GMT
Current Ambari trunk build fails with Python 2.6 during the test phase
because one of the HBase tests is using unittest.SkipTest (only available
with Python 2.7)

<goog_1845097492>
https://github.com/apache/ambari/blob/trunk/ambari-server/src/test/python/stacks/2.0.6/HBASE/test_phoenix_queryserver.py#L21

We tried using Python 2.7 but building the Ambari RPM requires Python 2.6.
There are explicit references to python 2.6 in many places.

https://github.com/apache/ambari/blob/trunk/ambari-common/src/main/unix/ambari-python-wrap#L20
https://github.com/apache/ambari/blob/trunk/ambari-server/src/main/assemblies/server.xml

What is the general consensus on version of python that should be used for
building Ambari?

-- 

*Lav Jain*
*Pivotal Data*

ljain@pivotal.io <mmathew@pivotal.io>

510.579.0072

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message