ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Gergely <dgerg...@hortonworks.com>
Subject Re: Review Request 44064: Unusable configs after creating override
Date Fri, 26 Feb 2016 14:53:15 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/44064/#review120867
-----------------------------------------------------------


Ship it!




Ship It!

- Daniel Gergely


On febr. 26, 2016, 12:29 du, Sebastian Toader wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/44064/
> -----------------------------------------------------------
> 
> (Updated febr. 26, 2016, 12:29 du)
> 
> 
> Review request for Ambari, Daniel Gergely, Robert Levas, and Robert Nettleton.
> 
> 
> Bugs: AMBARI-15200
>     https://issues.apache.org/jira/browse/AMBARI-15200
> 
> 
> Repository: ambari
> 
> 
> Description
> -------
> 
> Ambari server keeps all versions of service configurations. When the UI requests all
service configution versions for a service it expects in the response an additional flag that
marks which ones are the active ones. Since this active flag is not stored in the database
the server works out this flag on demand based on the create time stamp, version of the service
config entity.
> 
> As part of AMBARI-15158 a bug has been introduce as it was assumed that there is only
one "current" service configuration version per service accross each service configuration
group.
> This is wrong assumption as there is always ine "current" service configuration version
per each configuration group for a service.
> 
> 
> Diffs
> -----
> 
>   ambari-server/src/main/java/org/apache/ambari/server/state/cluster/ClusterImpl.java
4faee0e 
>   ambari-server/src/test/java/org/apache/ambari/server/state/cluster/ClusterTest.java
4d8e13b 
> 
> Diff: https://reviews.apache.org/r/44064/diff/
> 
> 
> Testing
> -------
> 
> Manual testing: created 3 node cluster and tested the fix with multiple config groups
and service configs.
> 
> All ambari server unit tests completed fine (branch-2.2 and 2.2.1-main; trunk)
> 
> 
> Thanks,
> 
> Sebastian Toader
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message