ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "raju patel (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-14662) Unable to find current_version while trying to install BigInsights add-on services like BigSheets, BigSQL through Blueprint
Date Fri, 15 Jan 2016 05:57:39 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-14662?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15101245#comment-15101245
] 

raju patel commented on AMBARI-14662:
-------------------------------------


We are already using stack version in our blueprint:

  "Blueprints" : {
    "stack_name" : "BigInsights",
    "stack_version" : "4.1"
  }

However, while automation through rest api tries to find current_version as well

Code snipppet from /var/lib/ambari-agent/cache/stacks/BigInsights/4.1/services/BIGSQL/package/scripts/params.py

odp_stack_version_unformatted = str(config['hostLevelParams']['stack_version'])
odp_current_version   = str(config['hostLevelParams']['current_version'])

This is where it fails to find the current_version.
I tried to include current_version in ambari blueprint as mentioned below:

  "Blueprints" : {
    "stack_name" : "BigInsights",
    "stack_version" : "4.1",
    "current_version" : "4.1"
  }

However blueprint registration fails after including this additional current_version attribute.
Could you please suggest me any other way for passing the variable.

> Unable to find current_version while trying to install BigInsights add-on services like
BigSheets, BigSQL through Blueprint
> ---------------------------------------------------------------------------------------------------------------------------
>
>                 Key: AMBARI-14662
>                 URL: https://issues.apache.org/jira/browse/AMBARI-14662
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-agent, ambari-server
>    Affects Versions: 2.1.0
>            Reporter: raju patel
>            Priority: Blocker
>
> While trying to install BigInsights 4.1 value add-on services i.e BigSheets and BigSql
through ambari blueprint, it throws below error:
> odp_current_version = str(config['hostLevelParams']['current_version'])
>   File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/config_dictionary.py",
line 81, in __getattr__
>     raise Fail("Configuration parameter '" + self.name + "' was not found in configurations
dictionary!")
> resource_management.core.exceptions.Fail: Configuration parameter 'current_version' was
not found in configurations dictionary!
> Traceback (most recent call last):
>   File "/var/lib/ambari-agent/cache/stacks/BigInsights/4.1/services/BIGSHEETS/package/scripts/master.py",
line 688, in <module>
>     Master().execute()
>   File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py",
line 218, in execute
>     method(env)
>   File "/var/lib/ambari-agent/cache/stacks/BigInsights/4.1/services/BIGSHEETS/package/scripts/master.py",
line 172, in install
>     import params
>   File "/var/lib/ambari-agent/cache/stacks/BigInsights/4.1/services/BIGSHEETS/package/scripts/params.py",
line 29, in <module>
>     odp_current_version           = str(config['hostLevelParams']['current_version'])
>   File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/config_dictionary.py",
line 81, in __getattr__
>     raise Fail("Configuration parameter '" + self.name + "' was not found in configurations
dictionary!")
> resource_management.core.exceptions.Fail: Configuration parameter 'current_version' was
not found in configurations dictionary!



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message