ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jayush Luniya (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-14474) PHD Ambari from trunk fails at HBase install
Date Mon, 04 Jan 2016 23:48:40 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-14474?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15082038#comment-15082038
] 

Jayush Luniya commented on AMBARI-14474:
----------------------------------------

Thanks [~jaoki] for confirming. This should not affect branch-2.2. Changes in AMBARI-14430
would cause this because we did the stack cleanup to remove stack-version hardcodings but
the PHD.json would override it to the hardcoded value which mean with inheritance we would
end up having to update the RPM version in each release. With the patch, I removed hardcodings
from PHD.json as well.

> PHD Ambari from trunk fails at HBase install
> --------------------------------------------
>
>                 Key: AMBARI-14474
>                 URL: https://issues.apache.org/jira/browse/AMBARI-14474
>             Project: Ambari
>          Issue Type: Bug
>            Reporter: jun aoki
>            Assignee: Jayush Luniya
>         Attachments: AMBARI-14474.patch
>
>
> We have got an issue where Hbase Installation fails due to yum install error upon deployment
with PHD Ambari (from trunk)
> Execution of '/usr/bin/yum -d 0 -e 0 -y install 'hbase_3_0_*'' returned 1. Error: Nothing
to do
> (full log [1])
> We use PHD-3.3.2.0-2950-centos6.tar.gz and it contains a bunch of 3_3 files instead of
3_0.
> e.g. hbase_3_3_2_0_2950-1.1.2.3.3.2.0-2950.el6.noarch.rpm 
> I'm guessing we need to add 3_3 "packages" to pluggable_stack
> https://github.com/Pivotal-Hadoop/ambari/blob/trunk/ambari-common/src/main/python/pluggable_stack_definition/configs/PHD.json#L221
> [1] installation log
> {code}
> stderr:   /var/lib/ambari-agent/data/errors-73.txt
> Traceback (most recent call last):
>   File "/var/lib/ambari-agent/cache/common-services/HBASE/0.96.0.2.0/package/scripts/hbase_client.py",
line 80, in <module>
>     HbaseClient().execute()
>   File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py",
line 228, in execute
>     method(env)
>   File "/var/lib/ambari-agent/cache/common-services/HBASE/0.96.0.2.0/package/scripts/hbase_client.py",
line 34, in install
>     self.install_packages(env, params.exclude_packages)
>   File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py",
line 444, in install_packages
>     Package(name)
>   File "/usr/lib/python2.6/site-packages/resource_management/core/base.py", line 155,
in __init__
>     self.env.run()
>   File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line
158, in run
>     self.run_action(resource, action)
>   File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line
121, in run_action
>     provider_action()
>   File "/usr/lib/python2.6/site-packages/resource_management/core/providers/package/__init__.py",
line 49, in action_install
>     self.install_package(package_name, self.resource.use_repos, self.resource.skip_repos)
>   File "/usr/lib/python2.6/site-packages/resource_management/core/providers/package/yumrpm.py",
line 49, in install_package
>     shell.checked_call(cmd, sudo=True, logoutput=self.get_logoutput())
>   File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 70,
in inner
>     result = function(command, **kwargs)
>   File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 92,
in checked_call
>     tries=tries, try_sleep=try_sleep)
>   File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 140,
in _call_wrapper
>     result = _call(command, **kwargs_copy)
>   File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 291,
in _call
>     raise Fail(err_msg)
> resource_management.core.exceptions.Fail: Execution of '/usr/bin/yum -d 0 -e 0 -y install
'hbase_3_0_*'' returned 1. Error: Nothing to do
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message