ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-13514) Service deploy wizard is not always restored to the correct state If browser session is lost while deploy is running
Date Wed, 20 Jan 2016 13:46:39 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-13514?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15108565#comment-15108565
] 

Hadoop QA commented on AMBARI-13514:
------------------------------------

{color:red}-1 overall{color}.  Here are the results of testing the latest attachment 
  http://issues.apache.org/jira/secure/attachment/12783304/AMBARI-13514.patch
  against trunk revision .

    {color:green}+1 @author{color}.  The patch does not contain any @author tags.

    {color:red}-1 tests included{color}.  The patch doesn't appear to include any new or modified
tests.
                        Please justify why no new tests are needed for this patch.
                        Also please list what manual steps were performed to verify this patch.

    {color:green}+1 javac{color}.  The applied patch does not increase the total number of
javac compiler warnings.

    {color:green}+1 release audit{color}.  The applied patch does not increase the total number
of release audit warnings.

    {color:green}+1 core tests{color}.  The patch passed unit tests in ambari-web.

Test results: https://builds.apache.org/job/Ambari-trunk-test-patch/4984//testReport/
Console output: https://builds.apache.org/job/Ambari-trunk-test-patch/4984//console

This message is automatically generated.

> Service deploy wizard is not always restored to the correct state If browser session
is lost while deploy is running
> --------------------------------------------------------------------------------------------------------------------
>
>                 Key: AMBARI-13514
>                 URL: https://issues.apache.org/jira/browse/AMBARI-13514
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-web
>    Affects Versions: 2.1.0
>            Reporter: Sangeeta Ravindran
>            Assignee: Sangeeta Ravindran
>         Attachments: AMBARI-13514.patch
>
>
> Reproduction Steps: 
> 1.Select one or more services and click on "Deploy" button. While deploy is running,
kill the browser.
> 2. Restart web browser and login to ambari-server. The UI will go back to the service
deploy wizard review page.
> 3. Click on "Deploy" again and you will get an error indicating that you are trying to
add a service that is already installed.
> for e.g.
> org.apache.ambari.server.controller.spi.ResourceAlreadyExistsException: Attempted to
create a host_component which already exists: [clusterName=hdpcluster, hostName=myhost.mydomain.com
componentName=HDFS_CLIENT]
> This happens because the services have now either already been deployed or are in the
middle of deploying. 
> The only way to recover is to exit out of the wizard by clicking on the X at the right
hand top edge.
> Expected results: 
> Ambari should either retrieve the status of the deploy wizard to reflect the actual state
of deploy, or go back to the dash board if browser session is lost.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message