ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rahul Pathak (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-13341) Ambari refuses stack upgrade without NN HA and other requirements
Date Tue, 26 Jan 2016 17:30:39 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-13341?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15117598#comment-15117598
] 

Rahul Pathak commented on AMBARI-13341:
---------------------------------------

I cannot reproduce this issue in Ambari 2.2.0

I have successfully upgraded from HDP 2.2.9 to HDP 2.3.4 using Ambari 2.2.0

I has feature called Express Upgrade which allows one-shot upgrade taking downtime and without
having NN HA

> Ambari refuses stack upgrade without NN HA and other requirements
> -----------------------------------------------------------------
>
>                 Key: AMBARI-13341
>                 URL: https://issues.apache.org/jira/browse/AMBARI-13341
>             Project: Ambari
>          Issue Type: Improvement
>          Components: ambari-server
>    Affects Versions: 2.1.0
>         Environment: HDP 2.2
>            Reporter: Hari Sekhon
>
> Ambari refuses to upgrade HDP 2.2 stack => 2.3 for a cluster not running NN HA among
other things - which is very inconvenient for small test clusters  as NN HA can't be deployed
with less than 3 nodes for ZK quorum, blocking the upgrade entirely. Ambari should be able
to ignore this and just do the upgrade anyway. In fact, better yet, do a faster upgrade as
per AMBARI-11098.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message