ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nate Cole" <nc...@hortonworks.com>
Subject Re: Review Request 42310: Express Upgrade failed during restart of STORM components
Date Thu, 14 Jan 2016 18:10:02 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/42310/#review114518
-----------------------------------------------------------

Ship it!



ambari-server/src/main/java/org/apache/ambari/server/controller/internal/UpgradeResourceProvider.java
(lines 1452 - 1453)
<https://reviews.apache.org/r/42310/#comment175371>

    Maybe also have the type?  The id still isn't a great indicator.


- Nate Cole


On Jan. 14, 2016, 12:12 p.m., Jonathan Hurley wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/42310/
> -----------------------------------------------------------
> 
> (Updated Jan. 14, 2016, 12:12 p.m.)
> 
> 
> Review request for Ambari, Alejandro Fernandez, Dmitro Lisnichenko, and Nate Cole.
> 
> 
> Bugs: AMBARI-14670
>     https://issues.apache.org/jira/browse/AMBARI-14670
> 
> 
> Repository: ambari
> 
> 
> Description
> -------
> 
> When upgrading HDP 2.2 to 2.4, the configurations for the 2.3 stack are not applied.
> 
> Caused by:
> 
> {code}
> cat /grid/0/log/storm/storm.out
> 
> Exception in thread "main" java.lang.ExceptionInInitializerError
> 	at java.lang.Class.forName0(Native Method)
> 	at java.lang.Class.forName(Class.java:270)
> 	at clojure.lang.RT.loadClassForName(RT.java:2093)
> 	at clojure.lang.RT.load(RT.java:430)
> 	at clojure.lang.RT.load(RT.java:411)
> 	at clojure.core$load$fn__5066.invoke(core.clj:5641)
> 	at clojure.core$load.doInvoke(core.clj:5640)
> 	at clojure.lang.RestFn.invoke(RestFn.java:408)
> 	at clojure.lang.Var.invoke(Var.java:379)
> 	at backtype.storm.ui.core.<clinit>(Unknown Source)
> Caused by: java.lang.IllegalArgumentException: Field nimbus.seeds must be an Iterable
but was a class java.lang.String
> 	at backtype.storm.ConfigValidation$2.validateField(ConfigValidation.java:113)
> 	at backtype.storm.ConfigValidation$NestableFieldValidator.validateField(ConfigValidation.java:47)
> 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> 	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
> 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
> 	at java.lang.reflect.Method.invoke(Method.java:606)
> 	at clojure.lang.Reflector.invokeMatchingMethod(Reflector.java:93)
> 	at clojure.lang.Reflector.invokeInstanceMethod(Reflector.java:28)
> 	at backtype.storm.config$validate_configs_with_schemas.invoke(config.clj:118)
> 	at backtype.storm.config$read_storm_config.invoke(config.clj:123)
> 	at backtype.storm.ui.core__init.load(Unknown Source)
> 	at backtype.storm.ui.core__init.<clinit>(Unknown Source)
> 	... 10 more
> {code}
> 
> It appears as though {{nimbus.host}} was never converted to {{nimbus.seeds}} even though
it's defined in the upgrade pack:
> 
> {code}
> <execute-stage service="STORM" component="NIMBUS" title="Apply config changes for
Nimbus">
>     <task xsi:type="configure" id="hdp_2_3_0_0_nimbus_convert_nimbus_host_to_seeds"/>
> </execute-stage>
> {code}
> 
> {code:title=HDP 2.2 storm-site}
> "nimbus.host": "os-s11-3-hifgts-c10tom21unsecha-5.novalocal",
> {code}
> 
> {code:title=HDP 2.4 storm-site}
> "nimbus.host": "os-s11-3-hifgts-c10tom21unsecha-5.novalocal",
> "nimbus.seeds": "localhost",
> {code}
> 
> 
> Diffs
> -----
> 
>   ambari-server/src/main/java/org/apache/ambari/server/controller/internal/UpgradeResourceProvider.java
d0f226f 
>   ambari-server/src/main/java/org/apache/ambari/server/state/stack/UpgradePack.java e3155ba

>   ambari-server/src/main/java/org/apache/ambari/server/state/stack/upgrade/ConfigureTask.java
f196e0b 
>   ambari-server/src/main/java/org/apache/ambari/server/state/stack/upgrade/Task.java
60091a6 
>   ambari-server/src/main/resources/stacks/HDP/2.2/upgrades/nonrolling-upgrade-2.4.xml
012c629 
>   ambari-server/src/main/resources/stacks/HDP/2.2/upgrades/upgrade-2.4.xml 5aee69d 
> 
> Diff: https://reviews.apache.org/r/42310/diff/
> 
> 
> Testing
> -------
> 
> EU and RU from HDP 2.2 to 2.4 with Storm
> 
> 
> Thanks,
> 
> Jonathan Hurley
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message