ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dmitro Lisnichenko" <dlysniche...@hortonworks.com>
Subject Review Request 42071: Ambari not showing active/standby status for Resource manager when custom ports are used
Date Fri, 08 Jan 2016 15:37:45 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/42071/
-----------------------------------------------------------

Review request for Ambari, Sumit Mohanty and Vitalyi Brodetskyi.


Bugs: AMBARI-14593
    https://issues.apache.org/jira/browse/AMBARI-14593


Repository: ambari


Description
-------

ISSUE :

RM HA is enabled and Customer is using custom ports for ( 38088 instead of 8088 )

yarn.resourcemanager.webapp.address.rm1 ; rm1-ravi..com:38088
yarn.resourcemanager.webapp.address.rm2 : rm2-ravi..com:38088

On the YARN Summary page, Ambari is not showing which RM is active and which one is standby.

It shows like this. I will attach screen shot as well.

App Timeline Server	 Started
ResourceManager	 Started
ResourceManager	 Started
NodeManagers	3/3 Started

EXPECTED RESULTS :

Ambari should show which RM is active/standby even when custom ports are being used.


Diffs
-----

  ambari-server/src/main/java/org/apache/ambari/server/controller/internal/HttpProxyPropertyProvider.java
302a54b 
  ambari-server/src/test/java/org/apache/ambari/server/controller/internal/HttpPropertyProviderTest.java
154d125 

Diff: https://reviews.apache.org/r/42071/diff/


Testing
-------

mvn clean test


Thanks,

Dmitro Lisnichenko


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message