ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Onischuk (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AMBARI-14431) Agent becomes unresposive after version incompatible Exception
Date Fri, 18 Dec 2015 10:51:46 GMT
Andrew Onischuk created AMBARI-14431:
----------------------------------------

             Summary: Agent becomes unresposive after version incompatible Exception 
                 Key: AMBARI-14431
                 URL: https://issues.apache.org/jira/browse/AMBARI-14431
             Project: Ambari
          Issue Type: Bug
            Reporter: Andrew Onischuk
            Assignee: Andrew Onischuk
             Fix For: 2.4.0
         Attachments: AMBARI-14431.patch

While testing with perf cluster found this bug:  
Agent did not register with server due to version incompatible error and then
did not recover from this state, although the server side was fixed.  
If agent is not retrying, it should quit

    
    
    
    ERROR 2015-12-10 23:04:35,184 Controller.py:165 - Cannot register host with non compatible
agent version, hostname=perf-a-1.c.pramod-thangali.internal, agentVersion=2.2.0.0, serverVersion=2.1.3.0
    INFO 2015-12-10 23:04:35,184 Controller.py:392 - Registration response from perf-a-1.c.pramod-thangali.internal
was FAILED
    ERROR 2015-12-10 23:04:35,185 main.py:315 - Fatal exception occurred:
    Traceback (most recent call last):
      File "/usr/lib/python2.6/site-packages/ambari_agent/main.py", line 312, in <module>
        main(heartbeat_stop_callback)
      File "/usr/lib/python2.6/site-packages/ambari_agent/main.py", line 303, in main
        ExitHelper.execute_cleanup()
    TypeError: unbound method execute_cleanup() must be called with ExitHelper instance as
first argument (got nothing instead)
    





--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message