ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Olivér Szabó (JIRA) <j...@apache.org>
Subject [jira] [Updated] (AMBARI-14397) Cluster deployment with exported blueprint with stack advisor enabled doesn't work
Date Wed, 16 Dec 2015 15:18:46 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-14397?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Olivér Szabó updated AMBARI-14397:
----------------------------------
    Fix Version/s:     (was: 2.2.1)
                   2.3.0

> Cluster deployment with exported blueprint with stack advisor enabled doesn't work
> ----------------------------------------------------------------------------------
>
>                 Key: AMBARI-14397
>                 URL: https://issues.apache.org/jira/browse/AMBARI-14397
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>    Affects Versions: 2.2.0
>            Reporter: Olivér Szabó
>            Assignee: Olivér Szabó
>             Fix For: 2.3.0
>
>         Attachments: AMBARI-14397.patch
>
>
> 1. Deploy a cluster using the UI or a brand new blueprint
> 2. Once the cluster is up and running export the blueprint ( ?format=blueprint )
> 3. Deploy a new cluster using the previously exported blueprint. In cluster creation
template enable the use of stack advisor:
> {code:java}
> "config_recommendation_strategy" : "ALWAYS_APPLY"
> {code}
> Ambari enters into a loop waiting for all cluster configuration types to reach TOPOLOGY_RESOLVED
state. Ambari continuously logs error messages like
> {code:java}
> AmbariContext:412 - Config type ams-hbase-site not resolved yet, Blueprint deployment
will wait until configuration update is completed
> {code}
> After 30 mins retry Ambari server eventually gives up and the cluster provisioning fails.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message