ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aravindan Vijayan (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-14350) AMS does not start up after redeploy cluster because of invalid ownership of its directories.
Date Fri, 11 Dec 2015 21:56:46 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-14350?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Aravindan Vijayan updated AMBARI-14350:
---------------------------------------
    Summary: AMS does not start up after redeploy cluster because of invalid ownership of
its directories.  (was: AMS does not startup after redeploy cluster because of invalid ownership
of its directories.)

> AMS does not start up after redeploy cluster because of invalid ownership of its directories.
> ---------------------------------------------------------------------------------------------
>
>                 Key: AMBARI-14350
>                 URL: https://issues.apache.org/jira/browse/AMBARI-14350
>             Project: Ambari
>          Issue Type: Bug
>    Affects Versions: 2.2.0
>            Reporter: Aravindan Vijayan
>            Assignee: Aravindan Vijayan
>            Priority: Critical
>             Fix For: 2.2.0
>
>
> PROBLEM
> Steps:
> Deployed cluster via blueprints.
> Reset cluster (reset ambari-server, host cleanup).
> Deployed cluster via UI.
> Result: Ambari Metrics Service go down.
> BUG
> AMS scripts do not change the ownership of certain directories to AMS user if they exist
already.
> FIX
> Adding an explicit chown to take ownership of the required directories (collector conf,
collector checkpoint, HBase tmp, HBase conf, HBase root)



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message