ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dmytro Sen" <d...@hortonworks.com>
Subject Review Request 41831: AMS fails to stay up after changing AMS configs to distributed mode
Date Thu, 31 Dec 2015 14:42:58 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/41831/
-----------------------------------------------------------

Review request for Ambari, Andrew Onischuk, Dmitro Lisnichenko, and Vitalyi Brodetskyi.


Bugs: AMBARI-14532
    https://issues.apache.org/jira/browse/AMBARI-14532


Repository: ambari


Description
-------

1. Bring up a cluster with basic services and Hbase HA enabled
2. Change following ams configs:
Metrics Service operation mode = distributed
hbase.cluster.distributed = true
hbase.rootdir = hdfs://nameservice/amshbase
3. restart AMS
4. Once AMS is started successfully it should stay up and running
Expected: AMS is up and running
Actual: AMS fails to stay up.


Diffs
-----

  ambari-server/src/main/resources/common-services/AMBARI_METRICS/0.1.0/configuration/ams-hbase-site.xml
45ccf75 

Diff: https://reviews.apache.org/r/41831/diff/


Testing
-------

Unit tests passed

----------------------------------------------------------------------
Ran 271 tests in 8.680s

OK
----------------------------------------------------------------------
Total run:891
Total errors:0
Total failures:0
OK


Thanks,

Dmytro Sen


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message