ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Nettleton" <rnettle...@hortonworks.com>
Subject Re: Review Request 41447: Cluster deployment with exported blueprint with stack advisor enabled doesn't work
Date Wed, 16 Dec 2015 19:36:11 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/41447/#review110729
-----------------------------------------------------------

Ship it!


Ship It!

- Robert Nettleton


On Dec. 16, 2015, 4:42 p.m., Oliver Szabo wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/41447/
> -----------------------------------------------------------
> 
> (Updated Dec. 16, 2015, 4:42 p.m.)
> 
> 
> Review request for Ambari, Robert Levas, Robert Nettleton, Sumit Mohanty, and Sebastian
Toader.
> 
> 
> Bugs: AMBARI-14397
>     https://issues.apache.org/jira/browse/AMBARI-14397
> 
> 
> Repository: ambari
> 
> 
> Description
> -------
> 
> 1. Deploy a cluster using the UI or a brand new blueprint
> 2. Once the cluster is up and running export the blueprint ( ?format=blueprint )
> 3. Deploy a new cluster using the previously exported blueprint. In cluster creation
template enable the use of stack advisor:
> "config_recommendation_strategy" : "ALWAYS_APPLY"
> 
> Ambari enters into a loop waiting for all cluster configuration types to reach TOPOLOGY_RESOLVED
state. Ambari continuously logs error messages like:
> 
> AmbariContext:412 - Config type ams-hbase-site not resolved yet, Blueprint deployment
will wait until configuration update is completed
> 
> After 30 mins retry Ambari server eventually gives up and the cluster provisioning fails.
> 
> Solution: update configTypeUpdated set properly
> 
> 
> Diffs
> -----
> 
>   ambari-server/src/main/java/org/apache/ambari/server/controller/internal/BlueprintConfigurationProcessor.java
457b78b 
>   ambari-server/src/test/java/org/apache/ambari/server/controller/internal/BlueprintConfigurationProcessorTest.java
033fe10 
> 
> Diff: https://reviews.apache.org/r/41447/diff/
> 
> 
> Testing
> -------
> 
> Total run:815
> Total errors:0
> Total failures:0
> OK
> INFO: AMBARI_SERVER_LIB is not set, using default /usr/lib/ambari-server
> INFO: Return code from stack upgrade command, retcode = 0
> StackAdvisor implementation for stack HDP1, version 2.0.6 was not found
> Returning DefaultStackAdvisor implementation
> StackAdvisor implementation for stack XYZ, version 1.0.0 was loaded
> StackAdvisor implementation for stack XYZ, version 1.0.1 was loaded
> Returning XYZ101StackAdvisor implementation
> [INFO] ------------------------------------------------------------------------
> [INFO] BUILD SUCCESS
> [INFO] ------------------------------------------------------------------------
> [INFO] Total time: 55:05.887s
> [INFO] Finished at: Wed Dec 16 15:37:51 CET 2015
> [INFO] Final Memory: 36M/800M
> [INFO] ------------------------------------------------------------------------
> 
> Jenkins patch testing is in progress.
> 
> 
> Thanks,
> 
> Oliver Szabo
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message