ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexandr Antonenko" <hiv...@gmail.com>
Subject Re: Review Request 40890: Unit tests for the PXF service under common-services
Date Thu, 03 Dec 2015 00:58:29 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/40890/#review108761
-----------------------------------------------------------

Ship it!


Ship It!

- Alexandr Antonenko


On Dec. 3, 2015, 12:53 a.m., Oleksandr Diachenko wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/40890/
> -----------------------------------------------------------
> 
> (Updated Dec. 3, 2015, 12:53 a.m.)
> 
> 
> Review request for Ambari, Alexander Denissov, Alexandr Antonenko, bhuvnesh chaudhary, Dmytro Sen, jun aoki, and Newton Alex.
> 
> 
> Bugs: AMBARI-14166
>     https://issues.apache.org/jira/browse/AMBARI-14166
> 
> 
> Repository: ambari
> 
> 
> Description
> -------
> 
> Currently PXF is part of common services, but is not covered with unit-tests.
> 
> 
> Diffs
> -----
> 
>   ambari-server/src/test/python/stacks/2.3/PXF/test_pxf.py PRE-CREATION 
>   ambari-server/src/test/python/stacks/2.3/configs/pxf_default.json PRE-CREATION 
> 
> Diff: https://reviews.apache.org/r/40890/diff/
> 
> 
> Testing
> -------
> 
> 2015-12-02 16:16:46,294 - Unable to determine hdp-select version for hive-server2
> 2015-12-02 16:16:46,294 - Skipping get_hdp_version since hdp-select is not yet available
> 2015-12-02 16:16:46,295 - Unable to determine hdp-select version for hive-server2
> 2015-12-02 16:16:46,295 - After hdp-select hive-metastore, reloaded module status_params
> 2015-12-02 16:16:46,297 - Skipping get_hdp_version since hdp-select is not yet available
> 2015-12-02 16:16:46,301 - After hdp-select hive-metastore, reloaded module params_linux
> 2015-12-02 16:16:46,302 - After hdp-select hive-metastore, reloaded module params
> 2015-12-02 16:16:46,309 - Executing Metastore Stack Upgrade pre-restart
> 2015-12-02 16:16:46,312 - Skipping get_hdp_version since hdp-select is not yet available
> ok
> test_security_status (test_hive_metastore.TestHiveMetastore) ... ok
> test_start_default (test_hive_metastore.TestHiveMetastore) ... 2015-12-02 16:16:46,356 - Skipping get_hdp_version since hdp-select is not yet available
> ok
> test_start_default_umask_027 (test_hive_metastore.TestHiveMetastore) ... 2015-12-02 16:16:46,383 - Skipping get_hdp_version since hdp-select is not yet available
> ok
> test_start_secured (test_hive_metastore.TestHiveMetastore) ... 2015-12-02 16:16:46,409 - Skipping get_hdp_version since hdp-select is not yet available
> ok
> test_stop_default (test_hive_metastore.TestHiveMetastore) ... 2015-12-02 16:16:46,434 - Skipping get_hdp_version since hdp-select is not yet available
> ok
> test_stop_secured (test_hive_metastore.TestHiveMetastore) ... 2015-12-02 16:16:46,448 - Skipping get_hdp_version since hdp-select is not yet available
> ok
> test_upgrade_metastore_schema (test_hive_metastore.TestHiveMetastore) ... 2015-12-02 16:16:46,459 - Executing Metastore Stack Upgrade pre-restart
> 2015-12-02 16:16:46,462 - Skipping get_hdp_version since hdp-select is not yet available
> 2015-12-02 16:16:46,462 - Unable to determine hdp-select version for hive-server2
> 2015-12-02 16:16:46,463 - Skipping get_hdp_version since hdp-select is not yet available
> 2015-12-02 16:16:46,463 - Unable to determine hdp-select version for hive-server2
> 2015-12-02 16:16:46,468 - Upgrading Hive Metastore Schema
> 2015-12-02 16:16:46,475 - For package : hive, DIRS = [{'current_dir': '/usr/hdp/current/hive-client/conf', 'conf_dir': '/etc/hive/conf'}]
> 2015-12-02 16:16:46,475 - For package : hive, Source dir: /etc/hive/conf, Dest dir: /usr/hdp/current/hive-client/conf
> 2015-12-02 16:16:46,477 - Skipping get_hdp_version since hdp-select is not yet available
> 2015-12-02 16:16:46,477 - Unable to determine hdp-select version for hive-server2
> 2015-12-02 16:16:46,478 - Skipping get_hdp_version since hdp-select is not yet available
> 2015-12-02 16:16:46,478 - Unable to determine hdp-select version for hive-server2
> 2015-12-02 16:16:46,479 - After hdp-select hive-metastore, reloaded module status_params
> 2015-12-02 16:16:46,484 - After hdp-select hive-metastore, reloaded module params_linux
> 2015-12-02 16:16:46,485 - After hdp-select hive-metastore, reloaded module params
> ok
> test_upgrade_metastore_schema_using_new_db (test_hive_metastore.TestHiveMetastore) ... 2015-12-02 16:16:46,492 - Upgrading Hive Metastore Schema
> 2015-12-02 16:16:46,495 - Skipping get_hdp_version since hdp-select is not yet available
> 2015-12-02 16:16:46,495 - Unable to determine hdp-select version for hive-metastore
> 2015-12-02 16:16:46,496 - Skipping get_hdp_version since hdp-select is not yet available
> 2015-12-02 16:16:46,496 - Unable to determine hdp-select version for hive-metastore
> ok
> test_upgrade_sqla_metastore_schema_with_jdbc_download (test_hive_metastore.TestHiveMetastore) ... 2015-12-02 16:16:46,516 - Executing Metastore Stack Upgrade pre-restart
> 2015-12-02 16:16:46,519 - Skipping get_hdp_version since hdp-select is not yet available
> 2015-12-02 16:16:46,519 - Unable to determine hdp-select version for hive-server2
> 2015-12-02 16:16:46,520 - Skipping get_hdp_version since hdp-select is not yet available
> 2015-12-02 16:16:46,520 - Unable to determine hdp-select version for hive-server2
> 2015-12-02 16:16:46,526 - Upgrading Hive Metastore Schema
> 2015-12-02 16:16:46,533 - For package : hive, DIRS = [{'current_dir': '/usr/hdp/current/hive-client/conf', 'conf_dir': '/etc/hive/conf'}]
> 2015-12-02 16:16:46,533 - For package : hive, Source dir: /etc/hive/conf, Dest dir: /usr/hdp/current/hive-client/conf
> 2015-12-02 16:16:46,535 - Skipping get_hdp_version since hdp-select is not yet available
> 2015-12-02 16:16:46,535 - Unable to determine hdp-select version for hive-server2
> 2015-12-02 16:16:46,536 - Skipping get_hdp_version since hdp-select is not yet available
> 2015-12-02 16:16:46,536 - Unable to determine hdp-select version for hive-server2
> 2015-12-02 16:16:46,537 - After hdp-select hive-metastore, reloaded module status_params
> 2015-12-02 16:16:46,543 - After hdp-select hive-metastore, reloaded module params_linux
> 2015-12-02 16:16:46,544 - After hdp-select hive-metastore, reloaded module params
> ok
> 
> ----------------------------------------------------------------------
> Ran 14 tests in 0.393s
> 
> OK
> Running tests for stack:2.1 service:STORM
> test_service_check (test_service_check.TestStormServiceCheck) ... ok
> test_configure_default (test_storm_drpc_server.TestStormDrpcServer) ... ok
> test_configure_secured (test_storm_drpc_server.TestStormDrpcServer) ... ok
> test_pre_upgrade_restart (test_storm_drpc_server.TestStormDrpcServer) ... 2015-12-02 16:16:47,312 - After hdp-select storm-client, reloaded module status_params
> 2015-12-02 16:16:47,314 - After hdp-select storm-client, reloaded module params_linux
> 2015-12-02 16:16:47,315 - After hdp-select storm-client, reloaded module params
> ok
> test_pre_upgrade_restart_23 (test_storm_drpc_server.TestStormDrpcServer) ... 2015-12-02 16:16:47,325 - For package : storm, DIRS = [{'current_dir': '/usr/hdp/current/storm-client/conf', 'conf_dir': '/etc/storm/conf'}]
> 2015-12-02 16:16:47,325 - For package : storm, Source dir: /etc/storm/conf, Dest dir: /usr/hdp/current/storm-client/conf
> 2015-12-02 16:16:47,327 - After hdp-select storm-client, reloaded module status_params
> 2015-12-02 16:16:47,329 - After hdp-select storm-client, reloaded module params_linux
> 2015-12-02 16:16:47,330 - After hdp-select storm-client, reloaded module params
> ok
> test_security_status (test_storm_drpc_server.TestStormDrpcServer) ... ok
> test_start_default (test_storm_drpc_server.TestStormDrpcServer) ... ok
> test_start_secured (test_storm_drpc_server.TestStormDrpcServer) ... ok
> test_stop_default (test_storm_drpc_server.TestStormDrpcServer) ... ok
> test_stop_secured (test_storm_drpc_server.TestStormDrpcServer) ... ok
> test_configure_default (test_storm_jaas_configuration.TestStormJaasConfiguration) ... ok
> test_configure_secured (test_storm_jaas_configuration.TestStormJaasConfiguration) ... ok
> test_start_default (test_storm_jaas_configuration.TestStormJaasConfiguration) ... 2015-12-02 16:16:48,180 - Ranger admin not installed
> ok
> test_start_secured (test_storm_jaas_configuration.TestStormJaasConfiguration) ... 2015-12-02 16:16:48,378 - Ranger admin not installed
> ok
> test_configure_default (test_storm_nimbus.TestStormNimbus) ... ok
> test_configure_secured (test_storm_nimbus.TestStormNimbus) ... ok
> test_pre_upgrade_restart (test_storm_nimbus.TestStormNimbus) ... 2015-12-02 16:16:49,007 - After hdp-select storm-client, reloaded module status_params
> 2015-12-02 16:16:49,010 - After hdp-select storm-client, reloaded module params_linux
> 2015-12-02 16:16:49,011 - After hdp-select storm-client, reloaded module params
> 2015-12-02 16:16:49,013 - After hdp-select storm-nimbus, reloaded module status_params
> 2015-12-02 16:16:49,015 - After hdp-select storm-nimbus, reloaded module params_linux
> 2015-12-02 16:16:49,017 - After hdp-select storm-nimbus, reloaded module params
> ok
> test_pre_upgrade_restart_23 (test_storm_nimbus.TestStormNimbus) ... 2015-12-02 16:16:49,027 - For package : storm, DIRS = [{'current_dir': '/usr/hdp/current/storm-client/conf', 'conf_dir': '/etc/storm/conf'}]
> 2015-12-02 16:16:49,028 - For package : storm, Source dir: /etc/storm/conf, Dest dir: /usr/hdp/current/storm-client/conf
> 2015-12-02 16:16:49,030 - After hdp-select storm-client, reloaded module status_params
> 2015-12-02 16:16:49,032 - After hdp-select storm-client, reloaded module params_linux
> 2015-12-02 16:16:49,033 - After hdp-select storm-client, reloaded module params
> 2015-12-02 16:16:49,035 - After hdp-select storm-nimbus, reloaded module status_params
> 2015-12-02 16:16:49,038 - After hdp-select storm-nimbus, reloaded module params_linux
> 2015-12-02 16:16:49,039 - After hdp-select storm-nimbus, reloaded module params
> ok
> test_security_status (test_storm_nimbus.TestStormNimbus) ... ok
> test_start_default (test_storm_nimbus.TestStormNimbus) ... 2015-12-02 16:16:49,094 - Ranger admin not installed
> ok
> test_start_secured (test_storm_nimbus.TestStormNimbus) ... 2015-12-02 16:16:49,302 - Ranger admin not installed
> ok
> test_stop_default (test_storm_nimbus.TestStormNimbus) ... ok
> test_stop_secured (test_storm_nimbus.TestStormNimbus) ... ok
> test_configure_default (test_storm_nimbus_prod.TestStormNimbus) ... ok
> test_configure_secured (test_storm_nimbus_prod.TestStormNimbus) ... ok
> test_pre_upgrade_restart (test_storm_nimbus_prod.TestStormNimbus) ... 2015-12-02 16:16:49,950 - After hdp-select storm-client, reloaded module status_params
> 2015-12-02 16:16:49,953 - After hdp-select storm-client, reloaded module params_linux
> 2015-12-02 16:16:49,955 - After hdp-select storm-client, reloaded module params
> 2015-12-02 16:16:49,957 - After hdp-select storm-nimbus, reloaded module status_params
> 2015-12-02 16:16:49,960 - After hdp-select storm-nimbus, reloaded module params_linux
> 2015-12-02 16:16:49,961 - After hdp-select storm-nimbus, reloaded module params
> ok
> test_pre_upgrade_restart_23 (test_storm_nimbus_prod.TestStormNimbus) ... 2015-12-02 16:16:49,973 - For package : storm, DIRS = [{'current_dir': '/usr/hdp/current/storm-client/conf', 'conf_dir': '/etc/storm/conf'}]
> 2015-12-02 16:16:49,974 - For package : storm, Source dir: /etc/storm/conf, Dest dir: /usr/hdp/current/storm-client/conf
> 2015-12-02 16:16:49,976 - After hdp-select storm-client, reloaded module status_params
> 2015-12-02 16:16:49,979 - After hdp-select storm-client, reloaded module params_linux
> 2015-12-02 16:16:49,980 - After hdp-select storm-client, reloaded module params
> 2015-12-02 16:16:49,982 - After hdp-select storm-nimbus, reloaded module status_params
> 2015-12-02 16:16:49,984 - After hdp-select storm-nimbus, reloaded module params_linux
> 2015-12-02 16:16:49,986 - After hdp-select storm-nimbus, reloaded module params
> ok
> test_start_default (test_storm_nimbus_prod.TestStormNimbus) ... ok
> test_start_secured (test_storm_nimbus_prod.TestStormNimbus) ... ok
> test_stop_default (test_storm_nimbus_prod.TestStormNimbus) ... ok
> test_stop_secured (test_storm_nimbus_prod.TestStormNimbus) ... ok
> test_configure_default (test_storm_rest_api_service.TestStormRestApi) ... ok
> test_configure_secured (test_storm_rest_api_service.TestStormRestApi) ... ok
> test_start_default (test_storm_rest_api_service.TestStormRestApi) ... ok
> test_start_secured (test_storm_rest_api_service.TestStormRestApi) ... ok
> test_stop_default (test_storm_rest_api_service.TestStormRestApi) ... ok
> test_stop_secured (test_storm_rest_api_service.TestStormRestApi) ... ok
> test_configure_default (test_storm_supervisor.TestStormSupervisor) ... ok
> test_configure_secured (test_storm_supervisor.TestStormSupervisor) ... ok
> test_pre_upgrade_restart (test_storm_supervisor.TestStormSupervisor) ... 2015-12-02 16:16:51,767 - After hdp-select storm-client, reloaded module status_params
> 2015-12-02 16:16:51,771 - After hdp-select storm-client, reloaded module params_linux
> 2015-12-02 16:16:51,772 - After hdp-select storm-client, reloaded module params
> 2015-12-02 16:16:51,773 - After hdp-select storm-supervisor, reloaded module status_params
> 2015-12-02 16:16:51,776 - After hdp-select storm-supervisor, reloaded module params_linux
> 2015-12-02 16:16:51,777 - After hdp-select storm-supervisor, reloaded module params
> ok
> test_pre_upgrade_restart_23 (test_storm_supervisor.TestStormSupervisor) ... 2015-12-02 16:16:51,790 - For package : storm, DIRS = [{'current_dir': '/usr/hdp/current/storm-client/conf', 'conf_dir': '/etc/storm/conf'}]
> 2015-12-02 16:16:51,791 - For package : storm, Source dir: /etc/storm/conf, Dest dir: /usr/hdp/current/storm-client/conf
> 2015-12-02 16:16:51,793 - After hdp-select storm-client, reloaded module status_params
> 2015-12-02 16:16:51,795 - After hdp-select storm-client, reloaded module params_linux
> 2015-12-02 16:16:51,797 - After hdp-select storm-client, reloaded module params
> 2015-12-02 16:16:51,798 - After hdp-select storm-supervisor, reloaded module status_params
> 2015-12-02 16:16:51,801 - After hdp-select storm-supervisor, reloaded module params_linux
> 2015-12-02 16:16:51,802 - After hdp-select storm-supervisor, reloaded module params
> ok
> test_start_default (test_storm_supervisor.TestStormSupervisor) ... ok
> test_start_secured (test_storm_supervisor.TestStormSupervisor) ... ok
> test_stop_default (test_storm_supervisor.TestStormSupervisor) ... ok
> test_stop_secured (test_storm_supervisor.TestStormSupervisor) ... ok
> test_configure_default (test_storm_supervisor_prod.TestStormSupervisor) ... ok
> test_pre_upgrade_restart (test_storm_supervisor_prod.TestStormSupervisor) ... 2015-12-02 16:16:52,494 - After hdp-select storm-client, reloaded module status_params
> 2015-12-02 16:16:52,497 - After hdp-select storm-client, reloaded module params_linux
> 2015-12-02 16:16:52,497 - After hdp-select storm-client, reloaded module params
> 2015-12-02 16:16:52,499 - After hdp-select storm-supervisor, reloaded module status_params
> 2015-12-02 16:16:52,502 - After hdp-select storm-supervisor, reloaded module params_linux
> 2015-12-02 16:16:52,504 - After hdp-select storm-supervisor, reloaded module params
> ok
> test_pre_upgrade_restart_23 (test_storm_supervisor_prod.TestStormSupervisor) ... 2015-12-02 16:16:52,514 - For package : storm, DIRS = [{'current_dir': '/usr/hdp/current/storm-client/conf', 'conf_dir': '/etc/storm/conf'}]
> 2015-12-02 16:16:52,514 - For package : storm, Source dir: /etc/storm/conf, Dest dir: /usr/hdp/current/storm-client/conf
> 2015-12-02 16:16:52,516 - After hdp-select storm-client, reloaded module status_params
> 2015-12-02 16:16:52,518 - After hdp-select storm-client, reloaded module params_linux
> 2015-12-02 16:16:52,520 - After hdp-select storm-client, reloaded module params
> 2015-12-02 16:16:52,521 - After hdp-select storm-supervisor, reloaded module status_params
> 2015-12-02 16:16:52,524 - After hdp-select storm-supervisor, reloaded module params_linux
> 2015-12-02 16:16:52,525 - After hdp-select storm-supervisor, reloaded module params
> ok
> test_start_default (test_storm_supervisor_prod.TestStormSupervisor) ... ok
> test_start_secured (test_storm_supervisor_prod.TestStormSupervisor) ... ok
> test_stop_default (test_storm_supervisor_prod.TestStormSupervisor) ... ok
> test_stop_secured (test_storm_supervisor_prod.TestStormSupervisor) ... ok
> test_configure_default (test_storm_ui_server.TestStormUiServer) ... ok
> test_configure_secured (test_storm_ui_server.TestStormUiServer) ... ok
> test_pre_upgrade_restart (test_storm_ui_server.TestStormUiServer) ... 2015-12-02 16:16:53,355 - After hdp-select storm-client, reloaded module status_params
> 2015-12-02 16:16:53,357 - After hdp-select storm-client, reloaded module params_linux
> 2015-12-02 16:16:53,358 - After hdp-select storm-client, reloaded module params
> ok
> test_pre_upgrade_restart_23 (test_storm_ui_server.TestStormUiServer) ... 2015-12-02 16:16:53,369 - For package : storm, DIRS = [{'current_dir': '/usr/hdp/current/storm-client/conf', 'conf_dir': '/etc/storm/conf'}]
> 2015-12-02 16:16:53,369 - For package : storm, Source dir: /etc/storm/conf, Dest dir: /usr/hdp/current/storm-client/conf
> 2015-12-02 16:16:53,371 - After hdp-select storm-client, reloaded module status_params
> 2015-12-02 16:16:53,373 - After hdp-select storm-client, reloaded module params_linux
> 2015-12-02 16:16:53,374 - After hdp-select storm-client, reloaded module params
> ok
> test_security_status (test_storm_ui_server.TestStormUiServer) ... ok
> test_start_default (test_storm_ui_server.TestStormUiServer) ... 2015-12-02 16:16:53,423 - Ranger admin not installed
> ok
> test_start_secured (test_storm_ui_server.TestStormUiServer) ... 2015-12-02 16:16:53,615 - Ranger admin not installed
> ok
> test_stop_default (test_storm_ui_server.TestStormUiServer) ... ok
> test_stop_secured (test_storm_ui_server.TestStormUiServer) ... ok
> 
> ----------------------------------------------------------------------
> Ran 61 tests in 6.954s
> 
> OK
> Running tests for stack:2.1 service:TEZ
> test_service_check (test_service_check.TestTezServiceCheck) ... ok
> test_configure_default (test_tez_client.TestTezClient) ... ok
> test_pre_upgrade_restart_23 (test_tez_client.TestTezClient) ... 2015-12-02 16:16:54,080 - For package : tez, DIRS = [{'current_dir': '/usr/hdp/current/tez-client/conf', 'conf_dir': '/etc/tez/conf'}]
> 2015-12-02 16:16:54,080 - For package : tez, Source dir: /etc/tez/conf, Dest dir: /usr/hdp/current/tez-client/conf
> 2015-12-02 16:16:54,081 - For package : hadoop, DIRS = [{'current_dir': '/usr/hdp/current/hadoop-client/conf', 'conf_dir': '/etc/hadoop/conf'}]
> 2015-12-02 16:16:54,081 - For package : hadoop, Source dir: /etc/hadoop/conf, Dest dir: /usr/hdp/current/hadoop-client/conf
> 2015-12-02 16:16:54,083 - After hdp-select hadoop-client, reloaded module params_linux
> 2015-12-02 16:16:54,084 - After hdp-select hadoop-client, reloaded module params
> ok
> test_upgrade (test_tez_client.TestTezClient) ... 2015-12-02 16:16:54,092 - After hdp-select hadoop-client, reloaded module params_linux
> 2015-12-02 16:16:54,093 - After hdp-select hadoop-client, reloaded module params
> ok
> test_upgrade_23 (test_tez_client.TestTezClient) ... 2015-12-02 16:16:54,107 - After hdp-select hadoop-client, reloaded module params_linux
> 2015-12-02 16:16:54,108 - After hdp-select hadoop-client, reloaded module params
> ok
> 
> ----------------------------------------------------------------------
> Ran 5 tests in 0.107s
> 
> OK
> Running tests for stack:2.1 service:YARN
> test_configure_default (test_apptimelineserver.TestAppTimelineServer) ... 2015-12-02 16:16:54,356 - Failed to get extracted version with hdp-select
> ok
> test_pre_upgrade_restart_23 (test_apptimelineserver.TestAppTimelineServer) ... 2015-12-02 16:16:54,398 - Executing Stack Upgrade pre-restart
> 2015-12-02 16:16:54,404 - For package : hadoop, DIRS = [{'current_dir': '/usr/hdp/current/hadoop-client/conf', 'conf_dir': '/etc/hadoop/conf'}]
> 2015-12-02 16:16:54,404 - For package : hadoop, Source dir: /etc/hadoop/conf, Dest dir: /usr/hdp/current/hadoop-client/conf
> 2015-12-02 16:16:54,404 - Normalized Conf Dir : /etc/hadoop/conf, Normalized Current Dir : /usr/hdp/current/hadoop-client/conf
> 2015-12-02 16:16:54,406 - After hdp-select hadoop-yarn-timelineserver, reloaded module status_params
> 2015-12-02 16:16:54,410 - After hdp-select hadoop-yarn-timelineserver, reloaded module params_linux
> 2015-12-02 16:16:54,410 - After hdp-select hadoop-yarn-timelineserver, reloaded module params
> ok
> test_security_status (test_apptimelineserver.TestAppTimelineServer) ... ok
> test_start_default (test_apptimelineserver.TestAppTimelineServer) ... 2015-12-02 16:16:54,449 - Failed to get extracted version with hdp-select
> ok
> test_status (test_apptimelineserver.TestAppTimelineServer) ... ok
> test_stop_default (test_apptimelineserver.TestAppTimelineServer) ... 2015-12-02 16:16:54,497 - Failed to get extracted version with hdp-select
> ok
> 
> ----------------------------------------------------------------------
> Ran 6 tests in 0.170s
> 
> OK
> Running tests for stack:2.2 service:ACCUMULO
> test_pre_upgrade_restart (test_accumulo_client.TestAccumuloClient) ... 2015-12-02 16:16:54,691 - Executing Accumulo Client Upgrade pre-restart
> 2015-12-02 16:16:54,692 - After hdp-select accumulo-client, reloaded module status_params
> 2015-12-02 16:16:54,695 - After hdp-select accumulo-client, reloaded module params
> ok
> test_pre_upgrade_restart_23 (test_accumulo_client.TestAccumuloClient) ... 2015-12-02 16:16:54,704 - Executing Accumulo Client Upgrade pre-restart
> 2015-12-02 16:16:54,705 - For package : accumulo, DIRS = [{'current_dir': '/usr/hdp/current/accumulo-client/conf', 'conf_dir': '/etc/accumulo/conf'}]
> 2015-12-02 16:16:54,705 - For package : accumulo, Source dir: /etc/accumulo/conf, Dest dir: /usr/hdp/current/accumulo-client/conf
> 2015-12-02 16:16:54,706 - After hdp-select accumulo-client, reloaded module status_params
> 2015-12-02 16:16:54,709 - After hdp-select accumulo-client, reloaded module params
> ok
> 
> ----------------------------------------------------------------------
> Ran 2 tests in 0.054s
> 
> OK
> Running tests for stack:2.2 service:common
> test_recommendAmsConfigurations (test_stack_advisor.TestHDP22StackAdvisor) ... max_inmemory_regions: -4.8
> Processing file: /Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/main/resources/stacks/HDP/2.2/services/../../../../common-services/AMBARI_METRICS/0.1.0/package/files/service-metrics/AMBARI_METRICS.txt
> Processing file: /Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/main/resources/stacks/HDP/2.2/services/../../../../common-services/AMBARI_METRICS/0.1.0/package/files/service-metrics/HOST.txt
> metrics length: 86
> max_inmemory_regions: -2.7
> Processing file: /Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/main/resources/stacks/HDP/2.2/services/../../../../common-services/AMBARI_METRICS/0.1.0/package/files/service-metrics/AMBARI_METRICS.txt
> Processing file: /Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/main/resources/stacks/HDP/2.2/services/../../../../common-services/AMBARI_METRICS/0.1.0/package/files/service-metrics/HOST.txt
> metrics length: 86
> max_inmemory_regions: -0.3
> Processing file: /Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/main/resources/stacks/HDP/2.2/services/../../../../common-services/AMBARI_METRICS/0.1.0/package/files/service-metrics/AMBARI_METRICS.txt
> Processing file: /Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/main/resources/stacks/HDP/2.2/services/../../../../common-services/AMBARI_METRICS/0.1.0/package/files/service-metrics/HDFS.txt
> Processing file: /Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/main/resources/stacks/HDP/2.2/services/../../../../common-services/AMBARI_METRICS/0.1.0/package/files/service-metrics/HOST.txt
> Processing file: /Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/main/resources/stacks/HDP/2.2/services/../../../../common-services/AMBARI_METRICS/0.1.0/package/files/service-metrics/YARN.txt
> metrics length: 175
> max_inmemory_regions: -4.8
> Processing file: /Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/main/resources/stacks/HDP/2.2/services/../../../../common-services/AMBARI_METRICS/0.1.0/package/files/service-metrics/AMBARI_METRICS.txt
> Processing file: /Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/main/resources/stacks/HDP/2.2/services/../../../../common-services/AMBARI_METRICS/0.1.0/package/files/service-metrics/HDFS.txt
> Processing file: /Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/main/resources/stacks/HDP/2.2/services/../../../../common-services/AMBARI_METRICS/0.1.0/package/files/service-metrics/HOST.txt
> Processing file: /Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/main/resources/stacks/HDP/2.2/services/../../../../common-services/AMBARI_METRICS/0.1.0/package/files/service-metrics/YARN.txt
> metrics length: 175
> max_inmemory_regions: 3.6
> Processing file: /Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/main/resources/stacks/HDP/2.2/services/../../../../common-services/AMBARI_METRICS/0.1.0/package/files/service-metrics/AMBARI_METRICS.txt
> Processing file: /Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/main/resources/stacks/HDP/2.2/services/../../../../common-services/AMBARI_METRICS/0.1.0/package/files/service-metrics/HDFS.txt
> Processing file: /Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/main/resources/stacks/HDP/2.2/services/../../../../common-services/AMBARI_METRICS/0.1.0/package/files/service-metrics/HOST.txt
> Processing file: /Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/main/resources/stacks/HDP/2.2/services/../../../../common-services/AMBARI_METRICS/0.1.0/package/files/service-metrics/YARN.txt
> metrics length: 175
> max_inmemory_regions: 13.2
> Processing file: /Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/main/resources/stacks/HDP/2.2/services/../../../../common-services/AMBARI_METRICS/0.1.0/package/files/service-metrics/AMBARI_METRICS.txt
> Processing file: /Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/main/resources/stacks/HDP/2.2/services/../../../../common-services/AMBARI_METRICS/0.1.0/package/files/service-metrics/HDFS.txt
> Processing file: /Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/main/resources/stacks/HDP/2.2/services/../../../../common-services/AMBARI_METRICS/0.1.0/package/files/service-metrics/HOST.txt
> Processing file: /Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/main/resources/stacks/HDP/2.2/services/../../../../common-services/AMBARI_METRICS/0.1.0/package/files/service-metrics/YARN.txt
> metrics length: 175
> max_inmemory_regions: -4.8
> Processing file: /Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/main/resources/stacks/HDP/2.2/services/../../../../common-services/AMBARI_METRICS/0.1.0/package/files/service-metrics/AMBARI_METRICS.txt
> Processing file: /Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/main/resources/stacks/HDP/2.2/services/../../../../common-services/AMBARI_METRICS/0.1.0/package/files/service-metrics/HDFS.txt
> Processing file: /Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/main/resources/stacks/HDP/2.2/services/../../../../common-services/AMBARI_METRICS/0.1.0/package/files/service-metrics/HOST.txt
> Processing file: /Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/main/resources/stacks/HDP/2.2/services/../../../../common-services/AMBARI_METRICS/0.1.0/package/files/service-metrics/YARN.txt
> metrics length: 175
> max_inmemory_regions: 13.2
> Processing file: /Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/main/resources/stacks/HDP/2.2/services/../../../../common-services/AMBARI_METRICS/0.1.0/package/files/service-metrics/AMBARI_METRICS.txt
> Processing file: /Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/main/resources/stacks/HDP/2.2/services/../../../../common-services/AMBARI_METRICS/0.1.0/package/files/service-metrics/HDFS.txt
> Processing file: /Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/main/resources/stacks/HDP/2.2/services/../../../../common-services/AMBARI_METRICS/0.1.0/package/files/service-metrics/HOST.txt
> Processing file: /Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/main/resources/stacks/HDP/2.2/services/../../../../common-services/AMBARI_METRICS/0.1.0/package/files/service-metrics/YARN.txt
> metrics length: 175
> ok
> test_recommendHDFSConfigurations (test_stack_advisor.TestHDP22StackAdvisor) ... ok
> test_recommendHbaseConfigurations (test_stack_advisor.TestHDP22StackAdvisor) ... ok
> test_recommendHbaseSiteConfigurations (test_stack_advisor.TestHDP22StackAdvisor) ... ok
> test_recommendHiveConfigurationAttributes (test_stack_advisor.TestHDP22StackAdvisor) ... ok
> test_recommendKnoxConfigurations (test_stack_advisor.TestHDP22StackAdvisor) ... ok
> test_recommendMapredConfigurationAttributes (test_stack_advisor.TestHDP22StackAdvisor) ... ok
> test_recommendMapredConfigurationAttributesWithPigService (test_stack_advisor.TestHDP22StackAdvisor) ... ok
> test_recommendRangerConfigurations (test_stack_advisor.TestHDP22StackAdvisor) ... ok
> test_recommendStormConfigurations (test_stack_advisor.TestHDP22StackAdvisor) ... ok
> test_recommendTezConfigurations (test_stack_advisor.TestHDP22StackAdvisor) ... ok
> test_recommendTezConfigurations_amMemoryMoreThan3072 (test_stack_advisor.TestHDP22StackAdvisor) ... ok
> test_recommendTezConfigurations_mapMemoryLessThan768 (test_stack_advisor.TestHDP22StackAdvisor) ... ok
> test_recommendYARNConfigurationAttributes (test_stack_advisor.TestHDP22StackAdvisor) ... ok
> test_recommendYARNConfigurations (test_stack_advisor.TestHDP22StackAdvisor) ... ok
> test_recommendYarnCGroupConfigurations (test_stack_advisor.TestHDP22StackAdvisor) ... ok
> test_validateHBASERangerPluginConfigurations (test_stack_advisor.TestHDP22StackAdvisor) ... ok
> test_validateHDFSConfigurations (test_stack_advisor.TestHDP22StackAdvisor) ... ok
> test_validateHDFSConfigurationsEnv (test_stack_advisor.TestHDP22StackAdvisor) ... ok
> test_validateHDFSRangerPluginConfigurations (test_stack_advisor.TestHDP22StackAdvisor) ... ok
> test_validateHiveConfigurations (test_stack_advisor.TestHDP22StackAdvisor) ... ok
> test_validateHiveConfigurationsEnv (test_stack_advisor.TestHDP22StackAdvisor) ... ok
> test_validateHiveServer2Configurations (test_stack_advisor.TestHDP22StackAdvisor) ... ok
> test_validateKafkaRangerPluginConfigurations (test_stack_advisor.TestHDP22StackAdvisor) ... ok
> test_validateKnoxRangerPluginConfigurations (test_stack_advisor.TestHDP22StackAdvisor) ... ok
> test_validateMR2XmxOptsEnv (test_stack_advisor.TestHDP22StackAdvisor) ... ok
> test_validateRangerConfigurationsEnv (test_stack_advisor.TestHDP22StackAdvisor) ... ok
> test_validateStormRangerPluginConfigurations (test_stack_advisor.TestHDP22StackAdvisor) ... ok
> test_validateTezConfigurationsEnv (test_stack_advisor.TestHDP22StackAdvisor) ... ok
> test_validateYARNConfigurationsEnv (test_stack_advisor.TestHDP22StackAdvisor) ... ok
> test_validateYARNRangerPluginConfigurations (test_stack_advisor.TestHDP22StackAdvisor) ... ok
> test_performance (test_stack_advisor_perf.TestHDP22StackAdvisor) ... time taken by old stack_advisor.py = 0.0571739673615
> time taken by current stack_advisor.py = 0.00380086898804
> time taken by old stack_advisor.py = 0.0798649787903
> time taken by current stack_advisor.py = 0.00435090065002
> ok
> 
> ----------------------------------------------------------------------
> Ran 32 tests in 0.432s
> 
> OK
> Running tests for stack:2.2 service:KAFKA
> test_configure_custom_paths_default (test_kafka_broker.TestKafkaBroker) ... 2015-12-02 16:16:55,481 - Effective stack version: 2.2.0.0
> 2015-12-02 16:16:55,482 - Calculating broker.id as 0
> ok
> test_configure_default (test_kafka_broker.TestKafkaBroker) ... 2015-12-02 16:16:55,498 - Effective stack version: 2.2.0.0
> 2015-12-02 16:16:55,499 - Calculating broker.id as 0
> ok
> test_pre_upgrade_restart (test_kafka_broker.TestKafkaBroker) ... 2015-12-02 16:16:55,508 - After hdp-select kafka-broker, reloaded module status_params
> 2015-12-02 16:16:55,510 - After hdp-select kafka-broker, reloaded module params
> ok
> test_pre_upgrade_restart_23 (test_kafka_broker.TestKafkaBroker) ... 2015-12-02 16:16:55,516 - For package : kafka, DIRS = [{'current_dir': '/usr/hdp/current/kafka-broker/conf', 'conf_dir': '/etc/kafka/conf'}]
> 2015-12-02 16:16:55,516 - For package : kafka, Source dir: /etc/kafka/conf, Dest dir: /usr/hdp/current/kafka-broker/conf
> 2015-12-02 16:16:55,517 - After hdp-select kafka-broker, reloaded module status_params
> 2015-12-02 16:16:55,519 - After hdp-select kafka-broker, reloaded module params
> ok
> 
> ----------------------------------------------------------------------
> Ran 4 tests in 0.089s
> 
> OK
> Running tests for stack:2.2 service:KERBEROS
> test_configure_cross_realm_trust (test_kerberos_client.TestKerberosClient) ... ok
> test_configure_managed_kdc (test_kerberos_client.TestKerberosClient) ... ok
> test_configure_unmanaged_ad (test_kerberos_client.TestKerberosClient) ... ok
> test_configure_unmanaged_kdc (test_kerberos_client.TestKerberosClient) ... ok
> test_configure_unmanaged_kdc_and_krb5conf (test_kerberos_client.TestKerberosClient) ... ok
> test_delete_keytab (test_kerberos_client.TestKerberosClient) ... ok
> test_get_property (test_kerberos_client.TestKerberosClient) ... ok
> test_set_keytab (test_kerberos_client.TestKerberosClient) ... ok
> test_configure_cross_realm_trust (test_kerberos_server.TestKerberosServer) ... ok
> test_configure_managed_kdc (test_kerberos_server.TestKerberosServer) ... ok
> test_configure_unmanaged_ad (test_kerberos_server.TestKerberosServer) ... ok
> test_configure_unmanaged_kdc (test_kerberos_server.TestKerberosServer) ... ok
> 
> ----------------------------------------------------------------------
> Ran 12 tests in 0.205s
> 
> OK
> Running tests for stack:2.2 service:KNOX
> test_configure_default (test_knox_gateway.TestKnoxGateway) ... 2015-12-02 16:16:56,174 - HDP version to use is 2.2.1.0
> ok
> test_pre_upgrade_restart (test_knox_gateway.TestKnoxGateway) ... 2015-12-02 16:16:56,206 - HDP version to use is 2.2.1.0
> 2015-12-02 16:16:56,209 - Backing up directories. Initial conf folder: /usr/hdp/current/knox-server/conf
> 2015-12-02 16:16:56,209 - Backing up Knox data directory before upgrade...
> 2015-12-02 16:16:56,210 - Knox directories to backup:
> {'/usr/hdp/current/knox-server/conf/': 'knox-conf-backup.tar', '/var/lib/knox/data': 'knox-data-backup.tar'}
> 2015-12-02 16:16:56,210 - Directory mappings to backup: {'/usr/hdp/current/knox-server/conf/': 'knox-conf-backup.tar', '/var/lib/knox/data': 'knox-data-backup.tar'}
> 2015-12-02 16:16:56,210 - Compressing /usr/hdp/current/knox-server/conf/ to /tmp/knox-upgrade-backup/knox-conf-backup.tar
> 2015-12-02 16:16:56,210 - Compressing /var/lib/knox/data to /tmp/knox-upgrade-backup/knox-data-backup.tar
> 2015-12-02 16:16:56,212 - After hdp-select knox-server, reloaded module status_params
> 2015-12-02 16:16:56,213 - HDP version to use is 2.2.1.0
> 2015-12-02 16:16:56,214 - After hdp-select knox-server, reloaded module params_linux
> 2015-12-02 16:16:56,215 - After hdp-select knox-server, reloaded module params
> ok
> test_pre_upgrade_restart_from_hdp_2300_to_2320 (test_knox_gateway.TestKnoxGateway) ... 2015-12-02 16:16:56,222 - HDP version to use is 2.3.2.0
> 2015-12-02 16:16:56,222 - Detected HDP with stack version 2.3.2.0-5678, will use knox_data_dir = /usr/hdp/2.3.2.0-5678/knox/data
> 2015-12-02 16:16:56,225 - Backing up directories. Initial conf folder: /usr/hdp/current/knox-server/conf
> 2015-12-02 16:16:56,225 - Backing up Knox data directory before upgrade...
> 2015-12-02 16:16:56,225 - Knox directories to backup:
> {'/usr/hdp/current/knox-server/conf/': 'knox-conf-backup.tar', '/var/lib/knox/data': 'knox-data-backup.tar'}
> 2015-12-02 16:16:56,226 - Directory mappings to backup: {'/usr/hdp/current/knox-server/conf/': 'knox-conf-backup.tar', '/var/lib/knox/data': 'knox-data-backup.tar'}
> 2015-12-02 16:16:56,226 - Compressing /usr/hdp/current/knox-server/conf/ to /tmp/knox-upgrade-backup/knox-conf-backup.tar
> 2015-12-02 16:16:56,226 - Compressing /var/lib/knox/data to /tmp/knox-upgrade-backup/knox-data-backup.tar
> 2015-12-02 16:16:56,227 - For package : knox, DIRS = [{'current_dir': '/usr/hdp/current/knox-server/conf', 'conf_dir': '/etc/knox/conf'}]
> 2015-12-02 16:16:56,227 - For package : knox, Source dir: /etc/knox/conf, Dest dir: /usr/hdp/current/knox-server/conf
> 2015-12-02 16:16:56,228 - Normalized Conf Dir : /etc/knox/conf, Normalized Current Dir : /usr/hdp/current/knox-server/conf
> 2015-12-02 16:16:56,229 - After hdp-select knox-server, reloaded module status_params
> 2015-12-02 16:16:56,230 - HDP version to use is 2.3.2.0
> 2015-12-02 16:16:56,231 - Detected HDP with stack version 2.3.2.0-5678, will use knox_data_dir = /usr/hdp/2.3.2.0-5678/knox/data
> 2015-12-02 16:16:56,232 - After hdp-select knox-server, reloaded module params_linux
> 2015-12-02 16:16:56,233 - After hdp-select knox-server, reloaded module params
> 2015-12-02 16:16:56,233 - Copying knox-conf-backup.tar into /usr/hdp/current/knox-server/conf/knox-conf-backup.tar file.
> ok
> test_pre_upgrade_restart_from_hdp_2320 (test_knox_gateway.TestKnoxGateway) ... 2015-12-02 16:16:56,242 - HDP version to use is 2.3.2.0
> 2015-12-02 16:16:56,242 - Detected HDP with stack version 2.3.2.0-1001, will use knox_data_dir = /usr/hdp/2.3.2.0-1001/knox/data
> 2015-12-02 16:16:56,244 - Backing up directories. Initial conf folder: /usr/hdp/current/knox-server/conf
> 2015-12-02 16:16:56,244 - Backing up Knox data directory before upgrade...
> 2015-12-02 16:16:56,245 - Knox directories to backup:
> {'/usr/hdp/current/knox-server/conf/': 'knox-conf-backup.tar', '/usr/hdp/2.3.2.0-1000/knox/data': 'knox-data-backup.tar'}
> 2015-12-02 16:16:56,245 - Directory mappings to backup: {'/usr/hdp/current/knox-server/conf/': 'knox-conf-backup.tar', '/usr/hdp/2.3.2.0-1000/knox/data': 'knox-data-backup.tar'}
> 2015-12-02 16:16:56,245 - Compressing /usr/hdp/current/knox-server/conf/ to /tmp/knox-upgrade-backup/knox-conf-backup.tar
> 2015-12-02 16:16:56,246 - Compressing /usr/hdp/2.3.2.0-1000/knox/data to /tmp/knox-upgrade-backup/knox-data-backup.tar
> 2015-12-02 16:16:56,246 - For package : knox, DIRS = [{'current_dir': '/usr/hdp/current/knox-server/conf', 'conf_dir': '/etc/knox/conf'}]
> 2015-12-02 16:16:56,247 - For package : knox, Source dir: /etc/knox/conf, Dest dir: /usr/hdp/current/knox-server/conf
> 2015-12-02 16:16:56,247 - Normalized Conf Dir : /etc/knox/conf, Normalized Current Dir : /usr/hdp/current/knox-server/conf
> 2015-12-02 16:16:56,248 - After hdp-select knox-server, reloaded module status_params
> 2015-12-02 16:16:56,249 - HDP version to use is 2.3.2.0
> 2015-12-02 16:16:56,250 - Detected HDP with stack version 2.3.2.0-1001, will use knox_data_dir = /usr/hdp/2.3.2.0-1001/knox/data
> 2015-12-02 16:16:56,251 - After hdp-select knox-server, reloaded module params_linux
> 2015-12-02 16:16:56,252 - After hdp-select knox-server, reloaded module params
> 2015-12-02 16:16:56,252 - Copying knox-conf-backup.tar into /usr/hdp/current/knox-server/conf/knox-conf-backup.tar file.
> ok
> test_pre_upgrade_restart_to_hdp_2300 (test_knox_gateway.TestKnoxGateway) ... 2015-12-02 16:16:56,259 - HDP version to use is 2.3.0.0
> 2015-12-02 16:16:56,261 - Backing up directories. Initial conf folder: /usr/hdp/current/knox-server/conf
> 2015-12-02 16:16:56,261 - Backing up Knox data directory before upgrade...
> 2015-12-02 16:16:56,262 - Knox directories to backup:
> {'/usr/hdp/current/knox-server/conf/': 'knox-conf-backup.tar', '/var/lib/knox/data': 'knox-data-backup.tar'}
> 2015-12-02 16:16:56,262 - Directory mappings to backup: {'/usr/hdp/current/knox-server/conf/': 'knox-conf-backup.tar', '/var/lib/knox/data': 'knox-data-backup.tar'}
> 2015-12-02 16:16:56,262 - Compressing /usr/hdp/current/knox-server/conf/ to /tmp/knox-upgrade-backup/knox-conf-backup.tar
> 2015-12-02 16:16:56,263 - Compressing /var/lib/knox/data to /tmp/knox-upgrade-backup/knox-data-backup.tar
> 2015-12-02 16:16:56,263 - For package : knox, DIRS = [{'current_dir': '/usr/hdp/current/knox-server/conf', 'conf_dir': '/etc/knox/conf'}]
> 2015-12-02 16:16:56,264 - For package : knox, Source dir: /etc/knox/conf, Dest dir: /usr/hdp/current/knox-server/conf
> 2015-12-02 16:16:56,264 - Normalized Conf Dir : /etc/knox/conf, Normalized Current Dir : /usr/hdp/current/knox-server/conf
> 2015-12-02 16:16:56,265 - After hdp-select knox-server, reloaded module status_params
> 2015-12-02 16:16:56,266 - HDP version to use is 2.3.0.0
> 2015-12-02 16:16:56,268 - After hdp-select knox-server, reloaded module params_linux
> 2015-12-02 16:16:56,269 - After hdp-select knox-server, reloaded module params
> 2015-12-02 16:16:56,269 - Copying knox-conf-backup.tar into /usr/hdp/current/knox-server/conf/knox-conf-backup.tar file.
> ok
> test_security_status (test_knox_gateway.TestKnoxGateway) ... ok
> test_start_default (test_knox_gateway.TestKnoxGateway) ... 2015-12-02 16:16:56,302 - HDP version to use is 2.2.1.0
> 2015-12-02 16:16:56,314 - Ranger admin not installed
> ok
> 
> ----------------------------------------------------------------------
> Ran 7 tests in 0.218s
> 
> OK
> Running tests for stack:2.2 service:PIG
> test_service_check_secure (test_pig_service_check.TestPigServiceCheck) ... ok
> 
> ----------------------------------------------------------------------
> Ran 1 test in 0.022s
> 
> OK
> Running tests for stack:2.2 service:RANGER
> test_configure_default (test_ranger_admin.TestRangerAdmin) ... 2015-12-02 16:16:56,728 - Checking DB connection
> ok
> test_configure_secured (test_ranger_admin.TestRangerAdmin) ... 2015-12-02 16:16:56,736 - Checking DB connection
> ok
> test_pre_upgrade_restart_23 (test_ranger_admin.TestRangerAdmin) ... 2015-12-02 16:16:56,755 - For package : ranger-admin, DIRS = [{'current_dir': '/usr/hdp/current/ranger-admin/conf', 'conf_dir': '/etc/ranger/admin/conf'}]
> 2015-12-02 16:16:56,755 - For package : ranger-admin, Source dir: /etc/ranger/admin/conf, Dest dir: /usr/hdp/current/ranger-admin/conf
> 2015-12-02 16:16:56,757 - After hdp-select ranger-admin, reloaded module params
> ok
> test_start_default (test_ranger_admin.TestRangerAdmin) ... 2015-12-02 16:16:56,764 - Checking DB connection
> ok
> test_start_secured (test_ranger_admin.TestRangerAdmin) ... 2015-12-02 16:16:56,772 - Checking DB connection
> ok
> test_stop_default (test_ranger_admin.TestRangerAdmin) ... ok
> test_stop_secured (test_ranger_admin.TestRangerAdmin) ... ok
> test_configure_default (test_ranger_usersync.TestRangerUsersync) ... ok
> test_configure_secured (test_ranger_usersync.TestRangerUsersync) ... ok
> test_start_default (test_ranger_usersync.TestRangerUsersync) ... ok
> test_start_secured (test_ranger_usersync.TestRangerUsersync) ... ok
> test_stop_default (test_ranger_usersync.TestRangerUsersync) ... ok
> test_stop_secured (test_ranger_usersync.TestRangerUsersync) ... ok
> test_upgrade (test_ranger_usersync.TestRangerUsersync) ... 2015-12-02 16:16:56,834 - After hdp-select ranger-usersync, reloaded module params
> ok
> test_upgrade_23 (test_ranger_usersync.TestRangerUsersync) ... 2015-12-02 16:16:56,845 - For package : ranger-usersync, DIRS = [{'current_dir': '/usr/hdp/current/ranger-usersync/conf', 'conf_dir': '/etc/ranger/usersync/conf'}]
> 2015-12-02 16:16:56,845 - For package : ranger-usersync, Source dir: /etc/ranger/usersync/conf, Dest dir: /usr/hdp/current/ranger-usersync/conf
> 2015-12-02 16:16:56,848 - After hdp-select ranger-usersync, reloaded module params
> ok
> 
> ----------------------------------------------------------------------
> Ran 15 tests in 0.168s
> 
> OK
> Running tests for stack:2.2 service:SLIDER
> test_configure_default (test_slider_client.TestSliderClient) ... ok
> test_pre_upgrade_restart (test_slider_client.TestSliderClient) ... 2015-12-02 16:16:57,049 - After hdp-select slider-client, reloaded module params_linux
> 2015-12-02 16:16:57,050 - After hdp-select slider-client, reloaded module params
> 2015-12-02 16:16:57,052 - After hdp-select hadoop-client, reloaded module params_linux
> 2015-12-02 16:16:57,053 - After hdp-select hadoop-client, reloaded module params
> ok
> test_pre_upgrade_restart_23 (test_slider_client.TestSliderClient) ... 2015-12-02 16:16:57,060 - For package : slider, DIRS = [{'current_dir': '/usr/hdp/current/slider-client/conf', 'conf_dir': '/etc/slider/conf'}]
> 2015-12-02 16:16:57,060 - For package : slider, Source dir: /etc/slider/conf, Dest dir: /usr/hdp/current/slider-client/conf
> 2015-12-02 16:16:57,062 - After hdp-select slider-client, reloaded module params_linux
> 2015-12-02 16:16:57,063 - After hdp-select slider-client, reloaded module params
> 2015-12-02 16:16:57,063 - For package : hadoop, DIRS = [{'current_dir': '/usr/hdp/current/hadoop-client/conf', 'conf_dir': '/etc/hadoop/conf'}]
> 2015-12-02 16:16:57,064 - For package : hadoop, Source dir: /etc/hadoop/conf, Dest dir: /usr/hdp/current/hadoop-client/conf
> 2015-12-02 16:16:57,065 - After hdp-select hadoop-client, reloaded module params_linux
> 2015-12-02 16:16:57,067 - After hdp-select hadoop-client, reloaded module params
> ok
> test_svc_check_default (test_slider_client.TestSliderClient) ... 2015-12-02 16:16:57,088 - Called copy_to_hdfs tarball: slider
> 2015-12-02 16:16:57,088 - Default version is None
> 2015-12-02 16:16:57,089 - Could not parse output of /tmp/copy_tarball_out.txt. Error: [Errno 2] No such file or directory: '/tmp/copy_tarball_out.txt'
> Traceback (most recent call last):
>   File "/Users/adiachenko/git/ambari-oss-mirror/ambari-common/src/main/python/resource_management/libraries/functions/copy_tarball.py", line 76, in _get_single_version_from_hdp_select
>     with open(tmp_file, 'r+') as file:
> IOError: [Errno 2] No such file or directory: '/tmp/copy_tarball_out.txt'
> 2015-12-02 16:16:57,089 - Could not parse output of /tmp/copy_tarball_out.txt. Error: [Errno 2] No such file or directory: '/tmp/copy_tarball_out.txt'
> Traceback (most recent call last):
>   File "/Users/adiachenko/git/ambari-oss-mirror/ambari-common/src/main/python/resource_management/libraries/functions/copy_tarball.py", line 76, in _get_single_version_from_hdp_select
>     with open(tmp_file, 'r+') as file:
> IOError: [Errno 2] No such file or directory: '/tmp/copy_tarball_out.txt'
> 2015-12-02 16:16:57,090 - Could not verify HDP version by calling '/usr/bin/hdp-select versions > /tmp/copy_tarball_out.txt'. Return Code: 0, Output: None.
> 2015-12-02 16:16:57,090 - Could not verify HDP version by calling '/usr/bin/hdp-select versions > /tmp/copy_tarball_out.txt'. Return Code: 0, Output: None.
> 2015-12-02 16:16:57,090 - Cannot copy slider tarball because unable to determine current version .
> ok
> test_svc_check_secured (test_slider_client.TestSliderClient) ... 2015-12-02 16:16:57,096 - Called copy_to_hdfs tarball: slider
> 2015-12-02 16:16:57,097 - Default version is None
> 2015-12-02 16:16:57,097 - Could not parse output of /tmp/copy_tarball_out.txt. Error: [Errno 2] No such file or directory: '/tmp/copy_tarball_out.txt'
> Traceback (most recent call last):
>   File "/Users/adiachenko/git/ambari-oss-mirror/ambari-common/src/main/python/resource_management/libraries/functions/copy_tarball.py", line 76, in _get_single_version_from_hdp_select
>     with open(tmp_file, 'r+') as file:
> IOError: [Errno 2] No such file or directory: '/tmp/copy_tarball_out.txt'
> 2015-12-02 16:16:57,097 - Could not parse output of /tmp/copy_tarball_out.txt. Error: [Errno 2] No such file or directory: '/tmp/copy_tarball_out.txt'
> Traceback (most recent call last):
>   File "/Users/adiachenko/git/ambari-oss-mirror/ambari-common/src/main/python/resource_management/libraries/functions/copy_tarball.py", line 76, in _get_single_version_from_hdp_select
>     with open(tmp_file, 'r+') as file:
> IOError: [Errno 2] No such file or directory: '/tmp/copy_tarball_out.txt'
> 2015-12-02 16:16:57,098 - Could not verify HDP version by calling '/usr/bin/hdp-select versions > /tmp/copy_tarball_out.txt'. Return Code: 0, Output: None.
> 2015-12-02 16:16:57,098 - Could not verify HDP version by calling '/usr/bin/hdp-select versions > /tmp/copy_tarball_out.txt'. Return Code: 0, Output: None.
> 2015-12-02 16:16:57,098 - Cannot copy slider tarball because unable to determine current version .
> ok
> 
> ----------------------------------------------------------------------
> Ran 5 tests in 0.089s
> 
> OK
> Running tests for stack:2.2 service:SPARK
> test_configure_default (test_job_history_server.TestJobHistoryServer) ... ok
> test_configure_secured (test_job_history_server.TestJobHistoryServer) ... ok
> test_pre_upgrade_restart_23 (test_job_history_server.TestJobHistoryServer) ... 2015-12-02 16:16:57,383 - Executing Spark Job History Server Stack Upgrade pre-restart
> 2015-12-02 16:16:57,383 - For package : spark, DIRS = [{'current_dir': '/usr/hdp/current/spark-client/conf', 'conf_dir': '/etc/spark/conf'}]
> 2015-12-02 16:16:57,384 - For package : spark, Source dir: /etc/spark/conf, Dest dir: /usr/hdp/current/spark-client/conf
> 2015-12-02 16:16:57,385 - After hdp-select spark-historyserver, reloaded module status_params
> 2015-12-02 16:16:57,388 - After hdp-select spark-historyserver, reloaded module params
> ok
> test_start_default (test_job_history_server.TestJobHistoryServer) ... ok
> test_start_secured (test_job_history_server.TestJobHistoryServer) ... ok
> test_stop_default (test_job_history_server.TestJobHistoryServer) ... ok
> test_stop_secured (test_job_history_server.TestJobHistoryServer) ... ok
> test_configure_default (test_spark_client.TestSparkClient) ... ok
> test_configure_secured (test_spark_client.TestSparkClient) ... ok
> test_pre_upgrade_restart_23 (test_spark_client.TestSparkClient) ... 2015-12-02 16:16:57,482 - Executing Spark Client Stack Upgrade pre-restart
> 2015-12-02 16:16:57,482 - For package : spark, DIRS = [{'current_dir': '/usr/hdp/current/spark-client/conf', 'conf_dir': '/etc/spark/conf'}]
> 2015-12-02 16:16:57,483 - For package : spark, Source dir: /etc/spark/conf, Dest dir: /usr/hdp/current/spark-client/conf
> 2015-12-02 16:16:57,484 - After hdp-select spark-client, reloaded module status_params
> 2015-12-02 16:16:57,487 - After hdp-select spark-client, reloaded module params
> ok
> test_service_check_default (test_spark_service_check.TestServiceCheck) ... ok
> test_service_check_secured (test_spark_service_check.TestServiceCheck) ... ok
> 
> ----------------------------------------------------------------------
> Ran 12 tests in 0.195s
> 
> OK
> Running tests for stack:2.3 service:ATLAS
> test_configure_default (test_metadata_server.TestMetadataServer) ... ok
> test_start_default (test_metadata_server.TestMetadataServer) ... ok
> test_stop_default (test_metadata_server.TestMetadataServer) ... ok
> 
> ----------------------------------------------------------------------
> Ran 3 tests in 0.052s
> 
> OK
> Running tests for stack:2.3 service:common
> test_createComponentLayoutRecommendations_hawq_1_Host (test_stack_advisor.TestHDP23StackAdvisor)
> Test that HAWQSTANDBY is not recommended on a single node cluster ... ok
> test_createComponentLayoutRecommendations_hawq_3_Hosts (test_stack_advisor.TestHDP23StackAdvisor)
> Test that HAWQSTANDBY is recommended on a 3-node cluster ... ok
> test_createComponentLayoutRecommendations_no_hawq_3_Hosts (test_stack_advisor.TestHDP23StackAdvisor)
> Test no failures when there are no HAWQ components ... ok
> test_getComponentLayoutValidations_hawq_3_Hosts (test_stack_advisor.TestHDP23StackAdvisor)
> Test layout validations for HAWQ components on a 3-node cluster ... ok
> test_getComponentLayoutValidations_nohawq_3_Hosts (test_stack_advisor.TestHDP23StackAdvisor)
> Test no failures when there are no HAWQ components on a 3-node cluster ... ok
> test_getComponentLayoutValidations_sparkts_no_hive (test_stack_advisor.TestHDP23StackAdvisor)
> Test SparkTS is picked when Hive is not installed ... ok
> test_getComponentLayoutValidations_sparkts_with_hive (test_stack_advisor.TestHDP23StackAdvisor)
> Test SparkTS is picked when Hive is installed ... ok
> test_noRiskyDictLookups (test_stack_advisor.TestHDP23StackAdvisor) ... max_inmemory_regions: -4.8
> Processing file: /Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/main/resources/stacks/HDP/2.3/services/../../../../common-services/AMBARI_METRICS/0.1.0/package/files/service-metrics/AMBARI_METRICS.txt
> Processing file: /Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/main/resources/stacks/HDP/2.3/services/../../../../common-services/AMBARI_METRICS/0.1.0/package/files/service-metrics/HBASE.txt
> Processing file: /Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/main/resources/stacks/HDP/2.3/services/../../../../common-services/AMBARI_METRICS/0.1.0/package/files/service-metrics/HDFS.txt
> Processing file: /Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/main/resources/stacks/HDP/2.3/services/../../../../common-services/AMBARI_METRICS/0.1.0/package/files/service-metrics/HOST.txt
> Processing file: /Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/main/resources/stacks/HDP/2.3/services/../../../../common-services/AMBARI_METRICS/0.1.0/package/files/service-metrics/KAFKA.txt
> Processing file: /Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/main/resources/stacks/HDP/2.3/services/../../../../common-services/AMBARI_METRICS/0.1.0/package/files/service-metrics/STORM.txt
> Processing file: /Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/main/resources/stacks/HDP/2.3/services/../../../../common-services/AMBARI_METRICS/0.1.0/package/files/service-metrics/YARN.txt
> metrics length: 272
> ok
> test_recommendHBASEConfigurations (test_stack_advisor.TestHDP23StackAdvisor) ... ok
> test_recommendHDFSConfigurations (test_stack_advisor.TestHDP23StackAdvisor) ... ok
> test_recommendHiveConfigurations (test_stack_advisor.TestHDP23StackAdvisor) ... ok
> test_recommendKAFKAConfigurations (test_stack_advisor.TestHDP23StackAdvisor) ... ok
> test_recommendRangerConfigurations (test_stack_advisor.TestHDP23StackAdvisor) ... ok
> test_recommendTezConfigurations (test_stack_advisor.TestHDP23StackAdvisor) ... ok
> test_recommendYARNConfigurations (test_stack_advisor.TestHDP23StackAdvisor) ... ok
> test_validateHiveConfigurations (test_stack_advisor.TestHDP23StackAdvisor) ... ok
> 
> ----------------------------------------------------------------------
> Ran 16 tests in 0.326s
> 
> OK
> Running tests for stack:2.3 service:MAHOUT
> test_configure_default (test_mahout_client.TestMahoutClient) ... ok
> test_pre_upgrade_restart (test_mahout_client.TestMahoutClient) ... 2015-12-02 16:16:58,374 - Executing Stack Upgrade pre-restart
> 2015-12-02 16:16:58,379 - After hdp-select mahout-client, reloaded module params
> ok
> test_pre_upgrade_restart_23 (test_mahout_client.TestMahoutClient) ... 2015-12-02 16:16:58,382 - Executing Stack Upgrade pre-restart
> 2015-12-02 16:16:58,385 - For package : mahout, DIRS = [{'current_dir': '/usr/hdp/current/mahout-client/conf', 'conf_dir': '/etc/mahout/conf'}]
> 2015-12-02 16:16:58,385 - For package : mahout, Source dir: /etc/mahout/conf, Dest dir: /usr/hdp/current/mahout-client/conf
> 2015-12-02 16:16:58,387 - After hdp-select mahout-client, reloaded module params
> ok
> test_configure_default (test_mahout_service_check.TestMahoutClient) ... ok
> 
> ----------------------------------------------------------------------
> Ran 4 tests in 0.036s
> 
> OK
> Running tests for stack:2.3 service:PXF
> test_configure_default (test_pxf.TestPxf) ... ok
> test_install_default (test_pxf.TestPxf) ... ok
> test_start_default (test_pxf.TestPxf) ... ok
> test_status_default (test_pxf.TestPxf) ... ok
> test_stop_default (test_pxf.TestPxf) ... ok
> 
> ----------------------------------------------------------------------
> Ran 5 tests in 0.032s
> 
> OK
> Running tests for stack:2.3 service:SPARK
> test_configure_default (test_spark_thrift_server.TestSparkThriftServer) ... ok
> test_pre_upgrade_restart_23 (test_spark_thrift_server.TestSparkThriftServer) ... 2015-12-02 16:16:58,797 - Executing Spark Thrift Server Stack Upgrade pre-restart
> 2015-12-02 16:16:58,798 - For package : spark, DIRS = [{'current_dir': '/usr/hdp/current/spark-client/conf', 'conf_dir': '/etc/spark/conf'}]
> 2015-12-02 16:16:58,798 - For package : spark, Source dir: /etc/spark/conf, Dest dir: /usr/hdp/current/spark-client/conf
> 2015-12-02 16:16:58,799 - After hdp-select spark-thriftserver, reloaded module status_params
> 2015-12-02 16:16:58,801 - After hdp-select spark-thriftserver, reloaded module params
> ok
> test_start_default (test_spark_thrift_server.TestSparkThriftServer) ... ok
> test_stop_default (test_spark_thrift_server.TestSparkThriftServer) ... ok
> 
> ----------------------------------------------------------------------
> Ran 4 tests in 0.074s
> 
> OK
> Running tests for stack:2.3 service:STORM
> test_service_check (test_service_check.TestStormServiceCheck) ... ok
> test_delete_zookeeper_data (test_storm_upgrade.TestStormUpgrade) ... 2015-12-02 16:16:59,007 - Clearing Storm data from ZooKeeper
> ok
> test_delete_zookeeper_data_jaas (test_storm_upgrade.TestStormUpgrade) ... 2015-12-02 16:16:59,015 - Clearing Storm data from ZooKeeper
> ok
> 
> ----------------------------------------------------------------------
> Ran 3 tests in 0.034s
> 
> OK
> Running tests for stack:2.3 service:YARN
> test_configure_default (test_ats_1_5.TestAts) ... ok
> 
> ----------------------------------------------------------------------
> Ran 1 test in 0.045s
> 
> OK
> Running tests for ambari-server
> 
> Running tests for custom actions
> test_execution (test_ru_execute_tasks.TestRUExecuteTasks) ... ok
> test_execution_custom_action (test_ru_execute_tasks.TestRUExecuteTasks) ... ok
> test_downgrade_unlink_configs (test_ru_set_all.TestRUSetAll) ... ok
> test_execution (test_ru_set_all.TestRUSetAll) ... ok
> test_execution_23 (test_ru_set_all.TestRUSetAll) ... ok
> test_unlink_configs_missing_backup (test_ru_set_all.TestRUSetAll) ... ok
> testDBConnectionCheck (TestCheckHost.TestCheckHost) ... No handlers could be found for logger "ambari_agent.HostCheckReportFileHandler"
> DB connection check started.
> Error downloading DBConnectionVerification.jar from Ambari Server resources. Check network access to Ambari Server.
> test exception
> DB connection check started.
> <MagicMock name='format().__add__()' id='4510883984'>
> DB connection check started.
> DB connection check started.
> DB connection check started.
> Custom java is not available on host. Please install it. Java home should be the same as on server. 
> 
> ok
> testHostResolution (TestCheckHost.TestCheckHost) ... IP address forward resolution check started.
> All hosts resolved to an IP address.
> IP address forward resolution check started.
> There were 5 host(s) that could not resolve to an IP address.
> ok
> testInvalidCheck (TestCheckHost.TestCheckHost) ... ok
> testJavaHomeAvailableCheck (TestCheckHost.TestCheckHost) ... Java home check started.
> Java home to check: test_java_home
> Java home exists!
> Java home check started.
> Java home to check: test_java_home
> Java home doesn't exist!
> ok
> testTransparentHugePage (TestCheckHost.TestCheckHost) ... ok
> testClearRepoCache (TestClearRepoCache.TestClearRepoCache) ... 2015-12-02 16:16:59,931 - Clear repository cache for the RedHat OS family
> 2015-12-02 16:16:59,931 - Clearing repository cache
> 2015-12-02 16:16:59,931 - call['/usr/bin/yum clean all'] {'sudo': True}
> 2015-12-02 16:16:59,964 - call returned (127, '/bin/bash: ambari-sudo.sh: command not found')
> ok
> test_exclude_existing_repo (TestInstallPackages.TestInstallPackages) ... 2015-12-02 16:16:59,975 - Will install packages for repository version 2.2.0.1-885
> 2015-12-02 16:16:59,977 - Attempting to determine actual version with build number.
> 2015-12-02 16:16:59,977 - Old versions: []
> 2015-12-02 16:16:59,977 - New versions: ['2.2.0.1-885']
> 2015-12-02 16:16:59,977 - Deltas: set(['2.2.0.1-885'])
> 2015-12-02 16:16:59,978 - Found actual version 2.2.0.1-885 by checking the delta between versions before and after installing packages
> 2015-12-02 16:16:59,978 - Cannot link configs unless HDP-2.3 or higher
> ok
> test_fail (TestInstallPackages.TestInstallPackages) ... 2015-12-02 16:16:59,985 - Will install packages for repository version 2.2.0.1-885
> 2015-12-02 16:16:59,990 - Package Manager failed to install packages. Error: side_effect() takes exactly 1 argument (2 given)
> Traceback (most recent call last):
>   File "/Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/test/python/stacks/utils/../../../../main/resources/custom_actions/scripts/install_packages.py", line 290, in install_packages
>     Package(self.get_base_packages_to_install())
>   File "/Users/adiachenko/git/ambari-oss-mirror/ambari-common/src/test/python/mock/mock.py", line 953, in __call__
>     return _mock_self._mock_call(*args, **kwargs)
>   File "/Users/adiachenko/git/ambari-oss-mirror/ambari-common/src/test/python/mock/mock.py", line 1016, in _mock_call
>     ret_val = effect(*args, **kwargs)
> TypeError: side_effect() takes exactly 1 argument (2 given)
> 2015-12-02 16:16:59,990 - Package Manager failed to install packages. Error: side_effect() takes exactly 1 argument (2 given)
> Traceback (most recent call last):
>   File "/Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/test/python/stacks/utils/../../../../main/resources/custom_actions/scripts/install_packages.py", line 290, in install_packages
>     Package(self.get_base_packages_to_install())
>   File "/Users/adiachenko/git/ambari-oss-mirror/ambari-common/src/test/python/mock/mock.py", line 953, in __call__
>     return _mock_self._mock_call(*args, **kwargs)
>   File "/Users/adiachenko/git/ambari-oss-mirror/ambari-common/src/test/python/mock/mock.py", line 1016, in _mock_call
>     ret_val = effect(*args, **kwargs)
> TypeError: side_effect() takes exactly 1 argument (2 given)
> 2015-12-02 16:16:59,993 - Installation of packages failed. Checking if installation was partially complete
> 2015-12-02 16:16:59,993 - Old versions: []
> 2015-12-02 16:16:59,993 - New versions: []
> 2015-12-02 16:16:59,994 - Deltas: set([])
> ok
> test_format_package_name (TestInstallPackages.TestInstallPackages) ... 2015-12-02 16:16:59,999 - Will install packages for repository version 2.2.0.1-885
> 2015-12-02 16:17:00,003 - Attempting to determine actual version with build number.
> 2015-12-02 16:17:00,003 - Old versions: []
> 2015-12-02 16:17:00,004 - New versions: ['2.2.0.1-885']
> 2015-12-02 16:17:00,004 - Deltas: set(['2.2.0.1-885'])
> 2015-12-02 16:17:00,004 - Found actual version 2.2.0.1-885 by checking the delta between versions before and after installing packages
> 2015-12-02 16:17:00,005 - Cannot link configs unless HDP-2.3 or higher
> ok
> test_normal_flow_rhel (TestInstallPackages.TestInstallPackages) ... 2015-12-02 16:17:00,013 - Will install packages for repository version 2.2.0.1-885
> 2015-12-02 16:17:00,015 - Attempting to determine actual version with build number.
> 2015-12-02 16:17:00,015 - Old versions: []
> 2015-12-02 16:17:00,015 - New versions: ['2.2.0.1-885']
> 2015-12-02 16:17:00,015 - Deltas: set(['2.2.0.1-885'])
> 2015-12-02 16:17:00,016 - Found actual version 2.2.0.1-885 by checking the delta between versions before and after installing packages
> 2015-12-02 16:17:00,016 - Cannot link configs unless HDP-2.3 or higher
> ok
> test_normal_flow_sles (TestInstallPackages.TestInstallPackages) ... 2015-12-02 16:17:00,024 - Will install packages for repository version 2.2.0.1-885
> 2015-12-02 16:17:00,026 - Attempting to determine actual version with build number.
> 2015-12-02 16:17:00,026 - Old versions: []
> 2015-12-02 16:17:00,027 - New versions: ['2.2.0.1-885']
> 2015-12-02 16:17:00,027 - Deltas: set(['2.2.0.1-885'])
> 2015-12-02 16:17:00,027 - Found actual version 2.2.0.1-885 by checking the delta between versions before and after installing packages
> 2015-12-02 16:17:00,027 - Cannot link configs unless HDP-2.3 or higher
> ok
> test_version_reporting__build_number_defined (TestInstallPackages.TestInstallPackages) ... 2015-12-02 16:17:00,033 - Will install packages for repository version 2.2.0.1-885
> 2015-12-02 16:17:00,035 - Attempting to determine actual version with build number.
> 2015-12-02 16:17:00,036 - Old versions: ['2.1.0.0-400']
> 2015-12-02 16:17:00,036 - New versions: ['2.1.0.0-400', '2.2.0.1-885']
> 2015-12-02 16:17:00,036 - Deltas: set(['2.2.0.1-885'])
> 2015-12-02 16:17:00,036 - Found actual version 2.2.0.1-885 by checking the delta between versions before and after installing packages
> 2015-12-02 16:17:00,036 - Cannot link configs unless HDP-2.3 or higher
> 2015-12-02 16:17:00,040 - Will install packages for repository version 2.2.0.1-885
> 2015-12-02 16:17:00,041 - Attempting to determine actual version with build number.
> 2015-12-02 16:17:00,041 - Old versions: ['2.1.0.0-400', '2.2.0.1-885']
> 2015-12-02 16:17:00,041 - New versions: ['2.1.0.0-400', '2.2.0.1-885']
> 2015-12-02 16:17:00,041 - Deltas: set([])
> 2015-12-02 16:17:00,041 - Cannot determine actual version installed by checking the delta between versions before and after installing package
> 2015-12-02 16:17:00,041 - Will try to find for the actual version by searching for best possible match in the list of versions installed
> 2015-12-02 16:17:00,041 - Best Fit Version: Resolved from repo version with valid build number: 2.2.0.1-885
> 2015-12-02 16:17:00,041 - Found actual version 2.2.0.1-885 by searching for best possible match
> 2015-12-02 16:17:00,041 - Cannot link configs unless HDP-2.3 or higher
> ok
> test_version_reporting__build_number_not_defined__usr_hdp_absent (TestInstallPackages.TestInstallPackages) ... 2015-12-02 16:17:00,046 - Will install packages for repository version 2.2.0.1
> 2015-12-02 16:17:00,047 - Attempting to determine actual version with build number.
> 2015-12-02 16:17:00,047 - Old versions: []
> 2015-12-02 16:17:00,047 - New versions: []
> 2015-12-02 16:17:00,047 - Deltas: set([])
> 2015-12-02 16:17:00,047 - Cannot determine actual version installed by checking the delta between versions before and after installing package
> 2015-12-02 16:17:00,047 - Will try to find for the actual version by searching for best possible match in the list of versions installed
> 2015-12-02 16:17:00,047 - Failure while computing actual version. Error: Could not determine actual version installed. Try reinstalling packages again.
> Traceback (most recent call last):
>   File "/Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/test/python/stacks/utils/../../../../main/resources/custom_actions/scripts/install_packages.py", line 325, in install_packages
>     self.compute_actual_version()
>   File "/Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/test/python/stacks/utils/../../../../main/resources/custom_actions/scripts/install_packages.py", line 210, in compute_actual_version
>     raise Fail(msg)
> Fail: Could not determine actual version installed. Try reinstalling packages again.
> 2015-12-02 16:17:00,047 - Failure while computing actual version. Error: Could not determine actual version installed. Try reinstalling packages again.
> Traceback (most recent call last):
>   File "/Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/test/python/stacks/utils/../../../../main/resources/custom_actions/scripts/install_packages.py", line 325, in install_packages
>     self.compute_actual_version()
>   File "/Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/test/python/stacks/utils/../../../../main/resources/custom_actions/scripts/install_packages.py", line 210, in compute_actual_version
>     raise Fail(msg)
> Fail: Could not determine actual version installed. Try reinstalling packages again.
> 2015-12-02 16:17:00,050 - Will install packages for repository version 2.2.0.1-885
> 2015-12-02 16:17:00,051 - Attempting to determine actual version with build number.
> 2015-12-02 16:17:00,051 - Old versions: []
> 2015-12-02 16:17:00,051 - New versions: []
> 2015-12-02 16:17:00,051 - Deltas: set([])
> 2015-12-02 16:17:00,051 - Cannot determine actual version installed by checking the delta between versions before and after installing package
> 2015-12-02 16:17:00,051 - Will try to find for the actual version by searching for best possible match in the list of versions installed
> 2015-12-02 16:17:00,051 - Failure while computing actual version. Error: Could not determine actual version installed. Try reinstalling packages again.
> Traceback (most recent call last):
>   File "/Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/test/python/stacks/utils/../../../../main/resources/custom_actions/scripts/install_packages.py", line 325, in install_packages
>     self.compute_actual_version()
>   File "/Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/test/python/stacks/utils/../../../../main/resources/custom_actions/scripts/install_packages.py", line 210, in compute_actual_version
>     raise Fail(msg)
> Fail: Could not determine actual version installed. Try reinstalling packages again.
> 2015-12-02 16:17:00,051 - Failure while computing actual version. Error: Could not determine actual version installed. Try reinstalling packages again.
> Traceback (most recent call last):
>   File "/Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/test/python/stacks/utils/../../../../main/resources/custom_actions/scripts/install_packages.py", line 325, in install_packages
>     self.compute_actual_version()
>   File "/Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/test/python/stacks/utils/../../../../main/resources/custom_actions/scripts/install_packages.py", line 210, in compute_actual_version
>     raise Fail(msg)
> Fail: Could not determine actual version installed. Try reinstalling packages again.
> ok
> test_version_reporting__build_number_not_defined__usr_hdp_present (TestInstallPackages.TestInstallPackages) ... 2015-12-02 16:17:00,055 - Will install packages for repository version 2.2.0.1
> 2015-12-02 16:17:00,056 - Attempting to determine actual version with build number.
> 2015-12-02 16:17:00,057 - Old versions: ['2.1.0.0-400']
> 2015-12-02 16:17:00,057 - New versions: ['2.1.0.0-400', '2.2.0.1-885']
> 2015-12-02 16:17:00,057 - Deltas: set(['2.2.0.1-885'])
> 2015-12-02 16:17:00,057 - Found actual version 2.2.0.1-885 by checking the delta between versions before and after installing packages
> 2015-12-02 16:17:00,057 - Cannot link configs unless HDP-2.3 or higher
> 2015-12-02 16:17:00,060 - Will install packages for repository version 2.2.0.1
> 2015-12-02 16:17:00,061 - Attempting to determine actual version with build number.
> 2015-12-02 16:17:00,061 - Old versions: ['2.1.0.0-400', '2.2.0.1-885']
> 2015-12-02 16:17:00,061 - New versions: ['2.1.0.0-400', '2.2.0.1-885']
> 2015-12-02 16:17:00,061 - Deltas: set([])
> 2015-12-02 16:17:00,062 - Cannot determine actual version installed by checking the delta between versions before and after installing package
> 2015-12-02 16:17:00,062 - Will try to find for the actual version by searching for best possible match in the list of versions installed
> 2015-12-02 16:17:00,062 - Best Fit Version: Resolved from normalized repo version without conflicts: 2.2.0.1-885
> 2015-12-02 16:17:00,062 - Found actual version 2.2.0.1-885 by searching for best possible match
> 2015-12-02 16:17:00,062 - Cannot link configs unless HDP-2.3 or higher
> ok
> test_version_reporting__build_number_not_defined__usr_hdp_present__no_components_installed (TestInstallPackages.TestInstallPackages) ... 2015-12-02 16:17:00,079 - Will install packages for repository version 2.2.0.1
> 2015-12-02 16:17:00,080 - Attempting to determine actual version with build number.
> 2015-12-02 16:17:00,080 - Old versions: []
> 2015-12-02 16:17:00,080 - New versions: []
> 2015-12-02 16:17:00,081 - Deltas: set([])
> 2015-12-02 16:17:00,081 - Cannot determine actual version installed by checking the delta between versions before and after installing package
> 2015-12-02 16:17:00,081 - Will try to find for the actual version by searching for best possible match in the list of versions installed
> 2015-12-02 16:17:00,081 - Failure while computing actual version. Error: Could not determine actual version installed. Try reinstalling packages again.
> Traceback (most recent call last):
>   File "/Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/test/python/stacks/utils/../../../../main/resources/custom_actions/scripts/install_packages.py", line 325, in install_packages
>     self.compute_actual_version()
>   File "/Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/test/python/stacks/utils/../../../../main/resources/custom_actions/scripts/install_packages.py", line 210, in compute_actual_version
>     raise Fail(msg)
> Fail: Could not determine actual version installed. Try reinstalling packages again.
> 2015-12-02 16:17:00,081 - Failure while computing actual version. Error: Could not determine actual version installed. Try reinstalling packages again.
> Traceback (most recent call last):
>   File "/Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/test/python/stacks/utils/../../../../main/resources/custom_actions/scripts/install_packages.py", line 325, in install_packages
>     self.compute_actual_version()
>   File "/Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/test/python/stacks/utils/../../../../main/resources/custom_actions/scripts/install_packages.py", line 210, in compute_actual_version
>     raise Fail(msg)
> Fail: Could not determine actual version installed. Try reinstalling packages again.
> ok
> test_version_reporting__wrong_build_number_specified__usr_hdp_absent (TestInstallPackages.TestInstallPackages) ... 2015-12-02 16:17:00,085 - Will install packages for repository version 2.2.0.1
> 2015-12-02 16:17:00,086 - Attempting to determine actual version with build number.
> 2015-12-02 16:17:00,086 - Old versions: []
> 2015-12-02 16:17:00,086 - New versions: []
> 2015-12-02 16:17:00,086 - Deltas: set([])
> 2015-12-02 16:17:00,086 - Cannot determine actual version installed by checking the delta between versions before and after installing package
> 2015-12-02 16:17:00,086 - Will try to find for the actual version by searching for best possible match in the list of versions installed
> 2015-12-02 16:17:00,086 - Failure while computing actual version. Error: Could not determine actual version installed. Try reinstalling packages again.
> Traceback (most recent call last):
>   File "/Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/test/python/stacks/utils/../../../../main/resources/custom_actions/scripts/install_packages.py", line 325, in install_packages
>     self.compute_actual_version()
>   File "/Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/test/python/stacks/utils/../../../../main/resources/custom_actions/scripts/install_packages.py", line 210, in compute_actual_version
>     raise Fail(msg)
> Fail: Could not determine actual version installed. Try reinstalling packages again.
> 2015-12-02 16:17:00,086 - Failure while computing actual version. Error: Could not determine actual version installed. Try reinstalling packages again.
> Traceback (most recent call last):
>   File "/Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/test/python/stacks/utils/../../../../main/resources/custom_actions/scripts/install_packages.py", line 325, in install_packages
>     self.compute_actual_version()
>   File "/Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/test/python/stacks/utils/../../../../main/resources/custom_actions/scripts/install_packages.py", line 210, in compute_actual_version
>     raise Fail(msg)
> Fail: Could not determine actual version installed. Try reinstalling packages again.
> 2015-12-02 16:17:00,089 - Will install packages for repository version 2.2.0.1-885
> 2015-12-02 16:17:00,090 - Attempting to determine actual version with build number.
> 2015-12-02 16:17:00,090 - Old versions: []
> 2015-12-02 16:17:00,090 - New versions: []
> 2015-12-02 16:17:00,090 - Deltas: set([])
> 2015-12-02 16:17:00,090 - Cannot determine actual version installed by checking the delta between versions before and after installing package
> 2015-12-02 16:17:00,090 - Will try to find for the actual version by searching for best possible match in the list of versions installed
> 2015-12-02 16:17:00,090 - Failure while computing actual version. Error: Could not determine actual version installed. Try reinstalling packages again.
> Traceback (most recent call last):
>   File "/Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/test/python/stacks/utils/../../../../main/resources/custom_actions/scripts/install_packages.py", line 325, in install_packages
>     self.compute_actual_version()
>   File "/Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/test/python/stacks/utils/../../../../main/resources/custom_actions/scripts/install_packages.py", line 210, in compute_actual_version
>     raise Fail(msg)
> Fail: Could not determine actual version installed. Try reinstalling packages again.
> 2015-12-02 16:17:00,090 - Failure while computing actual version. Error: Could not determine actual version installed. Try reinstalling packages again.
> Traceback (most recent call last):
>   File "/Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/test/python/stacks/utils/../../../../main/resources/custom_actions/scripts/install_packages.py", line 325, in install_packages
>     self.compute_actual_version()
>   File "/Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/test/python/stacks/utils/../../../../main/resources/custom_actions/scripts/install_packages.py", line 210, in compute_actual_version
>     raise Fail(msg)
> Fail: Could not determine actual version installed. Try reinstalling packages again.
> ok
> test_version_reporting__wrong_build_number_specified__usr_hdp_present (TestInstallPackages.TestInstallPackages) ... 2015-12-02 16:17:00,094 - Will install packages for repository version 2.2.0.1-500
> 2015-12-02 16:17:00,095 - Attempting to determine actual version with build number.
> 2015-12-02 16:17:00,095 - Old versions: ['2.1.0.0-400']
> 2015-12-02 16:17:00,095 - New versions: ['2.1.0.0-400', '2.2.0.1-885']
> 2015-12-02 16:17:00,095 - Deltas: set(['2.2.0.1-885'])
> 2015-12-02 16:17:00,097 - Found actual version 2.2.0.1-885 by checking the delta between versions before and after installing packages
> 2015-12-02 16:17:00,097 - Cannot link configs unless HDP-2.3 or higher
> 2015-12-02 16:17:00,099 - Will install packages for repository version 2.2.0.1-500
> 2015-12-02 16:17:00,100 - Attempting to determine actual version with build number.
> 2015-12-02 16:17:00,100 - Old versions: ['2.1.0.0-400', '2.2.0.1-885']
> 2015-12-02 16:17:00,101 - New versions: ['2.1.0.0-400', '2.2.0.1-885']
> 2015-12-02 16:17:00,101 - Deltas: set([])
> 2015-12-02 16:17:00,101 - Cannot determine actual version installed by checking the delta between versions before and after installing package
> 2015-12-02 16:17:00,101 - Will try to find for the actual version by searching for best possible match in the list of versions installed
> 2015-12-02 16:17:00,101 - Best Fit Version: Resolved from normalized repo version without conflicts: 2.2.0.1-885
> 2015-12-02 16:17:00,101 - Found actual version 2.2.0.1-885 by searching for best possible match
> 2015-12-02 16:17:00,101 - Cannot link configs unless HDP-2.3 or higher
> ok
> test_read_and_write_repo_version_history (TestRepoVersionHistory.TestRepoVersionHistory) ... ok
> testUpdateRepo (TestUpdateRepo.TestUpdateRepo) ... 2015-12-02 16:17:00,111 - Repository['TEST_REPO_ID'] {'base_url': 'TEST_BASE_URL', 'action': ['create'], 'components': [u'TEST_REPO_NAME', 'main'], 'repo_template': 'REPO_SUSE_RHEL_TEST_TEMPLATE', 'repo_file_name': 'TEST_REPO_NAME', 'mirror_list': None}
> 2015-12-02 16:17:00,114 - ERROR: There was an unexpected error while updating repositories
> Traceback (most recent call last):
>   File "/Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/main/resources/custom_actions/scripts/update_repo.py", line 43, in actionexecute
>     for item in repo_info_dict["repositories"]:
> KeyError: 'repositories'
> 2015-12-02 16:17:00,114 - ERROR: There was an unexpected error while updating repositories
> Traceback (most recent call last):
>   File "/Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/main/resources/custom_actions/scripts/update_repo.py", line 43, in actionexecute
>     for item in repo_info_dict["repositories"]:
> KeyError: 'repositories'
> ok
> 
> ----------------------------------------------------------------------
> Ran 25 tests in 0.295s
> 
> OK
> 
> Running tests for host scripts
> test_linux_flow (TestAlertDiskSpace.TestAlertDiskSpace) ... ok
> 
> ----------------------------------------------------------------------
> Ran 1 test in 0.001s
> 
> OK
> 
> Running tests for ambari-server
> test_adjust_directory_permissions (TestAmbariServer.TestAmbariServer) ... ok
> test_backup (TestAmbariServer.TestAmbariServer) ... ok
> test_backup_no_path (TestAmbariServer.TestAmbariServer) ... ok
> test_change_objects_owner_both (TestAmbariServer.TestAmbariServer) ... ok
> test_change_objects_owner_only_stderr (TestAmbariServer.TestAmbariServer) ... ok
> test_change_objects_owner_only_stdout (TestAmbariServer.TestAmbariServer) ... ok
> test_check_database_name_property (TestAmbariServer.TestAmbariServer) ... ok
> test_check_firewall_is_running (TestAmbariServer.TestAmbariServer) ... ok
> test_check_jdbc_drivers (TestAmbariServer.TestAmbariServer) ... ok
> test_check_postgre_up (TestAmbariServer.TestAmbariServer) ... ok
> test_check_selinux (TestAmbariServer.TestAmbariServer) ... ok
> test_configure_database_password (TestAmbariServer.TestAmbariServer) ... ok
> test_configure_database_password_silent (TestAmbariServer.TestAmbariServer) ... ok
> test_configure_database_username_password_masterkey_persisted (TestAmbariServer.TestAmbariServer) ... ok
> test_configure_ldap_password (TestAmbariServer.TestAmbariServer) ... ok
> test_configure_os_settings (TestAmbariServer.TestAmbariServer) ... ok
> test_configure_pg_hba_ambaridb_users (TestAmbariServer.TestAmbariServer) ... ok
> test_configure_pg_hba_postgres_user (TestAmbariServer.TestAmbariServer) ... ok
> test_configure_postgres (TestAmbariServer.TestAmbariServer) ... ok
> test_configure_postgresql_conf (TestAmbariServer.TestAmbariServer) ... ok
> test_copy_file (TestAmbariServer.TestAmbariServer) ... ok
> test_dbname_regex (TestAmbariServer.TestAmbariServer)
> Test to make sure the service name can contain digits ... ok
> test_download_jdk (TestAmbariServer.TestAmbariServer) ... ok
> test_ensure_jdbc_drivers_installed (TestAmbariServer.TestAmbariServer) ... ok
> test_find_jdk (TestAmbariServer.TestAmbariServer) ... ok
> test_find_properties_file (TestAmbariServer.TestAmbariServer) ... ok
> test_fix_database_options_called (TestAmbariServer.TestAmbariServer) ... ok
> test_generate_random_string (TestAmbariServer.TestAmbariServer) ... ok
> test_get_JAVA_HOME (TestAmbariServer.TestAmbariServer) ... ok
> test_get_YN_input (TestAmbariServer.TestAmbariServer) ... ok
> test_get_cert_info (TestAmbariServer.TestAmbariServer) ... ok
> test_get_choice_string_input (TestAmbariServer.TestAmbariServer) ... ok
> test_get_fqdn (TestAmbariServer.TestAmbariServer) ... ok
> test_get_ldap_event_spec_names (TestAmbariServer.TestAmbariServer) ... ok
> test_get_pass_file_path (TestAmbariServer.TestAmbariServer) ... ok
> test_get_postgre_status (TestAmbariServer.TestAmbariServer) ... ok
> test_get_ulimit_open_files (TestAmbariServer.TestAmbariServer) ... ok
> test_get_validated_string_input (TestAmbariServer.TestAmbariServer) ... ok
> test_import_cert_and_key (TestAmbariServer.TestAmbariServer) ... ok
> test_import_cert_and_key_action (TestAmbariServer.TestAmbariServer) ... ok
> test_import_cert_and_key_with_empty_password (TestAmbariServer.TestAmbariServer) ... ok
> test_import_cert_and_key_with_incorrect_password (TestAmbariServer.TestAmbariServer) ... ok
> test_is_jdbc_user_changed (TestAmbariServer.TestAmbariServer) ... ok
> test_is_server_runing_bad_file (TestAmbariServer.TestAmbariServer) ... ok
> test_is_valid_cert_exp (TestAmbariServer.TestAmbariServer) ... ok
> test_is_valid_cert_host (TestAmbariServer.TestAmbariServer) ... ok
> test_is_valid_filepath (TestAmbariServer.TestAmbariServer) ... ok
> test_is_valid_https_port (TestAmbariServer.TestAmbariServer) ... ok
> test_ldap_sync_all (TestAmbariServer.TestAmbariServer) ... ok
> test_ldap_sync_error_status (TestAmbariServer.TestAmbariServer) ... ok
> test_ldap_sync_existing (TestAmbariServer.TestAmbariServer) ... ok
> test_ldap_sync_groups (TestAmbariServer.TestAmbariServer) ... ok
> test_ldap_sync_no_sync_mode (TestAmbariServer.TestAmbariServer) ... ok
> test_ldap_sync_ssl (TestAmbariServer.TestAmbariServer) ... ok
> test_ldap_sync_users (TestAmbariServer.TestAmbariServer) ... ok
> test_main_test_backup (TestAmbariServer.TestAmbariServer) ... ok
> test_main_test_reset (TestAmbariServer.TestAmbariServer) ... ok
> test_main_test_restore (TestAmbariServer.TestAmbariServer) ... ok
> test_main_test_setup (TestAmbariServer.TestAmbariServer) ... ok
> test_main_test_setup_security (TestAmbariServer.TestAmbariServer) ... ok
> test_main_test_start (TestAmbariServer.TestAmbariServer) ... ok
> test_main_test_status_not_running (TestAmbariServer.TestAmbariServer) ... ok
> test_main_test_status_running (TestAmbariServer.TestAmbariServer) ... ok
> test_main_with_preset_dbms (TestAmbariServer.TestAmbariServer) ... ok
> test_move_user_custom_actions (TestAmbariServer.TestAmbariServer) ... ok
> test_parse_properties_file (TestAmbariServer.TestAmbariServer) ... ok
> test_print_error_msg (TestAmbariServer.TestAmbariServer) ... ok
> test_print_info_msg (TestAmbariServer.TestAmbariServer) ... ok
> test_print_warning_msg (TestAmbariServer.TestAmbariServer) ... ok
> test_prompt_db_properties (TestAmbariServer.TestAmbariServer) ... ok
> test_prompt_db_properties_default (TestAmbariServer.TestAmbariServer) ... ok
> test_prompt_db_properties_for_each_database_type (TestAmbariServer.TestAmbariServer) ... ok
> test_prompt_db_properties_oracle_sname (TestAmbariServer.TestAmbariServer) ... ok
> test_prompt_db_properties_postgre_adv (TestAmbariServer.TestAmbariServer) ... ok
> test_read_active_instance (TestAmbariServer.TestAmbariServer) ... ok
> test_read_ambari_user (TestAmbariServer.TestAmbariServer) ... ok
> test_read_password (TestAmbariServer.TestAmbariServer) ... ok
> test_refresh_stack_hash (TestAmbariServer.TestAmbariServer) ... ok
> test_regexps (TestAmbariServer.TestAmbariServer) ... ok
> test_remove_file (TestAmbariServer.TestAmbariServer) ... ok
> test_reset_default (TestAmbariServer.TestAmbariServer) ... ok
> test_reset_master_key_not_persisted (TestAmbariServer.TestAmbariServer) ... ok
> test_reset_master_key_persisted (TestAmbariServer.TestAmbariServer) ... ok
> test_restart_postgres (TestAmbariServer.TestAmbariServer) ... ok
> test_restore (TestAmbariServer.TestAmbariServer) ... ok
> test_restore_no_path (TestAmbariServer.TestAmbariServer) ... ok
> test_run_metainfo_upgrade (TestAmbariServer.TestAmbariServer) ... ok
> test_run_schema_upgrade (TestAmbariServer.TestAmbariServer) ... ok
> test_run_stack_upgrade (TestAmbariServer.TestAmbariServer) ... ok
> test_run_stack_upgrade_with_url_os (TestAmbariServer.TestAmbariServer) ... ok
> test_search_file (TestAmbariServer.TestAmbariServer) ... ok
> test_servicename_regex (TestAmbariServer.TestAmbariServer)
> Test to make sure the service name can contain digits ... ok
> test_set_file_permissions (TestAmbariServer.TestAmbariServer) ... ok
> test_setup_ambari_krb5_jaas (TestAmbariServer.TestAmbariServer) ... ok
> test_setup_db (TestAmbariServer.TestAmbariServer) ... ok
> test_setup_db_connect_attempts_fail (TestAmbariServer.TestAmbariServer) ... ok
> test_setup_db_connect_attempts_success (TestAmbariServer.TestAmbariServer) ... ok
> test_setup_https (TestAmbariServer.TestAmbariServer) ... ok
> test_setup_jce_policy (TestAmbariServer.TestAmbariServer) ... ok
> test_setup_ldap (TestAmbariServer.TestAmbariServer) ... ok
> test_setup_ldap_invalid_input (TestAmbariServer.TestAmbariServer) ... ok
> test_setup_master_key_not_persist (TestAmbariServer.TestAmbariServer) ... ok
> test_setup_master_key_persist (TestAmbariServer.TestAmbariServer) ... ok
> test_setup_remote_db_wo_client (TestAmbariServer.TestAmbariServer) ... ok
> test_setup_security (TestAmbariServer.TestAmbariServer) ... ok
> test_setup_truststore (TestAmbariServer.TestAmbariServer) ... ok
> test_start (TestAmbariServer.TestAmbariServer) ... ok
> test_store_password_file (TestAmbariServer.TestAmbariServer) ... ok
> test_store_remote_properties (TestAmbariServer.TestAmbariServer) ... ok
> test_sync_ldap_ambari_stopped (TestAmbariServer.TestAmbariServer) ... ok
> test_sync_ldap_forbidden (TestAmbariServer.TestAmbariServer) ... ok
> test_sync_ldap_not_configured (TestAmbariServer.TestAmbariServer) ... ok
> test_unpack_jce_policy (TestAmbariServer.TestAmbariServer) ... ok
> test_update_ambari_properties (TestAmbariServer.TestAmbariServer) ... ok
> test_update_ambari_properties_negative_case (TestAmbariServer.TestAmbariServer) ... ok
> test_update_ambari_properties_without_some_properties (TestAmbariServer.TestAmbariServer) ... ok
> test_update_host_names (TestAmbariServer.TestAmbariServer) ... ok
> test_update_properties_2 (TestAmbariServer.TestAmbariServer) ... ok
> test_upgrade_from_161 (TestAmbariServer.TestAmbariServer) ... ok
> test_upgrade_local_repo (TestAmbariServer.TestAmbariServer) ... ok
> test_upgrade_local_repo_nochange (TestAmbariServer.TestAmbariServer) ... ok
> test_upgrade_stack (TestAmbariServer.TestAmbariServer) ... ok
> test_validate_jdk (TestAmbariServer.TestAmbariServer) ... ok
> test_perform_backup (TestBackupRestore.TestBKRestore) ... Creating zip file...
> <MagicMock name='mock.__radd__().__add__()' id='4518114640'>
> Creating zip file...
> ok
> test_perform_restore (TestBackupRestore.TestBKRestore) ... <MagicMock name='mock.__radd__().__add__()' id='4525249680'>
> <MagicMock name='mock.__radd__().__add__()' id='4525249680'>
> ok
> test_PBootstrap (TestBootstrap.TestBootstrap) ... ok
> test_SCP (TestBootstrap.TestBootstrap) ... ok
> test_SSH (TestBootstrap.TestBootstrap) ... ok
> test_agent_setup_command_without_project_version (TestBootstrap.TestBootstrap) ... ok
> test_bootstrap_main (TestBootstrap.TestBootstrap) ... ok
> test_changePasswordFileModeOnHost (TestBootstrap.TestBootstrap) ... ok
> test_checkSudoPackage (TestBootstrap.TestBootstrap) ... ok
> test_checkSudoPackageUbuntu (TestBootstrap.TestBootstrap) ... ok
> test_copyNeededFiles (TestBootstrap.TestBootstrap) ... ok
> test_copyOsCheckScript (TestBootstrap.TestBootstrap) ... ok
> test_copyPasswordFile (TestBootstrap.TestBootstrap) ... ok
> test_createDoneFile (TestBootstrap.TestBootstrap) ... ok
> test_createTargetDir (TestBootstrap.TestBootstrap) ... ok
> test_deletePasswordFile (TestBootstrap.TestBootstrap) ... ok
> test_generateRandomFileName (TestBootstrap.TestBootstrap) ... ok
> test_getAmbariPort (TestBootstrap.TestBootstrap) ... ok
> test_getOsCheckScript (TestBootstrap.TestBootstrap) ... ok
> test_getOsCheckScriptRemoteLocation (TestBootstrap.TestBootstrap) ... ok
> test_getRemoteName (TestBootstrap.TestBootstrap) ... ok
> test_getRepoDir (TestBootstrap.TestBootstrap) ... ok
> test_getRepoFile (TestBootstrap.TestBootstrap) ... ok
> test_getRunSetupCommand (TestBootstrap.TestBootstrap) ... ok
> test_getRunSetupWithPasswordCommand (TestBootstrap.TestBootstrap) ... ok
> test_getSetupScript (TestBootstrap.TestBootstrap) ... ok
> test_host_log (TestBootstrap.TestBootstrap) ... ok
> test_interruptBootstrap (TestBootstrap.TestBootstrap) ... ok
> test_run (TestBootstrap.TestBootstrap) ... ok
> test_runOsCheckScript (TestBootstrap.TestBootstrap) ... ok
> test_runSetupAgent (TestBootstrap.TestBootstrap) ... ok
> test_run_setup_agent_command_ends_with_project_version (TestBootstrap.TestBootstrap) ... ok
> test_try_to_execute (TestBootstrap.TestBootstrap) ... ok
> test_exportBlueprint (TestClusterBlueprint.TestClusterBlueprint) ... ok
> test_importBlueprint (TestClusterBlueprint.TestClusterBlueprint) ... ok
> test_delete_config (TestConfigs.TestConfigs) ... ok
> test_delete_config_with_attributes (TestConfigs.TestConfigs) ... ok
> test_get_config_to_file (TestConfigs.TestConfigs) ... ok
> test_update_from_file (TestConfigs.TestConfigs) ... ok
> test_update_specific_config (TestConfigs.TestConfigs) ... ok
> test_update_specific_config_with_attributes (TestConfigs.TestConfigs) ... ok
> test_get_os_family (TestOSCheck.TestOSCheck) ... ok
> test_get_os_major_version (TestOSCheck.TestOSCheck) ... ok
> test_get_os_release_name (TestOSCheck.TestOSCheck) ... ok
> test_get_os_type (TestOSCheck.TestOSCheck) ... ok
> test_get_os_version (TestOSCheck.TestOSCheck) ... ok
> test_is_redhat_family (TestOSCheck.TestOSCheck) ... ok
> test_is_suse_family (TestOSCheck.TestOSCheck) ... ok
> test_os_type_check (TestOSCheck.TestOSCheck) ... Cluster primary/cluster OS family is aaa11 and local/current OS family is aaa11
> Cluster primary/cluster OS family is zzz_x77 and local/current OS family is ddd33
> ok
> test_update_ambari_properties_os (TestOSCheck.TestOSCheck) ... WARNING: Can not find /var/folders/n2/5p3wjp350jgbzprbf7kxkx6c0000gp/T/ambari-test/tmp5RscUX file from previous version, skipping import of settings
> ok
> test_count_hash_sum (TestResourceFilesKeeper.TestResourceFilesKeeper) ... ok
> test_is_ignored (TestResourceFilesKeeper.TestResourceFilesKeeper) ... ok
> test_list_common_services (TestResourceFilesKeeper.TestResourceFilesKeeper) ... ok
> test_list_stacks (TestResourceFilesKeeper.TestResourceFilesKeeper) ... ok
> test_perform_housekeeping (TestResourceFilesKeeper.TestResourceFilesKeeper) ... ok
> test_read_hash_sum (TestResourceFilesKeeper.TestResourceFilesKeeper) ... ok
> test_update_directory_archieves (TestResourceFilesKeeper.TestResourceFilesKeeper) ... ok
> test_update_directory_archive (TestResourceFilesKeeper.TestResourceFilesKeeper) ... ok
> test_write_hash_sum (TestResourceFilesKeeper.TestResourceFilesKeeper) ... ok
> test_zip_directory (TestResourceFilesKeeper.TestResourceFilesKeeper) ... ok
> test_server_class_path_custom_env_classpath (TestServerClassPath.TestConfigs) ... INFO: AMBARI_SERVER_LIB is not set, using default /usr/lib/ambari-server
> ok
> test_server_class_path_custom_jar (TestServerClassPath.TestConfigs) ... ok
> test_server_class_path_custom_jdbc_path (TestServerClassPath.TestConfigs) ... INFO: AMBARI_SERVER_LIB is not set, using default /usr/lib/ambari-server
> ok
> test_server_class_path_default (TestServerClassPath.TestConfigs) ... INFO: AMBARI_SERVER_LIB is not set, using default /usr/lib/ambari-server
> ok
> testCurrentVersionOptions (TestServerUpgrade.TestServerUpgrade) ... ok
> test_set_current (TestServerUpgrade.TestServerUpgrade) ... 
> Calling API http://127.0.0.1:8080/api/v1/clusters/cc/stack_versions : {'ClusterStackVersions': {'state': 'CURRENT', 'repository_version': 'HDP-2.2.2.0-2561', 'force': False}}
> 
> Current version successfully updated to HDP-2.2.2.0-2561
> ok
> test_set_current_with_force (TestServerUpgrade.TestServerUpgrade) ... 
> Calling API http://127.0.0.1:8080/api/v1/clusters/cc/stack_versions : {'ClusterStackVersions': {'state': 'CURRENT', 'repository_version': 'HDP-2.2.2.0-2561', 'force': True}}
> 
> Current version successfully updated to HDP-2.2.2.0-2561
> ok
> test_get_ambari_server_api_base (TestServerUtils.TestServerUtils) ... ok
> test_checkServerReachability (TestSetupAgent.TestSetupAgent) ... ok
> test_configureAgent (TestSetupAgent.TestSetupAgent) ... ok
> test_findNearestAgentPackageVersion (TestSetupAgent.TestSetupAgent) ... ok
> test_getAvailableAgentPackageVersions (TestSetupAgent.TestSetupAgent) ... ok
> test_installAgent (TestSetupAgent.TestSetupAgent) ... ok
> test_isAgentPackageAlreadyInstalled (TestSetupAgent.TestSetupAgent) ... ok
> test_returned_optimal_version_is_default (TestSetupAgent.TestSetupAgent) ... ok
> test_returned_optimal_version_is_initial (TestSetupAgent.TestSetupAgent) ... ok
> test_returned_optimal_version_is_initial_on_ubuntu (TestSetupAgent.TestSetupAgent) ... ok
> test_returned_optimal_version_is_nearest_on_suse (TestSetupAgent.TestSetupAgent) ... bash: zypper: command not found
> sed: illegal option -- s
> usage: sed script [-Ealn] [-i extension] [file ...]
>        sed [-Ealn] [-i extension] [-e script] ... [-f script_file] ... [file ...]
> sed: illegal option -- r
> usage: sed script [-Ealn] [-i extension] [file ...]
>        sed [-Ealn] [-i extension] [-e script] ... [-f script_file] ... [file ...]
> ok
> test_returned_optimal_version_is_nearest_on_ubuntu (TestSetupAgent.TestSetupAgent) ... bash: apt-cache: command not found
> sed: illegal option -- s
> usage: sed script [-Ealn] [-i extension] [file ...]
>        sed [-Ealn] [-i extension] [-e script] ... [-f script_file] ... [file ...]
> ok
> test_setup_agent_main (TestSetupAgent.TestSetupAgent) ... ok
> test_stackAdvisorDefaultImpl (TestStackAdvisor.TestStackAdvisorInitialization) ... Traceback (most recent call last):
>   File "/Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/test/python/../../main/resources/scripts/stack_advisor.py", line 138, in instantiateStackAdvisor
>     with open(path, 'rb') as fp:
> IOError: [Errno 2] No such file or directory: '/Users/adiachenko/git/ambari-oss-mirror/ambari-server/src/main/resources/scripts/./../stacks/HDP1/2.0.6/services/stack_advisor.py'
> StackAdvisor implementation for stack HDP1, version 2.0.6 was not found
> Returning DefaultStackAdvisor implementation
> ok
> test_stackAdvisorLoadedForNotHDPStack (TestStackAdvisor.TestStackAdvisorInitialization) ... StackAdvisor implementation for stack XYZ, version 1.0.0 was loaded
> StackAdvisor implementation for stack XYZ, version 1.0.1 was loaded
> Returning XYZ101StackAdvisor implementation
> ok
> test_ParseOptions (TestUpgradeHelper.TestUpgradeHelper) ... ok
> test_add_services (TestUpgradeHelper.TestUpgradeHelper) ... ok
> test_backup_configs (TestUpgradeHelper.TestUpgradeHelper) ... ok
> test_coerce_tag (TestUpgradeHelper.TestUpgradeHelper) ... ok
> test_conditional_replace (TestUpgradeHelper.TestUpgradeHelper) ... ok
> test_configuration_diff_analyze (TestUpgradeHelper.TestUpgradeHelper) ... ok
> test_delete_mr (TestUpgradeHelper.TestUpgradeHelper) ... ok
> test_get_YN_input (TestUpgradeHelper.TestUpgradeHelper) ... ok
> test_get_choice_string_input (TestUpgradeHelper.TestUpgradeHelper) ... ok
> test_get_cluster_stackname (TestUpgradeHelper.TestUpgradeHelper) ... ok
> test_get_config_resp_all (TestUpgradeHelper.TestUpgradeHelper) ... ok
> test_get_mr1_mapping (TestUpgradeHelper.TestUpgradeHelper) ... ok
> test_get_ranger_xaaudit_hdfs_destination_directory (TestUpgradeHelper.TestUpgradeHelper) ... ok
> test_get_tez_history_url_base (TestUpgradeHelper.TestUpgradeHelper) ... ok
> test_get_zookeeper_quorum (TestUpgradeHelper.TestUpgradeHelper) ... ok
> test_has_component_in_stack_def (TestUpgradeHelper.TestUpgradeHelper) ... ok
> test_install_services (TestUpgradeHelper.TestUpgradeHelper) ... ok
> test_is_services_exists (TestUpgradeHelper.TestUpgradeHelper) ... ok
> test_override_tag (TestUpgradeHelper.TestUpgradeHelper) ... ok
> test_read_mapping (TestUpgradeHelper.TestUpgradeHelper) ... ok
> test_replace_tag (TestUpgradeHelper.TestUpgradeHelper) ... ok
> test_report_formatter (TestUpgradeHelper.TestUpgradeHelper) ... ok
> test_update_config (TestUpgradeHelper.TestUpgradeHelper) ... ok
> test_verify_configuration (TestUpgradeHelper.TestUpgradeHelper) ... ok
> test_write_mapping (TestUpgradeHelper.TestUpgradeHelper) ... ok
> test_check_exitcode (TestUtils.TestUtils) ... ok
> test_compare_versions (TestUtils.TestUtils) ... ok
> test_format_with_reload (TestUtils.TestUtils) ... ok
> test_get_postgre_running_status (TestUtils.TestUtils) ... ok
> test_get_symlink_path (TestUtils.TestUtils) ... ok
> test_get_ubuntu_pg_version (TestUtils.TestUtils) ... ok
> test_locate_file (TestUtils.TestUtils) ... ok
> test_looking_for_pid (TestUtils.TestUtils) ... ok
> test_pid_exists (TestUtils.TestUtils) ... ok
> test_save_main_pid_ex (TestUtils.TestUtils) ... ok
> test_wait_for_pid (TestUtils.TestUtils) ... ok
> test_check_directories (TestValidateConfigs.TestValidateConfigs) ... Error: Validation failed. Directory / can't be created!
> ok
> test_check_user_in_group (TestValidateConfigs.TestValidateConfigs) ... ok
> test_check_users (TestValidateConfigs.TestValidateConfigs) ... Error: Validation failed. root is not a member of wrong_group group and root account can't be created!
> Error: Validation failed. wrong_user is not a member of root group and wrong_user account can't be created!
> Error: Validation failed. wrong_user is not a member of wrong_group group and wrong_user account can't be created!
> ok
> test_flatten_dict (TestValidateConfigs.TestValidateConfigs) ... ok
> test_get_value (TestValidateConfigs.TestValidateConfigs) ... ok
> test_comparison (TestVersion.TestVersion) ... ok
> test_format (TestVersion.TestVersion) ... ok
> test_get_component_version (TestVersionSelectUtil.TestVersionSelectUtil) ... ok
> test_convert_yaml_array (TestYAMLUtils.TestYAMLUtils) ... ok
> 
> ----------------------------------------------------------------------
> Ran 250 tests in 6.729s
> 
> OK
> ----------------------------------------------------------------------
> Total run:844
> Total errors:0
> Total failures:0
> OK
> 
> 
> Thanks,
> 
> Oleksandr Diachenko
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message