ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hari Sekhon (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AMBARI-14102) No metrics returned by Ambari REST API
Date Fri, 27 Nov 2015 15:21:10 GMT
Hari Sekhon created AMBARI-14102:
------------------------------------

             Summary: No metrics returned by Ambari REST API
                 Key: AMBARI-14102
                 URL: https://issues.apache.org/jira/browse/AMBARI-14102
             Project: Ambari
          Issue Type: Bug
          Components: ambari-server
    Affects Versions: 2.1.0
         Environment: HDP 2.2 + HDP 2.3 clusters
            Reporter: Hari Sekhon


The REST API doesn't seem to return metrics for various clusters:
{code}
curl -u admin:<password> 'http://<hostname>:8080/api/v1/clusters/myCluster?fields=metrics/load'
{
  "href" : "http://<hostname>:8080/api/v1/clusters/myCluster?fields=metrics/load",
  "Clusters" : {
    "cluster_name" : "myCluster",
    "version" : "HDP-2.2"
  }
}
{code}
That example is taken straight from the documentation at:

https://cwiki.apache.org/confluence/display/AMBARI/Ambari+Metrics+API+specification

Adding the time range to the end doesn't seem to help even when updating the epoch end range
for current timestamp.
{code}[1430844925,1448633316,15]&_=1448633316000{code}
The Metrics collector is definitely running and has been for some time.

I've even tried this on 2 different clusters, one HDP 2.2, one HDP 2.3 as well as the HDP
2.3 sandbox with the same result. The Ambari UI shows the graph for average load under Ambari
metrics service summary page so the metric is definitely collected but the REST API still
returns no results. Is this a bug or am I missing something else?



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message