ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-14002) Some hadoop-env settings do not show up on the UI
Date Sat, 21 Nov 2015 01:06:11 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-14002?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15019231#comment-15019231
] 

Hudson commented on AMBARI-14002:
---------------------------------

FAILURE: Integrated in Ambari-trunk-Commit #3880 (See [https://builds.apache.org/job/Ambari-trunk-Commit/3880/])
AMBARI-14002. Some hadoop-env settings do not show up on the UI. (jaimin: [http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=aa1389dede76127707de92aca3fad3c0808390c9])
* ambari-server/src/main/resources/common-services/HDFS/2.1.0.2.0/configuration/hadoop-env.xml
* ambari-server/src/main/resources/common-services/HBASE/0.96.0.2.0/configuration/hbase-env.xml
* ambari-server/src/main/resources/common-services/KNOX/0.5.0.2.2/configuration/knox-env.xml
* ambari-server/src/main/resources/common-services/STORM/0.9.1.2.1/configuration/storm-env.xml
* ambari-server/src/main/resources/common-services/ACCUMULO/1.6.1.2.2.0/configuration/accumulo-env.xml
* ambari-server/src/main/resources/common-services/ZOOKEEPER/3.4.5.2.0/configuration/zookeeper-env.xml


> Some hadoop-env settings do not show up on the UI
> -------------------------------------------------
>
>                 Key: AMBARI-14002
>                 URL: https://issues.apache.org/jira/browse/AMBARI-14002
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server, stacks
>    Affects Versions: 2.0.0
>            Reporter: Jaimin D Jetly
>            Assignee: Jaimin D Jetly
>            Priority: Critical
>             Fix For: 2.1.3
>
>         Attachments: AMBARI-14002_branch.2.1.patch, AMBARI-14002_trunk.patch
>
>
> This is what I get using the API:
> Cluster desired_config:
> {code}
> http://172.22.71.69:8080/api/v1/clusters/cl1
> ...
> "hadoop-env" : {
>         "tag" : "version1447847498130",
>         "user" : "admin",
>         "version" : 5
>       }
> {code}
> Config with that version:
> {code}
> {
>   "href" : "http://172.22.71.69:8080/api/v1/clusters/cl1/configurations?type=hadoop-env&tag=version1447847498130",
>   "items" : [
>     {
>       "href" : "http://172.22.71.69:8080/api/v1/clusters/cl1/configurations?type=hadoop-env&tag=version1447847498130",
>       "tag" : "version1447847498130",
>       "type" : "hadoop-env",
>       "version" : 5,
>       "Config" : {
>         "cluster_name" : "cl1",
>         "stack_id" : "HDP-2.3"
>       },
>       "properties" : {
>         "content" : "...",
>         "dtnode_heapsize" : "1024m",
>         "hadoop_heapsize" : "1132",
>         "hadoop_pid_dir_prefix" : "/var/run/hadoop",
>         "hadoop_root_logger" : "INFO,RFA",
>         "hdfs_log_dir_prefix" : "/grid/0/log/hadoop",
>         "hdfs_principal_name" : "hdfs-cl1@EXAMPLE.COM",
>         "hdfs_user" : "hdfs",
>         "hdfs_user_keytab" : "/etc/security/keytabs/hdfs.headless.keytab",
>         "hdfs_user_nofile_limit" : "128000",
>         "hdfs_user_nproc_limit" : "65536",
>         "keyserver_host" : " ",
>         "keyserver_port" : "",
>         "namenode_heapsize" : "1024m",
>         "namenode_opt_maxnewsize" : "132m",
>         "namenode_opt_maxpermsize" : "256m",
>         "namenode_opt_newsize" : "128m",
>         "namenode_opt_permsize" : "128m",
>         "nfsgateway_heapsize" : "1024",
>         "proxyuser_group" : "users"
>       }
>     }
>   ]
> }
> {code}
> searched for "hdfs_" and "hdfs_user_" and did not see hdfs_user_keytab or hdfs_principal_name
on ui



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message