ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-13912) Ranger Audit Store Configured With Postgres Prevents NameNode From Starting
Date Tue, 17 Nov 2015 21:55:11 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-13912?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15009616#comment-15009616
] 

Hudson commented on AMBARI-13912:
---------------------------------

FAILURE: Integrated in Ambari-trunk-Commit #3854 (See [https://builds.apache.org/job/Ambari-trunk-Commit/3854/])
AMBARI-13912 - Ranger Audit Store Configured With Postgres Prevents (jhurley: [http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=e32482997640a03d5dc7b4e6d03d1e317d95d20e])
* ambari-server/src/main/resources/common-services/HDFS/2.1.0.2.0/configuration/hadoop-env.xml
* ambari-server/src/main/resources/stacks/HDP/2.2/services/HDFS/configuration/hadoop-env.xml
* ambari-server/src/main/resources/stacks/HDP/2.3/services/HDFS/configuration/hadoop-env.xml


> Ranger Audit Store Configured With Postgres Prevents NameNode From Starting
> ---------------------------------------------------------------------------
>
>                 Key: AMBARI-13912
>                 URL: https://issues.apache.org/jira/browse/AMBARI-13912
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>    Affects Versions: 2.1.0
>            Reporter: Jonathan Hurley
>            Assignee: Jonathan Hurley
>            Priority: Critical
>             Fix For: 2.1.3
>
>         Attachments: AMBARI-13912.patch
>
>
> When Ranger is configured to use PostgresSQL, the HDFS NameNode will not startup correctly,
complaining about missing class drivers. The root of the problem is that {{hadoop-env.sh}}
adds JDBC drivers for Oracle and MySQL only.
> {code}
> # Add libraries required by oracle connector
> for jarFile in `ls /usr/share/java/*ojdbc* 2>/dev/null`
> do
>   JAVA_JDBC_LIBS=${JAVA_JDBC_LIBS}:$jarFile
> done
> {code}
> Ranger needs the following driver support:
> ||DB Type||JDBC Driver JAR Name||Minimum Supported Version||Driver Reference Link
> |Mysql|mysql-connector-java.jar|MySQL 5.6|[Link|http://dev.mysql.com/doc/connector-j/en/connector-j-versions.html]
> |Oracle|ojdbc6.jar or ojdbc7.jar|Oracle 11g|[Link|http://www.oracle.com/technetwork/database/features/jdbc/index-091264.html]
> |Postgres|postgresql.jar|Postgres 8.4|[Link|https://jdbc.postgresql.org/documentation/84/setup.html#build]
> |MS-SQLServer|sqljdbc4.jar|SQL Server 12|[Link|https://msdn.microsoft.com/en-us/sqlserver/aa937724.aspx]



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message