ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-13909) RU: Flume restart failed during downgrade
Date Tue, 17 Nov 2015 18:02:10 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-13909?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15009145#comment-15009145
] 

Hudson commented on AMBARI-13909:
---------------------------------

SUCCESS: Integrated in Ambari-trunk-Commit #3852 (See [https://builds.apache.org/job/Ambari-trunk-Commit/3852/])
AMBARI-13909. RU: Flume restart failed during downgrade (dlysnichenko) (dlysnichenko: [http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=e89233e7d3044169273d6ddd3ae79290190b6c55])
* ambari-server/src/main/resources/stacks/HDP/2.0.6/hooks/before-ANY/scripts/params.py


> RU: Flume restart failed during downgrade
> -----------------------------------------
>
>                 Key: AMBARI-13909
>                 URL: https://issues.apache.org/jira/browse/AMBARI-13909
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>    Affects Versions: 2.1.3
>            Reporter: Dmitry Lysnichenko
>            Assignee: Dmitry Lysnichenko
>             Fix For: 2.1.3
>
>         Attachments: AMBARI-13909.patch
>
>
> During Downgrade Flume restart failed
> No live cluster.
> {code}
> Traceback (most recent call last):
> File \"/var/lib/ambari-agent/cache/stacks/HDP/2.0.6/hooks/before-ANY/scripts/hook.py\",
line 35, in <module>
> BeforeAnyHook().execute()
> File \"/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py\",
line 218, in execute
> method(env)
> File \"/var/lib/ambari-agent/cache/stacks/HDP/2.0.6/hooks/before-ANY/scripts/hook.py\",
line 29, in hook
> setup_users()
> File \"/var/lib/ambari-agent/cache/stacks/HDP/2.0.6/hooks/before-ANY/scripts/shared_initialization.py\",
line 70, in setup_users
> create_tez_am_view_acls()
> File \"/var/lib/ambari-agent/cache/stacks/HDP/2.0.6/hooks/before-ANY/scripts/shared_initialization.py\",
line 94, in create_tez_am_view_acls
> if not params.tez_am_view_acls.startswith(\"*\"):
> File \"/usr/lib/python2.6/site-packages/resource_management/libraries/script/config_dictionary.py\",
line 81, in __getattr__
> raise Fail(\"Configuration parameter '\" + self.name + \"' was not found in configurations
dictionary!\")
> resource_management.core.exceptions.Fail: Configuration parameter 'tez.am.view-acls'
was not found in configurations dictionary!
> Error: Error: Unable to run the custom hook script ['/usr/bin/python2.6', '/var/lib/ambari-agent/cache/stacks/HDP/2.0.6/hooks/before-ANY/scripts/hook.py',
'ANY', '/var/lib/ambari-agent/data/command-2302.json', '/var/lib/ambari-agent/cache/stacks/HDP/2.0.6/hooks/before-ANY',
'/var/lib/ambari-agent/data/structured-out-2302.json', 'INFO', '/var/lib/ambari-agent/tmp']Error:
Error: Unable to run the custom hook script ['/usr/bin/python2.6', '/var/lib/ambari-agent/cache/stacks/HDP/2.0.6/hooks/before-START/scripts/hook.py',
'START', '/var/lib/ambari-agent/data/command-2302.json', '/var/lib/ambari-agent/cache/stacks/HDP/2.0.6/hooks/before-START',
'/var/lib/ambari-agent/data/structured-out-2302.json', 'INFO', '/var/lib/ambari-agent/tmp']
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message