ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dmytro Sen (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AMBARI-13817) HDP-2.3 does not have the ability to set heapsize for hive components
Date Tue, 10 Nov 2015 16:22:11 GMT
Dmytro Sen created AMBARI-13817:
-----------------------------------

             Summary: HDP-2.3 does not have the ability to set heapsize for hive components
                 Key: AMBARI-13817
                 URL: https://issues.apache.org/jira/browse/AMBARI-13817
             Project: Ambari
          Issue Type: Bug
          Components: stacks
    Affects Versions: 2.1.2
            Reporter: Dmytro Sen
            Assignee: Dmytro Sen
            Priority: Critical
             Fix For: 2.1.3


It could be as simple as making sure that ambari-server/src/main/resources/stacks/HDP/2.3/services/HIVE/configuration/hive-env.xml
has the same changes as in the 2.2. version (ambari-server/src/main/resources/stacks/HDP/2.2/services/HIVE/configuration/hive-env.xml).

Specifically the missing parts are:
{code}
export SERVICE=$SERVICE
if [ "$SERVICE" = "metastore" ]; then
  export HADOOP_HEAPSIZE="{{hive_metastore_heapsize}}"
else
  export HADOOP_HEAPSIZE="{{hive_heapsize}}"
fi
{code}




--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message